Автор Тема: Ошибка установки VSCode на Simply Linux  (Прочитано 231 раз)

Оффлайн shasoft

  • Начинающий
  • *
  • Сообщений: 5
Версия 10.1
Режим загруженного ядра 5.10.88-std-def-alt1

Устанавливаю через ''Установка сторонних приложений'. В результате получаю ошибку установки

Оффлайн N0rbert

  • Давно тут
  • **
  • Сообщений: 133
Re: Ошибка установки VSCode на Simply Linux
« Ответ #1 : 19.11.2022 17:18:22 »
Попробуйте установить из терминала командой

epm play code

Если получите при этом вывод

Следующие пакеты имеют неудовлетворенные зависимости:
  code: Требует: /usr/share/code/bin/code но пакет не может быть установлен
E: Извините, `битые' пакеты

то это известная ошибка - см. https://bugzilla.altlinux.org/44229 .

Если вы спешите, то можете установить более новую версию пакета из Сизифа с помощью команды

sudo apt-get install http://mirror.yandex.ru/altlinux/Sisyphus/noarch/RPMS.classic/eepm-3.27.3-alt1.noarch.rpm

и затем установить Code.
« Последнее редактирование: 19.11.2022 17:47:35 от N0rbert »

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 517
    • Домашняя страница
    • Email
Re: Ошибка установки VSCode на Simply Linux
« Ответ #2 : 19.11.2022 18:30:14 »
Автообновление epm – epm ei
Андрей Черепанов (cas@)

Оффлайн hasculdr

  • Завсегдатай
  • *
  • Сообщений: 654
Re: Ошибка установки VSCode на Simply Linux
« Ответ #3 : 19.11.2022 19:25:01 »
Нужен именно vs code? В репах есть codium:
$ apt-cache search codium
codium - Visual Studio Code without MS branding/telemetry/licensing
$ rpm -qa | grep codium
codium-1.72.1.22284-alt1.x86_64

Оффлайн N0rbert

  • Давно тут
  • **
  • Сообщений: 133
Re: Ошибка установки VSCode на Simply Linux
« Ответ #4 : 19.11.2022 19:32:21 »
epm ei

Спасибо, работает, но не очень очевидно. Запишу в свои заметки.
В epm --help эта опция описана, а в wiki упоминается только для Ассистента и Игр. В Etersoft Wiki опция упомянута только для универсального скрипта.

Оффлайн shasoft

  • Начинающий
  • *
  • Сообщений: 5
Re: Ошибка установки VSCode на Simply Linux
« Ответ #5 : 19.11.2022 21:28:38 »
Нужен именно vs code? В репах есть codium:
Сам я новичек в linux. Так что ориентируюсь на эту статью. А в ней VSCode.
Если плагины поддерживаются те же самые, то в общем то разницы нет.

Оффлайн shasoft

  • Начинающий
  • *
  • Сообщений: 5
Re: Ошибка установки VSCode на Simply Linux
« Ответ #6 : 19.11.2022 21:43:46 »
VSCode установлен. Спасибо за советы.
Для чайников типа меня:

Запускаем терминал. Через кнопку пуск "Эмулятор терминала"

Переходим в режим root с помощью командыsu и вводим пароль root.

Если этого пароля нет (у меня я так понял его не было потому что выдавали ошибку аутентификации), то его можно установить через команду sudo passwd root
opt-get install eepm
epm play code. Если ошибка "Извините, `битые' пакеты", то сначала запустить командуepm ei
А потом уже
opt-get install eepm


Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 517
    • Домашняя страница
    • Email
Re: Ошибка установки VSCode на Simply Linux
« Ответ #7 : 20.11.2022 09:45:23 »
epm ei

Спасибо, работает, но не очень очевидно. Запишу в свои заметки.
В epm --help эта опция описана, а в wiki упоминается только для Ассистента и Игр. В Etersoft Wiki опция упомянута только для универсального скрипта.
Потому что это хак. А новую версию из-за регрессий не пропускает отдел тестирования.
Андрей Черепанов (cas@)