Автор Тема: вопрос по работе встроенной звуковой карте  (Прочитано 267 раз)

Оффлайн vlomar

  • Начинающий
  • *
  • Сообщений: 11
Приветствую, уважаемые форумчане!
Позвольте поделиться своей ситуацией: на неопознанном китайском ноутбуке установил SLinux 10.0. Сначала не смог подключиться к интернету...
Проблема решилась покупкой USB модема, причем скорость оказалась на порядок выше,чем на родной встроенной карте на предустановленной Win10.Теперь вторая проблема-нет звука, хотя на Win10-был.
Что имеется: встроенная звуковая карта, которая определяется как "HDA- Intel-PCH", которая работает только c HDMI в формате digital. В Pulseaudio в разделах "Проигрывание" и "Устройства вывода" индикаторы звука реагируют, а в разделе "Конфигурация" -множество различных выходов HDMI, но возле каждого расположены две скобки (не подключено)(не доступно). Вот я и прошу Вашей помощи в таких вопросах:
1)можно ли мне слушать звук в динамиках ноутбука и проводных наушниках при таких параметрах выхода?
2) как их подключить?
С уважением!

Онлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 31 003
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Что выдаёт
# lspci -kv | grep -A4 -i audio

Оффлайн Александр Ерещенко

  • Завсегдатай
  • *
  • Сообщений: 839
Это случайно не аналогично вот этому: https://forum.altlinux.org/index.php?topic=45896.msg368269#msg368269

В последнее время на форуме уже повторяться начали вопросы по поводу этих звуковух - видимо, массово используются в недорогих ноутах

Оффлайн vlomar

  • Начинающий
  • *
  • Сообщений: 11
root@jdowgkaa7dnlb ~]# lspci -kv | grep -A4 -i audio
00:0e.0 Audio device: Intel Corporation Celeron N3350/Pentium N4200/Atom E3900 Series Audio Cluster (rev 0b)
   Subsystem: Realtek Semiconductor Co., Ltd. Device 10fc
   Flags: bus master, fast devsel, latency 32, IRQ 124
   Memory at 92118000 (64-bit, non-prefetchable) [size=16K]
   Memory at 92000000 (64-bit, non-prefetchable) [size=1M]

Оффлайн Aleksand

  • Начинающий
  • *
  • Сообщений: 15
Это случайно не аналогично вот этому:
Вероятнее всего так оно и есть.
Позавчера новости читал. В ядро 5.18 официально добавлена поддержка: ESSX8336.

Возился с двумя новыми ноутбуками от Депо. Пришли без ОС, но с лицензиями на Альт образование 9.
Установил Альт образование 9.2. Звука не было, и все было точно так же как описал ТС.
Общался с техподдержкой Депо, прислали ядро 5.12.6-cnl. Звук появился.

Оффлайн vlomar

  • Начинающий
  • *
  • Сообщений: 11
Приветствую всех! По-поводу заметки Александ...
Так Вы считаете, что ядро 5.18 с поддержкой ESSX8336 или ядро 5.12.6-cnl могут решить проблему со звуком на ноутбуке? Интересно, а как их можно получить для опробирования?
С уважением...

Оффлайн vlomar

  • Начинающий
  • *
  • Сообщений: 11
Приветствую!
Жаль, что нам так и не удалось оживить звуковую карту... если вдруг у кого-то появятся свежие мысли-пишите, буду весьма благодарен!
С уважением.

Оффлайн trs

  • Давно тут
  • **
  • Сообщений: 194
ядро 5.18 с поддержкой ESSX8336 или ядро 5.12.6-cnl могут решить проблему со звуком на ноутбуке?
В общем случае новое ядро поддерживает новое оборудование лучше. В частном случае, у Вас кодек Realtek, а не ESS. Точнее сказать не могу - команда lspci выводит информацию не о кодеках, а о PCI устройствах, к которым кодек может быть "припаян" (а может он быть подключён и к SDIO). Существует команда alsa-info.sh - вот она сохраняет больше данных в файл. Помимо ядра на звук влияют другие вещи - прошивки контролеров (firmware) и alsa. Посмотрите решение https://forum.altlinux.org/index.php?topic=45896.msg368269#msg368269 где помимо ядра устанавливаются дополнительные пакеты.

Второй момент - у Вас не новый Cannon Point, как по ссылке, а Celeron N3350 - это модель 2016-го года. Есть вероятность, что звук на ноубуке заработает наоборот на старых ядрах. Intel начала менять в звуковой подсистеме формат firmware, переходить на openfirmware (см. "sof" по ссылке), а при изменениях нередко что-то ломается. Так у меня на планшете сломался звук когда я пробовал обновить ядро с 5.10 на какое-то другое.