Автор Тема: LSI SAS2116  (Прочитано 4008 раз)

Оффлайн berkut_174

  • Мастер
  • ***
  • Сообщений: 7 009
    • Email
LSI SAS2116
« : 11.02.2021 10:12:28 »
Всем привет!
Как узнать, что поддержка точно есть в модуле ядра mpt2sas ?
См. modinfo mpt2sas, но точного подтверждения не вижу.
Спасибо.
Сноси Винду, переходи на Линукс ! :)

Оффлайн klark973

  • Давно тут
  • **
  • Сообщений: 653
  • Неспящий саппорт
Re: LSI SAS2116
« Ответ #1 : 11.02.2021 11:03:34 »
По LKDDb быстрее всего, в первую очередь нужен вывод lspci -nnk
To moan or to solve -- that is the question!

Оффлайн berkut_174

  • Мастер
  • ***
  • Сообщений: 7 009
    • Email
Re: LSI SAS2116
« Ответ #2 : 11.02.2021 16:04:13 »
По LKDDb быстрее всего, в первую очередь нужен вывод lspci -nnk
так у меня нет этой платы сейчас, я вот и хочу понять, будет ли она работать вообще
Сноси Винду, переходи на Линукс ! :)

Оффлайн klark973

  • Давно тут
  • **
  • Сообщений: 653
  • Неспящий саппорт
Re: LSI SAS2116
« Ответ #3 : 11.02.2021 16:41:58 »
Ну, судя по https://pci-ids.ucw.cz/v2.2/pci.ids и https://cateee.net/lkddb/web-lkddb/SCSI_MPT3SAS.html вижу всего две PCI ID (1000:0064 и 1000:0065), обе полноценно поддерживаются с ядра 4.19). В Raw-data там и ссылки на конкретные места в исходниках. Но это пальцем в небо, т.к. по факту у платы с тем же маркетинговым названием может оказаться совсем иной PCI ID, вот тогда "сюрприз будет".
To moan or to solve -- that is the question!

Оффлайн berkut_174

  • Мастер
  • ***
  • Сообщений: 7 009
    • Email
Re: LSI SAS2116
« Ответ #4 : 11.02.2021 20:54:38 »
https://cateee.net/lkddb/web-lkddb/SCSI_MPT3SAS.html
наверно имелось ввиду mpt2sas ?
и там вроде пишут
found in Linux kernels: 2.6.30–2.6.39, 3.0–3.19, 4.0–4.3
направление я понял, попробую как-то уточнить у продавца... так как не хотелось бы получить нерабочую железку
вообще хотел такую взять https://www.nix.ru/autocatalog/controllers_3ware/_116553.html
Сноси Винду, переходи на Линукс ! :)

Оффлайн berkut_174

  • Мастер
  • ***
  • Сообщений: 7 009
    • Email
Re: LSI SAS2116
« Ответ #5 : 11.02.2021 21:42:55 »
3.0–3.19
да, я вижу у себя в modinfo поддержку даже на ядре 3.14.79-std-def-alt0.M70P.2 из p7:
alias:          pci:v00001000d00000065sv*sd*bc*sc*i*
alias:          pci:v00001000d00000064sv*sd*bc*sc*i*
Сноси Винду, переходи на Линукс ! :)

Оффлайн klark973

  • Давно тут
  • **
  • Сообщений: 653
  • Неспящий саппорт
Re: LSI SAS2116
« Ответ #6 : 12.02.2021 09:04:12 »
наверно имелось ввиду mpt2sas ?
Нет, читайте внимательно про обе: https://github.com/torvalds/linux/blob/master/drivers/scsi/mpt3sas/Kconfig

и там вроде пишут:  Linux kernels: 2.6.30
А оно точно вам надо?

направление я понял, попробую как-то уточнить у продавца... так как не хотелось бы получить нерабочую железку
Главное получить PCI ID, который характеризует поддержку однозначно, в отличие от маркетинга.
To moan or to solve -- that is the question!

Оффлайн berkut_174

  • Мастер
  • ***
  • Сообщений: 7 009
    • Email
Re: LSI SAS2116
« Ответ #7 : 12.02.2021 18:58:20 »
читайте
ничего не понял, кроме:
Цитировать
Dummy config option for backwards compatibility: configure the MPT3SAS driver instead.

А оно точно вам надо?
в данном случае конечно же нет :)

PCI ID
как бы его ещё получить... в моей ситуации продавец сообщил, что не может предоставить эти данные
Сноси Винду, переходи на Линукс ! :)

Оффлайн klark973

  • Давно тут
  • **
  • Сообщений: 653
  • Неспящий саппорт
Re: LSI SAS2116
« Ответ #8 : 13.02.2021 03:26:34 »
Продавцы серверного оборудования обычно дают время на тестирование.
To moan or to solve -- that is the question!