Автор Тема: NVid_Workst 8.1 (june) 64-разрядный_  (Прочитано 1019 раз)

ms1984

  • Гость
NVid_Workst 8.1 (june) 64-разрядный_
« : 12.02.2018 15:05:58 »
Доброго времени суток.
Поставил таки чудо, но увы драйвера поднять не смог.
Прошу помощи.
руководствовался по старинке - https://www.altlinux.org/Nvidia_optimus,_%D0%BD%D0%B0%D1%81%D1%82%D1%80%D0%BE%D0%B9%D0%BA%D0%B0_%D0%B8_%D0%B7%D0%B0%D0%BF%D1%83%D1%81%D0%BA_bumblebee
 Железо- две видеокарты одна интел вторая нвидия. прикладываю код. Заранее хочу отметить система обновлена программно как положено без косяков включая ядро.
core-i7 ~ # apt-get dist-upgrade
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Подсчет обновлений... Завершено
0 будет обновлено, 0 новых установлено, 0 пакетов будет удалено и 0 не будет обновлено.
core ~ # update-kernel
Running kernel version: kernel-image-std-def-1:4.9.80-alt0.M80P.1
Checking for available kernel packages...
Latest kernel std-def-1:4.9.80-alt0.M80P.1 is already running on your system.
No upgrade is needed. Use -f for force.
core ~ # apt-get install kernel-modules-nvidia-std-def
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Выбрано kernel-modules-nvidia-std-def#384.111-alt2.264528.0.M80P.1 для 'kernel-modules-nvidia-std-def'
Последняя версия kernel-modules-nvidia-std-def#384.111-alt2.264528.0.M80P.1 уже установлена.
0 будет обновлено, 0 новых установлено, 0 пакетов будет удалено и 0 не будет обновлено.
core ~ # apt-get install kernel-modules-bbswitch-std-def bumblebee
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Выбрано kernel-modules-bbswitch-std-def#0.8-alt1.264528.0.M80P.1 для 'kernel-modules-bbswitch-std-def'
Последняя версия kernel-modules-bbswitch-std-def#0.8-alt1.264528.0.M80P.1 уже установлена.
Последняя версия bumblebee уже установлена.
0 будет обновлено, 0 новых установлено, 0 пакетов будет удалено и 0 не будет обновлено.
core ~ #

0000000@core ~ $ lspci
00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor DRAM Controller (rev 06)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor PCI Express x16 Controller (rev 06)
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
00:03.0 Audio device: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller (rev 06)
00:14.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB xHCI (rev 05)
00:16.0 Communication controller: Intel Corporation 8 Series/C220 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #1 (rev d5)
00:1c.2 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #3 (rev d5)
00:1c.3 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #4 (rev d5)
00:1d.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation HM87 Express LPC Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 8 Series/C220 Series Chipset Family 6-port SATA Controller 1 [AHCI mode] (rev 05)
00:1f.3 SMBus: Intel Corporation 8 Series/C220 Series Chipset Family SMBus Controller (rev 05)
01:00.0 3D controller: NVIDIA Corporation GM107M [GeForce GTX 860M] (rev ff)
03:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter
04:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTL8411B PCI Express Card Reader (rev 01)
04:00.1 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 12)
00000000@core ~ $


6) Создадим файл (от рута, можно через mc) /etc/X11/xorg.conf следующего содержания с указанием ранее полученного BusID:   - создал положил.

Перегружаю проверяю:
00000000@core ~ $ optirun glxinfo | grep OpenGL
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
Error: couldn't find RGB GLX visual or fbconfig
Error: couldn't find RGB GLX visual or fbconfig
[VGL] ERROR: in glXGetConfig--
[VGL]    341: Could not obtain Pbuffer-capable RGB visual on the server
0000000@core ~ $

Буду признателен за содействие и помощь. Куда дальше рыть и искать не знаю.спасибо.

ms1984

  • Гость
Re: NVid_Workst 8.1 (june) 64-разрядный_
« Ответ #1 : 12.02.2018 15:18:06 »
И если не сложно еще вопрос - поставил телеграмм десктоп через синаптик из репозиториев. значки телеграмма появились, а вот софтина не запускается...

000000@000000 ~ $ Telegram

(Telegram:2215): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1594:13: not a number

(Telegram:2215): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1594:13: Expected a string.

(Telegram:2215): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1977:11: not a number

(Telegram:2215): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1977:11: Expected a string.

(Telegram:2215): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:2527:11: not a number

(Telegram:2215): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:2527:11: Expected a string.

(Telegram:2215): Gtk-WARNING **: Theme parsing error: applications.css:21:0: Expected a valid selector

(Telegram:2215): GLib-GObject-WARNING **: cannot register existing type 'GdkDisplayManager'

(Telegram:2215): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed

(Telegram:2215): GLib-GObject-CRITICAL **: g_object_new: assertion 'G_TYPE_IS_OBJECT (object_type)' failed

(Telegram:2215): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(Telegram:2215): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(Telegram:2215): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(Telegram:2215): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(Telegram:2215): GLib-GObject-WARNING **: cannot register existing type 'GdkDisplay'

(Telegram:2215): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed

(Telegram:2215): GLib-GObject-CRITICAL **: g_type_register_static: assertion 'parent_type > 0' failed

(Telegram:2215): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed

(Telegram:2215): GLib-GObject-CRITICAL **: g_object_new: assertion 'G_TYPE_IS_OBJECT (object_type)' failed
Ошибка сегментирования
000000@000000 ~ $

ms1984

  • Гость
Re: NVid_Workst 8.1 (june) 64-разрядный_
« Ответ #2 : 13.02.2018 05:41:59 »
И если не сложно еще вопрос - поставил телеграмм десктоп через синаптик из репозиториев. значки телеграмма появились, а вот софтина не запускается...

000000@000000 ~ $ Telegram

(Telegram:2215): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1594:13: not a number

(Telegram:2215): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1594:13: Expected a string.

(Telegram:2215): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1977:11: not a number

(Telegram:2215): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1977:11: Expected a string.

(Telegram:2215): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:2527:11: not a number

(Telegram:2215): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:2527:11: Expected a string.

(Telegram:2215): Gtk-WARNING **: Theme parsing error: applications.css:21:0: Expected a valid selector

(Telegram:2215): GLib-GObject-WARNING **: cannot register existing type 'GdkDisplayManager'

(Telegram:2215): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed

(Telegram:2215): GLib-GObject-CRITICAL **: g_object_new: assertion 'G_TYPE_IS_OBJECT (object_type)' failed

(Telegram:2215): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(Telegram:2215): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(Telegram:2215): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(Telegram:2215): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(Telegram:2215): GLib-GObject-WARNING **: cannot register existing type 'GdkDisplay'

(Telegram:2215): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed

(Telegram:2215): GLib-GObject-CRITICAL **: g_type_register_static: assertion 'parent_type > 0' failed

(Telegram:2215): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed

(Telegram:2215): GLib-GObject-CRITICAL **: g_object_new: assertion 'G_TYPE_IS_OBJECT (object_type)' failed
Ошибка сегментирования
000000@000000 ~ $

С телеграм разобрался- виноват не посмотрел на вики- https://www.altlinux.org/Telegram  починился работает.
Открыт пока вопрос по дровам.

ms1984

  • Гость
Re: NVid_Workst 8.1 (june) 64-разрядный_
« Ответ #3 : 13.02.2018 06:09:53 »
Плиз... помогите.... все делаю по инструкции, результат нулевой....  сорян - примус надо было установить. все завелось, но работает собака через видео интеловское, ищу как переключить на нвидиевскую надо было доустановить - Для нормальной работы 32-х разрядных приложений и игр на 64-х разрядной системе через primus должны быть установлены следующие пакеты: i586-primus,
Тема решена!Спс. но хочу сказать, что командой греп один фиг выплевывает плохие картинки:
~ $ optirun glxinfo | grep OpenGL
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
Error: couldn't find RGB GLX visual or fbconfig
Error: couldn't find RGB GLX visual or fbconfig
[VGL] ERROR: in glXGetConfig--
[VGL]    341: Could not obtain Pbuffer-capable RGB visual on the server
 ~ $

« Последнее редактирование: 13.02.2018 07:47:06 от ms1984 »