Автор Тема: libpq-dev на altserver10  (Прочитано 871 раз)

Оффлайн systemspirit

  • Начинающий
  • *
  • Сообщений: 2
libpq-dev на altserver10
« : 17.02.2023 16:45:35 »
Добрый день.

Есть веб сервер, развернутый на altserver10, в качестве cgi у него используется python3 через апач с помощью Options +ExecCGI.

этому питону, необходимо подключаться к postgres sql серверу
для этого у него имеются зависимости
psycopg2==2.9.3
psycopg2-binary==2.9.3

данные зависимости нельзя установить через pip, если на сервере не установлен пакет libpq-dev

сам pgsql ставили с репозитория postgrespro.ru

подскажите пож как поставить данный пакет на altserver10, тк apt-get instal libpq-dev пишет Невозможно найти пакет

подключенные sources.list

rpm [p10] http://ftp.altlinux.org/pub/distributions/ALTLinux p10/branch/x86_64 classic
rpm [p10] http://ftp.altlinux.org/pub/distributions/ALTLinux p10/branch/noarch classic

rpm [p10] http://mirror.yandex.ru/altlinux p10/branch/x86_64 classic
rpm [p10] http://mirror.yandex.ru/altlinux p10/branch/x86_64-i586 classic
rpm [p10] http://mirror.yandex.ru/altlinux p10/branch/noarch classic



Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 32 303
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Re: libpq-dev на altserver10
« Ответ #1 : 17.02.2023 17:11:48 »
В альт не бывает dev , в альте есть только devel.
dev - это в Дебиановской ветке дистрибутивов принято так называть девелоперские пакеты

Оффлайн systemspirit

  • Начинающий
  • *
  • Сообщений: 2
Re: libpq-dev на altserver10
« Ответ #2 : 17.02.2023 17:52:57 »
спасибо