Автор Тема: Установка УТМ ЕГАИС на Альт Рабочую станцию 10.1  (Прочитано 764 раз)

Оффлайн AsaThorr

  • Начинающий
  • *
  • Сообщений: 5
Добрый день! Провожу тесты по переводу кассы с Windows на ОС Linux. Выбор пал на Альт (хочется нашего =)) Все для работы кассы установил и работает нормально. Осталось поставить УТМ ЕГАИС. У них на сайте только deb-пакет. И ничего путнего в инете не нашел для установки УТМ на Альт Линукс, есть инструкции только для Debian И Ubuntu. Может кто-нибудь подсказать как это сделать на Альте?

Оффлайн NickM

  • Завсегдатай
  • *
  • Сообщений: 907

Оффлайн AsaThorr

  • Начинающий
  • *
  • Сообщений: 5
Попробовал установить с помощью epm. В итоге выдало так текст

Выбрано u-trans для '/var/tmp/tmp.hW0SoTGprG/u-trans-4.2.0-alt1.repacked.with.epm.2538.x86_64.rpm'
Некоторые пакеты установить невозможно. Это может означать, что Вы
потребовали невозможного, либо пользуетесь нестабильным репозиторием.
Часть необходимых пакетов либо ещё не создана, либо была удалена
из каталога 'Входящие'.

Так как для выполнения Вашего запроса достаточно одной операции, то
скорее всего этот пакет просто невозможно установить. Сообщите, пожалуйста,
об этом как о найденной ошибке в пакете.
Эти сведения могут помочь найти выход из ситуации:

Следующие пакеты имеют неудовлетворенные зависимости:
  u-trans: Требует: /lib/ld-linux.so.2(GLIBC_2.3) но пакет не может быть установлен
           Требует: /lib/libc.so.6(GLIBC_2.0) но пакет не может быть установлен
           Требует: /lib/libc.so.6(GLIBC_2.1) но пакет не может быть установлен
           Требует: /lib/libc.so.6(GLIBC_2.1.2) но пакет не может быть установлен
           Требует: /lib/libc.so.6(GLIBC_2.1.3) но пакет не может быть установлен
           Требует: /lib/libc.so.6(GLIBC_2.11) но пакет не может быть установлен
           Требует: /lib/libc.so.6(GLIBC_2.2) но пакет не может быть установлен
           Требует: /lib/libc.so.6(GLIBC_2.2.4) но пакет не может быть установлен
           Требует: /lib/libc.so.6(GLIBC_2.3) но пакет не может быть установлен
           Требует: /lib/libc.so.6(GLIBC_2.3.2) но пакет не может быть установлен
           Требует: /lib/libc.so.6(GLIBC_2.3.4) но пакет не может быть установлен
           Требует: /lib/libc.so.6(GLIBC_2.4) но пакет не может быть установлен
           Требует: /lib/libc.so.6(GLIBC_2.7) но пакет не может быть установлен
           Требует: /lib/libc.so.6(GLIBC_2.9) но пакет не может быть установлен
           Требует: /lib/libdl.so.2(GLIBC_2.0) но пакет не может быть установлен
           Требует: /lib/libdl.so.2(GLIBC_2.1) но пакет не может быть установлен
           Требует: /lib/libgcc_s.so.1(GCC_3.0) но пакет не может быть установлен
           Требует: /lib/libgcc_s.so.1(GCC_3.3) но пакет не может быть установлен
           Требует: /lib/libgcc_s.so.1(GCC_4.2.0) но пакет не может быть установлен
           Требует: /lib/libgcc_s.so.1(GLIBC_2.0) но пакет не может быть установлен
           Требует: /lib/libm.so.6(GLIBC_2.0) но пакет не может быть установлен
           Требует: /lib/libm.so.6(GLIBC_2.1) но пакет не может быть установлен
           Требует: /lib/libpthread.so.0(GLIBC_2.0) но пакет не может быть установлен
           Требует: /lib/libpthread.so.0(GLIBC_2.1) но пакет не может быть установлен
           Требует: /lib/libpthread.so.0(GLIBC_2.1.1) но пакет не может быть установлен
           Требует: /lib/libpthread.so.0(GLIBC_2.2) но пакет не может быть установлен
           Требует: /lib/libpthread.so.0(GLIBC_2.2.3) но пакет не может быть установлен
           Требует: /lib/libpthread.so.0(GLIBC_2.3.2) но пакет не может быть установлен
           Требует: /lib/libpthread.so.0(GLIBC_2.3.3) но пакет не может быть установлен
           Требует: /lib/librt.so.1(GLIBC_2.2) но пакет не может быть установлен
           Требует: /lib/libthread_db.so.1(GLIBC_2.1.3) но пакет не может быть установлен
           Требует: /usr/lib/libasound.so.2(ALSA_0.9) но пакет не может быть установлен
           Требует: /usr/lib/libasound.so.2(ALSA_0.9.0rc4) но пакет не может быть установлен
           Требует: /usr/lib/libstdc++.so.6(CXXABI_1.3) но пакет не может быть установлен
           Требует: /usr/lib/libstdc++.so.6(GLIBCXX_3.4) но пакет не может быть установлен
           Требует: /usr/lib/libstdc++.so.6(GLIBCXX_3.4.9) но пакет не может быть установлен
E: Извините, `битые' пакеты

Оффлайн AsaThorr

  • Начинающий
  • *
  • Сообщений: 5
А вот тут инструкция с сайта егаис https://egais.ru/utm/README-UTM-INSTALL.HTML

Оффлайн yaleks

  • Мастер
  • ***
  • Сообщений: 6 242
так это 32 битное приложение.
надо доустановить i586-glibc-core i586-libgcc1 i586-glibc-pthread и далее по аналогии

Оффлайн AsaThorr

  • Начинающий
  • *
  • Сообщений: 5
в том то и дело, что это уже все установлено ( запустил установку еще раз, чтобы было видно
[root@host-15 ~]# apt-get install i586-glibc-core i586-libgcc1
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Выбрано i586-glibc-core.32bit для 'i586-glibc-core'
Последняя версия i586-glibc-core.32bit уже установлена.
Выбрано i586-libgcc1.32bit для 'i586-libgcc1'
Последняя версия i586-libgcc1.32bit уже установлена.
0 будет обновлено, 0 новых установлено, 0 пакетов будет удалено и 0 не будет обновлено.

и это со всеми библиотеками, которые были указаны до этого