Автор Тема: viber: error while loading shared libraries: libevent-2.1.so.7: cannot open..  (Прочитано 664 раз)

Оффлайн Δημητριος

  • Давно тут
  • **
  • Сообщений: 311
hello today  i tried to install viber the way you told me in the past here  but I find that it does not work referred to the problem below

 The main reason is a library ,library libevent-2.1.so.7 not found,but the paradox is that it is installed...
viber
viber: error while loading shared libraries: libevent-2.1.so.7: cannot open shared object file: No such file or directory

warning: absolute symlink: /var/tmp/tmp.WoN1jyrQ4i/viber.deb.tmpdir/viber-21.8.0.11/usr/bin/Viber -> /opt/viber/Viber
find-provides: absolute symbolic link /var/tmp/tmp.WoN1jyrQ4i/viber.deb.tmpdir/viber-21.8.0.11/usr/bin/Viber -> /opt/viber/Viber is not going to provide anything
find-provides: running scripts (alternatives,debuginfo,lib,pam,perl,pkgconfig,python,python3,shell)
find-requires: running scripts (cpp,debuginfo,files,lib,pam,perl,pkgconfig,pkgconfiglib,python,python3,rpmlib,shebang,shell,static,symlinks,systemd-services)
lib.req: WARNING: /var/tmp/tmp.WoN1jyrQ4i/viber.deb.tmpdir/viber-21.8.0.11/opt/viber/Viber: overlinked libraries: /usr/lib64/libGL.so.1
lib.req: WARNING: /opt/viber/lib/libQt6WebEngineCore.so.6: library libevent-2.1.so.7 not found
lib.req: WARNING: /var/tmp/tmp.WoN1jyrQ4i/viber.deb.tmpdir/viber-21.8.0.11/opt/viber/lib/libQt6WebEngineCore.so.6: overlinked libraries: /usr/lib64/libXtst.so.6
/var/tmp/tmp.WoN1jyrQ4i/viber.deb.tmpdir/viber-21.8.0.11/opt/viber/plugins/imageformats/libqtiff.so: /usr/lib64/libtiff.so.5: no version information available (required by /var/tmp/tmp.WoN1jyrQ4i/viber.deb.tmpdir/viber-21.8.0.11/opt/viber/plugins/imageformats/libqtiff.so)
++ /bin/sed -e '/^libtiff.so.5(LIBTIFF_.*/d'
--- find-requires-deps 2024-02-06 17:06:03.095795778 +0200
+++ filter-requires-deps 2024-02-06 17:06:03.097795784 +0200
@@ -197,3 +197,2 @@
 libtiff.so.5()(64bit) >= set:lgI8QNYVq01pu21U6ZKJyE7OW1iah1tcGNJdLR7TG41Usi
-libtiff.so.5(LIBTIFF_4.0)(64bit)
 libts.so.0()(64bit) >= set:iftPufgDzDAGNCo7
 # rpm -Uvh /var/tmp/tmp.WoN1jyrQ4i/viber-21.8.0.11-epm1.repacked.2.x86_64.rpm
Preparing...                                                                                                                       #################################################################################################### [100%]
Updating / installing...
1: viber-100:21.8.0.11-epm1.repacked.2                                                                                             #################################################################################################### [ 50%]
Cleaning up / removing...
2: viber-100:21.8.0.11-epm1.repacked.2                                                                                             #################################################################################################### [100%]
Running /usr/lib/rpm/posttrans-filetriggers

do you know what can i do thanks you

PS: The paradox is finally that the app image works, in relation to the old problem that didn't work.  :-ohere..unbelievable.... :-o
############
some attempts were made but without success

⚠️ with the precious help of dear gost87  I tried to upgrade the problematic package , however there were important dependencies that did not leave such margins..
one case
apt-get install libevent2.1-2.1.12-alt1.x86_64.rpm
Reading Package Lists... Done
Building Dependency Tree... Done
Selecting libevent2.1 for 'libevent2.1-2.1.12-alt1.x86_64.rpm'
The following packages will be upgraded
  libevent2.1
The following packages will be REMOVED:
  chromium gvfs-backend-nfs gvfs-backends libcamera nfs-clients pipewire-libs
  thunderbird transmission-gtk xfce4-default
1 upgraded, 0 newly installed, 9 removed and 0 not upgraded.
Need to get 0B/205kB of archives.
After unpacking 784MB disk space will be freed.
Do you want to continue?               

⚠️second case
After that ,i try to  install some specific packages , but it was completely impossible to install them because these dependencies will  blowing up
 in the air distro...
packages
glibc-2.32-alt5.p10.2.x86_64.rpm
libcrypto1.1-1.1.1w-alt1.x86_64.rpm
libevent2.1-2.1.12-alt1.x86_64.rpm
libssl1.1-1.1.1w-alt1.x86_64.rpm
Reading Package Lists... Done
Building Dependency Tree... Done
Selecting libcrypto1.1 for /libcrypto1.1-1.1.1w-alt1.x86_64.rpm'
The following packages will be upgraded
  libcrypto1.1
The following packages will be REMOVED:
  GConf ImageMagick ImageMagick-doc ImageMagick-tools LibreOffice
  LibreOffice-common LibreOffice-extensions LibreOffice-gtk3
  LibreOffice-integrated LibreOffice-langpack-en_US NetworkManager
  NetworkManager-adsl NetworkManager-applet-gtk NetworkManager-bluetooth
  NetworkManager-daemon NetworkManager-l2tp NetworkManager-l2tp-gtk-common
  NetworkManager-l2tp-gtk3 NetworkManager-openconnect
  NetworkManager-openconnect-gtk NetworkManager-openvpn
  NetworkManager-openvpn-gtk-common NetworkManager-openvpn-gtk3
  NetworkManager-ppp NetworkManager-pptp NetworkManager-pptp-gtk-common
  NetworkManager-pptp-gtk3 NetworkManager-team NetworkManager-vpnc
  NetworkManager-vpnc-gtk-common NetworkManager-vpnc-gtk3 NetworkManager-wifi
  NetworkManager-wwan alt-rootfs-installer alterator alterator-auth
  alterator-browser-qt5 alterator-datetime alterator-datetime-functions
  alterator-lookout alterator-net-eth alterator-net-functions
  alterator-net-openvpn alterator-net-pppoe alterator-net-pptp alterator-notes
  alterator-openvpn-sh-functions alterator-packages alterator-root
  alterator-services alterator-sslkey alterator-standalone alterator-sysconfig
  alterator-users alterator-x11 alterator-xkb altmediawriter appinstall
  apt-indicator apt-repo atril-gtk atril-gtk-djvu atril-gtk-pixbuf
  atril-gtk-xps audacious audacious-plugins beesu bind-utils blueberry
  branding-simply-linux-alterator branding-simply-linux-xfce-settings c2050
  cert-sh-functions chromium cifs-utils consolehelper cpu-x cups cups-filters
  cups-filters-libs cups-pdf curl easytag eepm eiskaltdcpp-common
  eiskaltdcpp-gtk eiskaltdcpp-gtk-data elinks epsoneplijs epsonscan2 exo-utils
  ffmpeg ffmpeg-plugin-browser firefox-esr flatpak foo2zjs
  freerdp-plugins-standard fuse-gvfs fwupd gcr gcr-libs geoclue2 ghostscript
  ghostscript-classic ghostscript-common gimagereader-qt5 gimp
  gimp-plugin-gutenprint gnome-bluetooth gnome-games-aisleriot
  gnome-games-chess gnome-games-klotski gnome-games-mahjongg gnome-games-mines
  gnome-games-tetravex gnome-keyring gnome-online-accounts gnome-software
  gnome-software-disable-updates gnome-themes-extra gnome-themes-extra-data
  gnupg2 gparted gphoto2 grub-customizer gst-devtools gst-libav
  gst-plugins-bad1.0 gst-plugins-good1.0 gstreamer-editing-services
  gtk-theme-classiclooks gtk2-ssh-askpass gtk2-theme-classiclooks
  gtk2-theme-clearlooks gtk2-theme-greybird gutenprint gutenprint-cups gvfs
  gvfs-backend-admin gvfs-backend-afc gvfs-backend-afp gvfs-backend-cdda
  gvfs-backend-dnssd gvfs-backend-goa gvfs-backend-google gvfs-backend-mtp
  gvfs-backend-nfs gvfs-backend-recent-files gvfs-backend-smb gvfs-backends
  homebank homebank-help hostname-hook-hosts hplip hplip-common hplip-hpcups
  hplip-hpijs hplip-sane krb5-kinit libGConf libImageMagick6.7
  libappindicator-gtk3 libappindicator-gtk3-gir libappstream libaudacious
  libavahi-ui libavdevice58 libavfilter7 libavformat58
  libayatana-appindicator3-1 libayatana-ido3-0 libayatana-indicator3-7 libbind
  libblockdev-crypto libcamera libcanberra-gtk2 libcanberra-gtk3 libchamplain
  libchamplain-gtk3 libclutter libclutter-gtk3 libcmis libcups libcurl
  libdbusmenu-gtk3 libeiskaltdcpp libevent2 libevent2.1 libexo-gtk3
  libfarstream0.2 libffmpegthumbnailer libflatpak libfreerdp libgarcon
  libgarcon-gtk3 libgarcon-settings-manager-menu libgdata libgegl libgepub
  libges libges-gir libgimp libglade libgnome-bluetooth libgnome-bluetooth-gir
  libgnome-games-support libgnome-online-accounts libgnomekbd libgpgme11
  libgpgmepp6 libgphoto2-6 libgraphviz libgs libgsasl libgspell libgssdp1.2
  libgtk+2 libgtk+3 libgtk+3-gir libgtk-engine-hc libgtk-engine-murrine
  libgtk4 libgtkmm3 libgtkmm4 libgtksourceview4 libgtkspell libguile-vhttpd
  libgupnp-igd libgupnp1.2 libgutenprint libhandy1 libhandy1-gir
  libimobiledevice libindicator-gtk3 libinput libjcat libkeybinder3 libkrb5
  libldap libldb liblive555 liblrdf libmate-desktop libmypaint
  libmysqlclient21 libnautilus libneon libnet-snmp35 libnice libnma libofx
  libopenconnect libopencv4.5 libostree libpeas libpeas-gir
  libpeas-python3-loader libphodav libpoppler0-cpp libpoppler1-qt5
  libpoppler126 libpoppler130 libpoppler8-glib libpq5 libpurple libpython3
  libqt5-bluetooth libqt5-designer libqt5-eglfsdeviceintegration
  libqt5-eglfskmssupport libqt5-gui libqt5-help libqt5-hunspellinputmethod
  libqt5-location libqt5-multimedia libqt5-network libqt5-nfc libqt5-opengl
  libqt5-positioning libqt5-positioningquick libqt5-printsupport libqt5-qml
  libqt5-qmlmodels libqt5-qmlworkerscript libqt5-quick libqt5-quickcontrols2
  libqt5-quickshapes libqt5-quicktemplates2 libqt5-quickwidgets
  libqt5-remoteobjects libqt5-sensors libqt5-svg libqt5-virtualkeyboard
  libqt5-webchannel libqt5-websockets libqt5-widgets libqt5-x11extras
  libqt5-xcbqpa libqt5-xmlpatterns libqtspell-qt5 librabbitmq-c4 libraptor2
  librasqal3 libredland libreoffice-languagetool librest libsane libsasl2-3
  libshout2 libsmbclient libsoup libsoup-gnome libspectre libspice-glib
  libspice-gtk3 libspice-server libssh libssl1.1 libthunar libtirpc
  libtpm2-tss0 libtracker libvhttpd libvolume_key libvte libvte3 libwacom
  libwebkit2gtk libwebkitgtk2 libwinpr libwnck3 libwnck3-gir libxapps
  libxapps-gir libxfce4panel-gtk3 libxfce4ui-gtk3 libyelp lightdm
  lightdm-gtk-greeter lightdm-gtk-greeter-settings lz11-V2 mate-calc
  mate-file-archiver mate-search-tool mencoder mousepad mugshot newmoon
  nfs-clients nfs-utils onboard open-vm-tools open-vm-tools-desktop
  openconnect openldap-clients openssh-clients openssh-server openssl openvpn
  orage ostree packageinstall packagekit pam_gnome-keyring pam_krb5
  pavucontrol pidgin pidgin-libnotify pinentry-gnome3 pipewire-libs pitivi
  polkit-gnome poppler ppp ppp-pppoe pptp-client printer-driver-brlaser
  printer-driver-ptouch printer-driver-splix printer-drivers-base python
  python-module-numpy python-module-pycairo python-module-pygobject
  python-module-pygtk python-modules python-modules-bsddb
  python-modules-compiler python-modules-ctypes python-modules-email
  python-modules-encodings python-modules-hotshot python-modules-logging
  python-modules-multiprocessing python-modules-unittest python-modules-xml
  python-strict python3 python3-base python3-module-Pillow
  python3-module-PyQt5 python3-module-PyQt5-sip python3-module-Reportlab
  python3-module-appdirs python3-module-attrs python3-module-automat
  python3-module-canberra python3-module-certifi python3-module-cffi
  python3-module-click python3-module-constantly python3-module-cryptography
  python3-module-cups python3-module-cupshelpers python3-module-cycler
  python3-module-cython-hidapi python3-module-dateutil python3-module-dbus
  python3-module-distro python3-module-enchant python3-module-gst1.0
  python3-module-hyperlink python3-module-idna python3-module-incremental
  python3-module-kiwisolver python3-module-libevdev python3-module-matplotlib
  python3-module-matplotlib-cairo python3-module-matplotlib-gtk3
  python3-module-mpl_toolkits python3-module-numpy python3-module-olefile
  python3-module-openssl python3-module-pexpect python3-module-pkg_resources
  python3-module-pluggy python3-module-ptyprocess python3-module-pycairo
  python3-module-pycares python3-module-pycparser python3-module-pygobject
  python3-module-pygobject3 python3-module-pymorphy2 python3-module-pyparsing
  python3-module-pyudev python3-module-serial python3-module-setproctitle
  python3-module-six python3-module-smbc python3-module-tornado
  python3-module-twisted-core python3-module-twisted-logger
  python3-module-twisted-names python3-module-twisted-words
  python3-module-zope.interface python3-modules-sqlite3
  python3-modules-tkinter qt5-quickcontrols qt5-quickcontrols2
  qt5-virtualkeyboard rdesktop realmd remmina remmina-plugins
  remmina-plugins-exec remmina-plugins-rdp remmina-plugins-secret
  remmina-plugins-spice remmina-plugins-vnc ristretto rpcbind rpminstall samba
  samba-client samba-common-libs samba-common-tools samba-dcerpc samba-libs
  samba-winbind samba-winbind-clients sane seahorse shotwell skypeforlinux
  spice-vdagent stardict stardict-mueller7 stardict-quick_en-ru
  stardict-quick_ru-en strongswan synaptic synaptic-usermode
  system-config-printer system-config-printer-lib system-config-printer-udev
  tesseract tesseract-langpack-en tesseract-langpack-ru thunar
  thunar-archive-plugin thunar-media-tags-plugin thunar-shares-plugin
  thunar-volman-plugin thunderbird transcode transmission-gtk tumbler udisks2
  usbmuxd userpasswd vhttpd-utils viber virtualbox-guest-additions vlc
  vlc-interface-qt vlc-interface-skins2 vlc-maxi vlc-plugin-ffmpeg
  vlc-plugin-live555 vlc-plugin-notify vlc-plugin-shout vlc-plugin-smb wget
  wpa_supplicant xfburn xfce4-about xfce4-appfinder xfce4-battery-plugin
  xfce4-clipman-plugin xfce4-cpufreq-plugin xfce4-cpugraph-plugin
  xfce4-datetime-plugin xfce4-default xfce4-diskperf-plugin xfce4-eyes-plugin
  xfce4-fsguard-plugin xfce4-mailwatch-plugin xfce4-minimal xfce4-mount-plugin
  xfce4-netload-plugin xfce4-notes-plugin xfce4-notifyd xfce4-panel
  xfce4-places-plugin xfce4-power-manager xfce4-pulseaudio-plugin
  xfce4-screensaver xfce4-screenshooter xfce4-sensors-plugin xfce4-session
  xfce4-settings xfce4-systemload-plugin xfce4-taskmanager xfce4-terminal
  xfce4-time-out-plugin xfce4-timer-plugin xfce4-verve-plugin
  xfce4-whiskermenu-plugin xfce4-xkb-plugin xfdesktop xfsprogs xfwm4
  xfwm4-themes xinit xinitrc xorg-conf-libinput-touchpad xorg-dri-intel
  xorg-dri-radeon xorg-dri-swrast xorg-dri-virtio xorg-dri-vmwgfx
  xorg-drv-amdgpu xorg-drv-ati xorg-drv-cirrus xorg-drv-evdev xorg-drv-fbdev
  xorg-drv-intel xorg-drv-libinput xorg-drv-mach64 xorg-drv-mga xorg-drv-qxl
  xorg-drv-r128 xorg-drv-radeon xorg-drv-spiceqxl xorg-drv-synaptics
  xorg-drv-vboxvideo xorg-drv-vesa xorg-drv-vmmouse xorg-drv-vmware
  xorg-drv-wacom xorg-server xorg-utils xrdp xsane xsane-doc xsane-doc-ru
  xsane-gimp2 yandex-browser-stable yelp zoom
WARNING: The following essential packages will be removed
This should NOT be done unless you know exactly what you are doing!
  openssh-server libkrb5 (due to openssh-server)
1 upgraded, 0 newly installed, 600 removed and 0 not upgraded.
Need to get 0B/1377kB of archives.
After unpacking 5507MB disk space will be freed.
You are about to do something potentially harmful
To continue type in the phrase 'Yes, do as I say!'
 ?]
« Последнее редактирование: 07.02.2024 02:09:47 от Δημητριος »

Оффлайн gosts 87

  • Завсегдатай
  • *
  • Сообщений: 2 734
  • Дмитрий/Dmitry/德米特里/दिमित्री
PS: :-oThe paradox is finally that the app image works, in relation to the old problem that didn't work.  :-ohere..unbelievable.... :-o
There is nothing paradoxical about this. :-)

Оффлайн Δημητριος

  • Давно тут
  • **
  • Сообщений: 311
PS: :-oThe paradox is finally that the app image works, in relation to the old problem that didn't work.  :-ohere..unbelievable.... :-o
There is nothing paradoxical about this. :-)
no, the paradox is that as soon as one was fixed and started to work, the other broke.. :-) thanks for your help...