Автор Тема: Не запускается Evolution [Решено]  (Прочитано 650 раз)

Оффлайн sirares

  • Давно тут
  • **
  • Сообщений: 201
Здравствуйте, требуется помощь с запуском Evolution.
История  такова: система kworkstation 10.2, обновления все поставлены, при запуске evolution в графике - колесо запуска покрутится и - тишина, при запуске из консоли такой выхлоп:[xxxxxx-xx@xxxxxx ~]$ evolution
Xlib:  extension "GLX" missing on display ":10.0".
Xlib:  extension "GLX" missing on display ":10.0".
free(): double free detected in tcache 2
Аварийный останов
после обновления ядра update-kernel -t std-def, (обновлены какие-то модули Nvidia)  - ничего не изменилось, ошибка та-же.
Подозреваю, что ошибка с Гономовсими библиотеками, т.к на машине с другой конфигурацией evolution запускался, почту принимал, а открывать письма не мог - ошибка библиотек, сейчас не скажу какая, но там был конфликт ядра и Intel G4560 с H110 MB - висел на этапе запуска vmlinuz и initrd более 3 минут, помогла только замена на Mate версию workstation 10.1.
Thunderbird  не предлагать - под запретом!
« Последнее редактирование: 19.03.2024 07:34:54 от sirares »

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 954
    • Домашняя страница
    • Email
Re: Не запускается Evolution
« Ответ #1 : 04.03.2024 20:09:35 »
Андрей Черепанов (cas@)

Оффлайн sirares

  • Давно тут
  • **
  • Сообщений: 201
Re: Не запускается Evolution
« Ответ #2 : 05.03.2024 04:44:05 »
Спасибо, проверю - отпишусь
P.S. Комп слабый Intel Core 2 Duo, 2GB RAM, видеокарта тоже древняя gf240, ввиду этого принято решение переустановить версию с KDE на Mate, так как требования ниже...
« Последнее редактирование: 06.03.2024 09:42:22 от sirares »

Оффлайн sirares

  • Давно тут
  • **
  • Сообщений: 201
Re: Не запускается Evolution
« Ответ #3 : 18.03.2024 08:20:40 »
Проблема решена. Всего замечено на четырех компьютерах, но будут еще и не раз!!!

Для версии KDE Kworkstation
В наличии конфликт видеокарты Nvidia Geforce 218(210), по умолчанию устанавливаются проприентарные дрова - они в свою очередь вытесняют библиотеки LibGL.
Эти библиотеки необходимы для работы Evolution - без них он или не запускается, или не читает почту, хотя может ее загрузить.
Всего пока выявлено четыре компьютера с подобной проблемой, пока решена на двух.
Решение: Замена драйверов на свободные: https://www.altlinux.org/Nvidia
После замены в одном случае понадобилось дополнительно удалить все модули nvidiaapt-get remove apt-scripts-nvidia
Для версии Mate Workstation
проблем с evolution нет, НО
Замечено, что  система уходит в сон и не просыпается, на компьютерах без такой видеокарты этого нет!
пока не разобрался, но заметил, что в /etc/X11/xorg.conf.d/ нет файла с описанием монитора 10-monitor.conf

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 32 299
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Re: Не запускается Evolution
« Ответ #4 : 18.03.2024 08:50:57 »
но заметил, что в /etc/X11/xorg.conf.d/ нет файла с описанием монитора 10-monitor.conf
Он вообще-то не обязателен.

Оффлайн sirares

  • Давно тут
  • **
  • Сообщений: 201
Re: Не запускается Evolution
« Ответ #5 : 19.03.2024 07:33:52 »
Он вообще-то не обязателен
Может быть и не обязателен - не спорю, вам виднее.
Но уходит в сон и не просыпается - хотя это уже совсем другой вопрос не имеющий отношения к сабжу.
Открывать новую тему пока не планирую - мало информации, только то что два из четырех компов на которых не работал evolution в KDE при установки Mate уходят в сон, но evolution работает.
Какая связь - на всех Geforce 210 серии, процы, майнборды - разные, есть даже фирменный HP.
Спасибо большое  за наводку смотреть дрова на Nvidia
« Последнее редактирование: 19.03.2024 07:37:00 от sirares »