Автор Тема: Wine Staging 6 под P9/P10  (Прочитано 622 раз)

Оффлайн AndreyNag

  • Начинающий
  • *
  • Сообщений: 14
Wine Staging 6 под P9/P10
« : 26.04.2024 10:38:43 »
Здравствуйте.
Возникла необходимость поставить wine staging 6.x на рабочие станции P9 и P10. Ни стоковый wine v.9, ни vanilla, не позволяют нормально пользоваться "Справки БК" и "КонсультантПлюс". На машинах, где остался wine v.6.x проблем нет. Всё работает штатно.
Вопрос: Как установить на актуальные версии P9 и P10 wine 6-й версии правильно. В репозитории нужной версии нет, в том числе и Sisyphus'e.
Спасибо за внимание.

Оффлайн ProfessorNavigator

  • Давно тут
  • **
  • Сообщений: 240
Re: Wine Staging 6 под P9/P10
« Ответ #1 : 26.04.2024 11:46:24 »
Можно через Playonlinux. Или клонировать репозиторий например отсюда: https://github.com/wine-mirror/wine. Дальше git checkout <нужная_версия> и собрать руками самому. Правда придётся установить все сборочные зависимости. Если есть опыт - можно собрать в hasher, тогда не придётся тащить на машину сборочные зависимости. Можно ещё попробовать через portproton, но не уверен, что там такие старые версии wine есть.

Оффлайн AndreyNag

  • Начинающий
  • *
  • Сообщений: 14
Re: Wine Staging 6 под P9/P10
« Ответ #2 : 26.04.2024 13:57:20 »
Можно через Playonlinux
Не получилось. Пробовал. Толи я тупой, толи одно из двух. :-\
Попробую собрать из исходников.
Пока пытался руками пакеты устанавливать напоролся на неразрешимую зависимость с библиотекой libFAudio.so.0 >= set:mfeLZvQieDe4tMQQOgLE..... потому, что в системе P10 с кедами уже установлена более новая версия. 8-|
Интересно контейнеров с нужными версиями wine нету? ???

Оффлайн GrishaDm

  • Давно тут
  • **
  • Сообщений: 345
Re: Wine Staging 6 под P9/P10
« Ответ #3 : 26.04.2024 14:05:00 »
А у меня наоборот wine месяца 3 назад я поставил и работал почему-то только x32 (причём криво-косо, там надо было запускать версию i586 и только из-под рута), а потом, после очередного обновления, он починился и такой, и x64. И cross over нормально работает.

Оффлайн ProfessorNavigator

  • Давно тут
  • **
  • Сообщений: 240
Re: Wine Staging 6 под P9/P10
« Ответ #4 : 26.04.2024 15:17:00 »
Не получилось. Пробовал. Толи я тупой, толи одно из двух
Там действительно немного поплясать с бубном нужно. Я уже давно этим не занимался - не помню, как именно.

Пока пытался руками пакеты устанавливать напоролся на неразрешимую зависимость с библиотекой libFAudio.so.0 >= set:mfeLZvQieDe4tMQQOgLE..... потому, что в системе P10 с кедами уже установлена более новая версия
Да, такое вполне может быть. Придётся ещё и зависимости некоторые самому руками собирать. Можете, кстати, попробовать установить portproton и поиграть с их версиями wine - они специально патченые, возможно какая-то заработает. Можно ещё lutris попробовать, но там уже совсем не знаю как и что - я его никогда не использовал. 

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 957
    • Домашняя страница
    • Email
Re: Wine Staging 6 под P9/P10
« Ответ #5 : 27.04.2024 11:05:12 »
Здравствуйте.
Возникла необходимость поставить wine staging 6.x на рабочие станции P9 и P10. Ни стоковый wine v.9, ни vanilla, не позволяют нормально пользоваться "Справки БК" и "КонсультантПлюс". На машинах, где остался wine v.6.x проблем нет. Всё работает штатно.
Вопрос: Как установить на актуальные версии P9 и P10 wine 6-й версии правильно. В репозитории нужной версии нет, в том числе и Sisyphus'e.
Спасибо за внимание.
Вы говорите неправду. wine в p10 специально дорабатывался для работы со СправкиБК и было множество подтверждений его работоспособности от заказчиков.
Андрей Черепанов (cas@)