Автор Тема: Antique-retro-2.6.18-alt12M40.3  (Прочитано 34332 раз)

Оффлайн YYY

  • Мастер
  • ***
  • Сообщений: 5 763
Re: Antique-retro-2.6.18-alt12M40.3
« Ответ #75 : 08.04.2013 09:51:56 »
Под форумы думаю 9.2 хорошо, под сети - не специалист...

Оффлайн sb

  • Модератор глобальный
  • *****
  • Сообщений: 8 808
    • Email
Re: Antique-retro-2.6.18-alt12M40.3
« Ответ #76 : 08.04.2013 10:21:45 »
Попробую перепаковать тогда 9.27. Действительно
9.2 легче 9.6 и это хорошо видно на глаз....

Оффлайн Vasiliy

  • Завсегдатай
  • *
  • Сообщений: 309
  • +++
Re: Antique-retro-2.6.18-alt12M40.3
« Ответ #77 : 03.07.2013 11:00:28 »
А что, реально можно уже 9.27 установить из репки?
« Последнее редактирование: 03.07.2013 11:32:34 от Vasiliy »

Оффлайн YYY

  • Мастер
  • ***
  • Сообщений: 5 763
Re: Antique-retro-2.6.18-alt12M40.3
« Ответ #78 : 05.07.2013 16:59:50 »
А что, реально можно уже 9.27 установить из репки?

Такую старую версию в репозиторий нельзя складывать - лицензия не позволяет...
Но можно с оф. сайта попробовать...
http://arc.opera.com/pub/opera/linux/927/final/en/i386/static/opera-9.27-20080331.1-static-qt.i386-en.rpm
ну и локализация
http://operafan.net/component/option,com_remository/Itemid,72/func,fileinfo/id,111/
« Последнее редактирование: 05.07.2013 17:03:12 от YYY »

Оффлайн Vasiliy

  • Завсегдатай
  • *
  • Сообщений: 309
  • +++
Re: Antique-retro-2.6.18-alt12M40.3
« Ответ #79 : 07.07.2013 22:56:18 »
Опробовал эту версию - выигрыша в плане уменьшения времени цпу (opera-98%) нет, страницы грузятся по несколько минут почти. Вывод, как я уже писал где-то на альт-линукс-форуме, для данного железа класса-А (о котором уже сказано "мало что могут") оптимально нужна ось по-легче. Но специально под класс-А сборка 2.6.(<18) не целесообразна, понимаю. Это те времена массового оптимизации производства по среды: NT, Win95 и 2.4.x. Увы, это надо признать. Что порекомендуете? Master, Junior, Compact?

Оффлайн YYY

  • Мастер
  • ***
  • Сообщений: 5 763
Re: Antique-retro-2.6.18-alt12M40.3
« Ответ #80 : 07.07.2013 23:05:48 »
Ну мастер вы пробовали же...

Проблема не в самой оси... проблема в страничках...
Если странички заставляют браузер нагружать процессор,  то выходов не много...
Надо выбрать минимальнотормозящий браузер при оптимально устраивающих возможностях...
Надо понимать что современный интернет - тупняк... Выход... попробовать уменьшать версию браузера в надежде что он не будет уметь исполнять тормозящие скрипты и другую чепуху...

ИМХО, по большому счету тут дело такое...
вы установите более менее свежую оперу на вин-95 и тормоза будут тут как тут...

Если 9.2 тормозит... пробуйте 8ку...
http://arc.opera.com/pub/opera/linux/854/final/en/i386/static/opera-8.54-20060330.1-static-qt.i386-en.rpm
потом 7ку
http://arc.opera.com/pub/opera/linux/754u2/final/en/i386/static/opera-7.54-20050131.1-static-qt.i386-en.rpm


Да...

Вы
skipstone
из репозитория пробовали?
Можно попробовать netsurf для 4ки собрать...

« Последнее редактирование: 07.07.2013 23:25:13 от YYY »

Оффлайн Vasiliy

  • Завсегдатай
  • *
  • Сообщений: 309
  • +++
Re: Antique-retro-2.6.18-alt12M40.3
« Ответ #81 : 08.07.2013 11:52:58 »

Если 9.2 тормозит... пробуйте 8ку...
http://arc.opera.com/pub/opera/linux/854/final/en/i386/static/opera-8.54-20060330.1-static-qt.i386-en.rpm


Установил, только запустить не получается, всё обыскал, никак файлик не нахожу родной для запуска, где может лежать? opera.shellscript от 8.54 в /usr/bin/ лежит, но он не запускает?
« Последнее редактирование: 08.07.2013 12:23:39 от Vasiliy »

Оффлайн YYY

  • Мастер
  • ***
  • Сообщений: 5 763
Re: Antique-retro-2.6.18-alt12M40.3
« Ответ #82 : 08.07.2013 12:25:41 »
попробуйте в
/usr/lib/opera/8.54-20060330.1/
« Последнее редактирование: 08.07.2013 12:27:35 от YYY »

Оффлайн Vasiliy

  • Завсегдатай
  • *
  • Сообщений: 309
  • +++
Re: Antique-retro-2.6.18-alt12M40.3
« Ответ #83 : 08.07.2013 12:42:17 »
попробуйте в
/usr/lib/opera/8.54-20060330.1/
/usr/lib/opera/8.54-20060330.1/opera - тоже не запускает.

Оффлайн YYY

  • Мастер
  • ***
  • Сообщений: 5 763
Re: Antique-retro-2.6.18-alt12M40.3
« Ответ #84 : 08.07.2013 14:24:08 »

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 9 953
Re: Antique-retro-2.6.18-alt12M40.3
« Ответ #85 : 08.07.2013 15:46:59 »
попробуйте в
/usr/lib/opera/8.54-20060330.1/
/usr/lib/opera/8.54-20060330.1/opera - тоже не запускает.
Стоп-стоп-стоп!
А почему в lib?
Бинарник там не должен лежать.
Делаю по вашей ссылке:
$ wget -c http://arc.opera.com/pub/opera/linux/854/final/en/i386/static/opera-8.54-20060330.1-static-qt.i386-en.rpm
Разворачиваем rpm в текущий каталог:
$ rpm2cpio ./opera-8.54-20060330.1-static-qt.i386-en.rpm | cpio -idmv
etc/opera6rc
etc/opera6rc.fixed
usr/X11R6/bin
usr/X11R6/bin/opera
usr/bin
usr/bin/opera
...
Ищем где лежат стартовые бинарники:
$ find ./usr/ -name opera|ls -l $(grep bin)
-rwxr-xr-x 1 altlinux altlinux 5941 мар 30  2006 ./usr/bin/opera
lrwxrwxrwx 1 altlinux altlinux   14 июл  8 14:34 ./usr/X11R6/bin/opera -> /usr/bin/opera

Первое бинарник, второе симлинк на него.

По первой ссылке из двух от YYY оно еще и джаву требует?
$ opera
ERROR: ld.so: object 'libjvm.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libawt.so' from LD_PRELOAD cannot be preloaded: ignored.
/usr/lib/opera/8.54-20060330.5/opera: error while loading shared libraries: libqt-mt.so.3: cannot open shared object file: No such file or directory
« Последнее редактирование: 08.07.2013 16:39:40 от Speccyfighter »

Оффлайн YYY

  • Мастер
  • ***
  • Сообщений: 5 763
Re: Antique-retro-2.6.18-alt12M40.3
« Ответ #86 : 08.07.2013 17:39:20 »
> Стоп-стоп-стоп!
> А почему в lib?

Ну раз не работает из /usr/bin скрипт. А скрипт в итоге запускает из lib

Сейчас проверю что да как...

Оффлайн YYY

  • Мастер
  • ***
  • Сообщений: 5 763
Re: Antique-retro-2.6.18-alt12M40.3
« Ответ #87 : 08.07.2013 17:59:29 »
У меня запустилась.
http://arc.opera.com/pub/opera/linux/854/final/en/i386/static/opera-8.54-20060330.1-static-qt.i386-en.rpm
Надо удалить старый RPM из системы, потом очистить скрытый каталог с настройками пользователя ($HOME/.opera/), а потом установить эту версию и уже запускать...

При запуске 1 процесс вместо 5 и по памяти в 1.5-2 раза меньше (конечно без учета страничек... странички они разные)
« Последнее редактирование: 08.07.2013 19:04:25 от YYY »

Оффлайн sb

  • Модератор глобальный
  • *****
  • Сообщений: 8 808
    • Email
Re: Antique-retro-2.6.18-alt12M40.3
« Ответ #88 : 08.07.2013 18:49:13 »
У меня запустилась.
Немного в оффтоп залезу с вашего позволения. А с отображением форума в этой версии как (нет проблем) ?

Оффлайн YYY

  • Мастер
  • ***
  • Сообщений: 5 763
Re: Antique-retro-2.6.18-alt12M40.3
« Ответ #89 : 08.07.2013 18:58:46 »
Да все отлично! :)
Памяти опера 8.5 с форумом - менее 11 Мб требует
« Последнее редактирование: 08.07.2013 19:01:48 от YYY »