Автор Тема: не могу найти библиотеку для QT5  (Прочитано 15153 раз)

Оффлайн yaleks

  • Мастер
  • ***
  • Сообщений: 6 104
Re: не могу найти библиотеку для QT5
« Ответ #15 : 21.11.2018 15:55:06 »
Qt_5.11 в сизифе, в p8 - 5.9 .

Оффлайн zerg

  • ненужная строка
  • alt linux team
  • ***
  • Сообщений: 2 230
  • ненужная строка
    • Найдётся всё
Re: не могу найти библиотеку для QT5
« Ответ #16 : 21.11.2018 16:13:34 »
Подскажите пожалуйста - как мне найти в каком RPM файле эта библиотека заключена?
Код: (bash) [Выделить]
apt-cache search libQt5Charts.so.5
И как мне установить ее так, чтобы подтянулись все необходимые зависимости, которые может быть еще вылезут?
Код: (bash) [Выделить]
apt-get install libqt5-charts
« Последнее редактирование: 21.11.2018 16:15:57 от zerg »
Убрать этот мусор можно переключателем: Не показывать подписи других пользователей.

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 123
    • Домашняя страница
    • Email
Re: не могу найти библиотеку для QT5
« Ответ #17 : 21.11.2018 17:54:59 »
Пересобрать qt5-charts под p7
А в приведенном примере - проблема с пакетами уже на р8 зафиксирована.

подскажите как разрешить проблему зависимостей,
/usr/lib64/libQt5Core.so.5: version `Qt_5.11' not found
если все библиотеки уже установлены на р8
Обновить систему целиком.
Андрей Черепанов (cas@)

Оффлайн woronin

  • Завсегдатай
  • *
  • Сообщений: 381
    • Email
Re: не могу найти библиотеку для QT5
« Ответ #18 : 25.11.2018 20:30:04 »
Обновить систему целиком.

Попытался осуществить обновление, не свезло...
Сначала выполнил
# epm release-upgrade
 вроде как прошло без ошибок, потом запустил
 # update-kernel

Свалился вот с такой ошибкой
/usr/share/eepm/epm-sh-functions: line 142: update-kernel: команда не найдена
Error:

И все по старому - не легчает. Пишет все тоже самое
./VCPaMain: /usr/lib64/libQt5Core.so.5: version `Qt_5.11' not found (required by ./VCPaMain)

может еще можно какие-то пассы выполнить?

Оффлайн yaleks

  • Мастер
  • ***
  • Сообщений: 6 104
Re: не могу найти библиотеку для QT5
« Ответ #19 : 25.11.2018 20:58:57 »
./VCPaMain: /usr/lib64/libQt5Core.so.5: version `Qt_5.11' not found (required by ./VCPaMain)
откуда у вас эта софтина?
Чтобы была qt-5.11 надо до сизифа обновляться или пересобрать её с qt-5.9.6 чтобы работало в p8.

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 123
    • Домашняя страница
    • Email
Андрей Черепанов (cas@)

Оффлайн woronin

  • Завсегдатай
  • *
  • Сообщений: 381
    • Email
Re: не могу найти библиотеку для QT5
« Ответ #21 : 27.11.2018 04:37:13 »
откуда у вас эта софтина?
Чтобы была qt-5.11 надо до сизифа обновляться или пересобрать её с qt-5.9.6 чтобы работало в p8.
Это разработка коллеги - работа с конечными автоматами. Он ее разработал и собрал как смог, в той конфигурации, которую то него требуют заказчики. У него все нормально работает, в Astra Linux
В Базальте на р8 почему -то не получается ее запустить.
Попробую перейти на Сизиф репозиторий и обновить библиотеки, чтоб и здесь можно было бы запускать

Оффлайн yaleks

  • Мастер
  • ***
  • Сообщений: 6 104
Re: не могу найти библиотеку для QT5
« Ответ #22 : 27.11.2018 13:14:29 »
Это разработка коллеги - работа с конечными автоматами. Он ее разработал и собрал как смог, в той конфигурации, которую то него требуют заказчики. У него все нормально работает, в Astra Linux
В Базальте на р8 почему -то не получается ее запустить.
Попросите его собрать в Альте на p8. Я не думаю что он использовал какие-то особые фичи которых не было в qt-5.9. Или надо библиотеки qt с этой программой поставлять рядом (не рекомендуется).