Автор Тема: QTCreator не видит QMLTermWidget  (Прочитано 493 раз)

Оффлайн gc986

  • Давно тут
  • **
  • Сообщений: 78
  • Жить, хорошо )))
    • Email
QTCreator не видит QMLTermWidget
« : 16.03.2024 12:29:41 »
Начали изучать разработку на QT, используя QTCreator, и захотел встроить QMLTermWidget в приложение, но ничего не получается, так как система ругается на класс QMLTermWidget и QMLTermSession. При этом на QMLTermScrollbar не ругается. Получается что тут вижу, а тут не вижу. Библиотеку установил (через репозиторий) и приписал в проекте. Как думаете, в чём может быть проблема? Может ещё какие то заголовочные фалы нужно куда то положить?

XD XD XD XD

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 32 258
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Re: QTCreator не видит QMLTermWidget
« Ответ #1 : 16.03.2024 13:15:28 »
Что выдаёт:
rpm -qa | grep qt5

Оффлайн gc986

  • Давно тут
  • **
  • Сообщений: 78
  • Жить, хорошо )))
    • Email
Re: QTCreator не видит QMLTermWidget
« Ответ #2 : 16.03.2024 20:38:53 »
Что выдаёт:
rpm -qa | grep qt5

Очень много всего. Если я собираю простое приложение с кнопочками например, то всё норм. Вся загвоздка в этом компоненте

rpm -qa | grep qt5
qt5-quickcontrols2-common-5.15.12-alt1.noarch
libqt5-positioning-5.15.12-alt1.x86_64
libqt5-script-5.15.12-alt1.x86_64
libqt5-3dinput-5.15.12-alt1.x86_64
libqt5-bluetooth-5.15.12-alt1.x86_64
qt5-declarative-common-5.15.12-alt1.x86_64
libqt5-quick-5.15.12-alt1.x86_64
qt5-quickcontrols-5.15.12-alt1.x86_64
qt5-script-common-5.15.12-alt1.noarch
libqt5-webenginewidgets-5.15.16-alt1.x86_64
libqt5-svg-5.15.12-alt1.x86_64
libqt5-virtualkeyboard-5.15.12-alt1.x86_64
qt5-declarative-devel-5.15.12-alt1.x86_64
alterator-browser-qt5-3.4.18-alt1.x86_64
libqt5-eglfsdeviceintegration-5.15.12-alt1.x86_64
libqt5-designer-5.15.12-alt1.x86_64
qt5-websockets-common-5.15.12-alt1.noarch
libqt5-3dextras-5.15.12-alt1.x86_64
qt5-webengine-common-5.15.16-alt1.noarch
libqt5-websockets-5.15.12-alt1.x86_64
libqt5-quicktemplates2-5.15.12-alt1.x86_64
qt5-qmltermwidget-common-0.2.0-alt1.noarch
libqt5-3danimation-5.15.12-alt1.x86_64
qt5-webkit-common-5.212.0-alt24.noarch
libqt5-x11extras-5.15.12-alt1.x86_64
libqt5-3dquickinput-5.15.12-alt1.x86_64
libqt5-serialport-5.15.12-alt1.x86_64
libpoppler1-qt5-23.08.0-alt3.x86_64
qt5ct-1.1-alt1.x86_64
libqt5-xmlpatterns-5.15.12-alt1.x86_64
qt5-qtbase-5.15.12-alt1.noarch
libqt5-qmlmodels-5.15.12-alt1.x86_64
qt5-tools-common-5.15.12-alt1.noarch
libqt5-3dcore-5.15.12-alt1.x86_64
qt5-multimedia-common-5.15.12-alt1.noarch
qt5-base-doc-5.15.12-alt1.x86_64
libqt5-remoteobjects-5.15.12-alt1.x86_64
qt5-base-common-5.15.12-alt1.x86_64
libqt5-qmlworkerscript-5.15.12-alt1.x86_64
qt5-imageformats-common-5.15.12-alt1.noarch
libqt5-webchannel-5.15.12-alt1.x86_64
libqt5-hunspellinputmethod-5.15.12-alt1.x86_64
qt5-graphicaleffects-5.15.12-alt1.x86_64
qt5-declarative-doc-5.15.12-alt1.x86_64
libqt5-widgets-5.15.12-alt1.x86_64
libqt5-quickwidgets-5.15.12-alt1.x86_64
libqt5-designercomponents-5.15.12-alt1.x86_64
qt5-sensors-common-5.15.12-alt1.noarch
libqt5-3dquick-5.15.12-alt1.x86_64
libqt5-webenginecore-5.15.16-alt1.x86_64
libqt5-network-5.15.12-alt1.x86_64
libqt5-concurrent-5.15.12-alt1.x86_64
libqt5-quickcontrols2-5.15.12-alt1.x86_64
libqt5-3dquickanimation-5.15.12-alt1.x86_64
libqt5-webkit-5.212.0-alt24.x86_64
libqt5-core-5.15.12-alt1.x86_64
qt5-3d-5.15.12-alt1.x86_64
qt5-qtbase-gui-5.15.12-alt1.noarch
libqt5-3dquickscene2d-5.15.12-alt1.x86_64
libqt5-positioningquick-5.15.12-alt1.x86_64
libqt5-multimedia-5.15.12-alt1.x86_64
libqt5-xml-5.15.12-alt1.x86_64
libqt5-qml-5.15.12-alt1.x86_64
qt5-location-common-5.15.12-alt1.noarch
libqt5-3drender-5.15.12-alt1.x86_64
qt5-xmlpatterns-common-5.15.12-alt1.noarch
rpm-macros-qt5-5.15.12-alt1.noarch
qt5-designer-5.15.12-alt1.x86_64
libqt5-webkitwidgets-5.212.0-alt24.x86_64
libqt5-nfc-5.15.12-alt1.x86_64
libqtspell-qt5-0.8.5-alt2.1.x86_64
libqt5-eglfskmssupport-5.15.12-alt1.x86_64
libquazip-qt5-0.8.1-alt1.x86_64
libqt5-quickshapes-5.15.12-alt1.x86_64
libqt5-test-5.15.12-alt1.x86_64
qt5-imageformats-5.15.12-alt1.x86_64
qt5-x11extras-common-5.15.12-alt1.noarch
qt5-graphicaleffects-common-5.15.12-alt1.noarch
qt5-virtualkeyboard-5.15.12-alt1.x86_64
qt5-translations-5.15.12-alt1.noarch
libqt5-printsupport-5.15.12-alt1.x86_64
libqt5-opengl-5.15.12-alt1.x86_64
libqt5-help-5.15.12-alt1.x86_64
qt5-svg-common-5.15.12-alt1.noarch
libqt5-3dquickextras-5.15.12-alt1.x86_64
qt5-virtualkeyboard-common-5.15.12-alt1.noarch
libqt5-quickparticles-5.15.12-alt1.x86_64
libqt5-quicktest-5.15.12-alt1.x86_64
libqt5-gui-5.15.12-alt1.x86_64
qt5-quickcontrols2-5.15.12-alt1.x86_64
libqt5-3dlogic-5.15.12-alt1.x86_64
qt5-remoteobjects-common-5.15.12-alt1.noarch
libqt5-sensors-5.15.12-alt1.x86_64
libqt5-3dquickrender-5.15.12-alt1.x86_64
qt5-qmltermwidget-0.2.0-alt1.x86_64
qt5-serialport-common-5.15.12-alt1.noarch
qt5-base-devel-5.15.12-alt1.x86_64
gimagereader-qt5-3.4.1-alt4.x86_64
libqt5-location-5.15.12-alt1.x86_64
qt5-connectivity-common-5.15.12-alt1.noarch
qt5-3d-common-5.15.12-alt1.x86_64
libqt5-dbus-5.15.12-alt1.x86_64
libqt5-sql-5.15.12-alt1.x86_64
qt5-tools-5.15.12-alt1.x86_64
qt5-webchannel-common-5.15.12-alt1.noarch
libqt5-xcbqpa-5.15.12-alt1.x86_64
XD XD XD XD

Оффлайн zerg

  • ненужная строка
  • alt linux team
  • ***
  • Сообщений: 2 495
  • ненужная строка
    • Найдётся всё
Re: QTCreator не видит QMLTermWidget
« Ответ #3 : 17.03.2024 13:52:30 »
система ругается на класс QMLTermWidget и QMLTermSession
Изучайте эту ругань.
Убрать этот мусор можно переключателем: Не показывать подписи других пользователей.

Оффлайн gc986

  • Давно тут
  • **
  • Сообщений: 78
  • Жить, хорошо )))
    • Email
Re: QTCreator не видит QMLTermWidget
« Ответ #4 : 17.03.2024 14:50:17 »
Вообщем разобрался с горем пополам.

Как оказалось, в настройках проекта надо указать следующее (по умолчанию там был только quick)
QT += quick gui core widgets
Далее в главном классе main.cpp необходимо использовать QApplication, заместо QGuiApplication (меняем в конструкторе класса и в импорте).

Я не силён в QML, но по ходу это из-за того что этот класс, QMLTermWidget, наследуется от виджета (ну или типа того), и в таком случае главный класс приложения должен быть QApplication.
« Последнее редактирование: 31.03.2024 13:45:02 от gc986 »
XD XD XD XD