Автор Тема: Недостаточность образов в репозиториях ALT Linux платформы p9  (Прочитано 433 раз)

Оффлайн vadval15

  • Давно тут
  • **
  • Сообщений: 171
Почему в репозиториях ALT Linux платформы p9 отсутствует образ 32-битной версии ОС alt kworkstation? Заранее признателен за ответ.

Оффлайн asy

  • alt linux team
  • ***
  • Сообщений: 7 689
  • Sunny 273 RUS crew
Некоторые дистрибутивы уже не выпускаются для i586. Может быть kworkstation из их числа. А смысл сейчс делать рабочую станцию i586? На железке, которая x86_64 не умеет, будет тоскливо, а если умеет, то надо ставить сразу 64-разрядную.

Ну а уж если действительно нужно такое, возьмите стартеркит какой-нибудь для i586 и поставте пакет kde5-big.

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 174
    • Домашняя страница
    • Email
Почему в репозиториях ALT Linux платформы p9 отсутствует образ 32-битной версии ОС alt kworkstation? Заранее признателен за ответ.
Потому что он выпускается только для x86_64. Если хотите систему с KDE5 под i586, установите Альт Образование без базового образовательного компонента, но со включенным KDE5. Образ Альт Образование 10.0 (пока не анонсированный, но доступный для скачивания): http://ftp.altlinux.ru/pub/distributions/ALTLinux/p10/images/education/i586/alt-education-10.0-i586.iso (7,8 ГБ).
Андрей Черепанов (cas@)

Оффлайн YYY

  • Мастер
  • ***
  • Сообщений: 5 781
А смысл сейчс делать рабочую станцию i586? На железке, которая x86_64 не умеет, будет тоскливо, а если умеет, то надо ставить сразу 64-разрядную.
в 1.5 раза разница по потреблению оперативной памяти. Если 64-битный софт не нужен (скайп/зум), то при размере оперативки менее 4 гигов смысла в 64 нет...

Оффлайн asy

  • alt linux team
  • ***
  • Сообщений: 7 689
  • Sunny 273 RUS crew
в 1.5 раза разница по потреблению оперативной памяти. Если 64-битный софт не нужен
Но он нужен. Тот же FireFox не тестируется на i586. Так что собирается он не благодоря, а вопреки, и закончиться это может в любой момент. И такого ПО всё больше.

Оффлайн vadval15

  • Давно тут
  • **
  • Сообщений: 171
Спасибо всем за советы. Скорее всего, придётся ими воспользоваться. Тем не менее, для ОС alt workstation 32-битная версия образа в репозиториях указанной платформы всё же имеется. В таком случае, получается, что оболочка Mate ещё может работать в ОС с данной версией, а KDE - уже нет, или причина такого несоответствия иная?

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 174
    • Домашняя страница
    • Email
Спросите напрямую у релиз-менеджера Альт Рабочая станция К.
Андрей Черепанов (cas@)

Оффлайн YYY

  • Мастер
  • ***
  • Сообщений: 5 781
в 1.5 раза разница по потреблению оперативной памяти. Если 64-битный софт не нужен
Но он нужен. Тот же FireFox не тестируется на i586. Так что собирается он не благодоря, а вопреки, и закончиться это может в любой момент. И такого ПО всё больше.

- Тебя как, сразу прикончить или желаешь помучиться?
- Лучше, конечно, помучиться.
(c)

Ну пока i686 жив-здоров :)
При наличии старого железа лучше сидеть на 32х битах без тормозни с перспективой когда-нибудь через несколько лет заиметь проблемы, чем  на x64 страдать из-за недостатка оперативы.

Может старый комп помрет быстрее чем ФФ-32 бита перестанет работать :)


« Последнее редактирование: 11.12.2021 20:16:21 от YYY »

Оффлайн Антон Мидюков

  • alt linux team
  • ***
  • Сообщений: 4 497
  • antohami@
На 2 ГБ  оперативы 500 МБ как-то жалко отдавать под DE. Потому и смысла кажется особого нет в kde5 на i586. Ну и на i586 скорее всего проблемы с видео. А kde5 к нему требовательный.

Оффлайн gosts 87

  • Завсегдатай
  • *
  • Сообщений: 1 424
  • Дмитрий/Dmitry/德米特里/दिमित्री
При наличии старого железа лучше сидеть на 32х битах без тормозни с перспективой когда-нибудь через несколько лет заиметь проблемы, чем  на x64 страдать из-за недостатка оперативы.
Ну, не знаю. У меня и на 64 Битах всё нормально, хотя "железо" мощным не назовёшь.
На 32-битной "Винде" "железо" быстрее "накроется"  :-)
« Последнее редактирование: 11.12.2021 21:47:12 от gosts 87 »

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 9 953
в 1.5 раза разница по потреблению оперативной памяти. Если 64-битный софт не нужен
Но он нужен. Тот же FireFox не тестируется на i586.

И толку что FF 64 бит тестируется? :-)
Он у меня дважды в утечку памяти валился. Знаешь что это такое? Это когда компьютер превращается в кирпич. Это когда гуй окирпичен полностью, а набор команды в tty превращается в ад. Но для начала, в этот tty нужно сначала попасть. У меня у сына, фокс 64 бит, сегодня ноутбук с Core i5 и восемью гигами памяти завесил намертво. У которого 8 гигов, это потолок по чипсету.
Что же до 32 бит не нужен, ты в англоязычный саппор мозиллы сходи. Он весь забит вопросами по снижению расхода памяти. Нафик бы упёрлось такое счастье.
Проблема не в 32 бит. Проблема в программистах, у которых руки из жопы растут. Где-то с 54-ой версии, в FF добавили e10s. Что значительно увеличило расход памяти. Причём число процессов контента, по-дефолту стоит в максимуме, - жрать память насколько можно. А чтобы расход памяти стал ещё бОльшим зап*лом, начиная с 68-ой версии FF, мозилла убирает триггер выключения e10s. И теперь для снижения расхода памяти, отрубить его можно только через переменную.

Так что собирается он не благодоря, а вопреки, и закончиться это может в любой момент. И такого ПО всё больше.

Как это "нужно" делается и как эта "кухня" устроена, там за ширмой, это мне уже известно. :-)
Этих программистов-лохотронщиков, поймал за хвост на андроиде 4.2.2:
С точки зрения пользователя, ютуб-клиент в андроид 4.2.2 не поддерживается. И пользователь получит отказ в запуске с предупреждением о неподдерживаемой устаревшей версии. Но пользователь даже не подозревает, что его разводят как лоха.
Убедиться в том что программисты уроды и лохотронщики, достаточно просто, хоть и неочевидно:
После отказа ютуб-клента, его следует закрыть и очистить кеш памяти. Затем идти в настройки управления приложениями и удалить ютуб-клиент вместе с кешем до версии в прошивке. Затем сходить на пока работающий гуглплей и обновить клиент тубы до той же версии, которая была установлена ранее. Не надеясь что это хоть к чему-то приведёт, тыкнуть в иконку клиента для запуска. И о чудо! Ютуб-клиент работает! Но упаси вас бог закрывать клиент с очисткой кеша. Он на повторном запуске снова вывалит отказ запуска с предупреждением об устаревшей версии. Эти твари программисты на повторном запуске сделали проверку версии, чтобы клиент валился с отказом запуска работающего приложения, а пользователь бежал в магазин за новым андроидом.
Как там Андриано Челентано говорил в фильме Блеф?
"Ставь на красное, ставь на чёрное, - всё равно выигрывает зеро."

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 9 953
Споры о том что лучше, 64 бит или 32 бит, длятся уже далеко не один год. Но все они начинаются и заканчиваются на Remap memory. А это уже отдельная тема на предмет, как программисты из пользователя хотят сделать лоха.

Оффлайн vadval15

  • Давно тут
  • **
  • Сообщений: 171
Благодарю всех за ответы. Возможно, этот вопрос отпадёт сам собой  ещё до обновления ОС по причине выхода из строя имеющейся техники.