Автор Тема: При старте выводится сообщение SGX disabled by BIOS  (Прочитано 5440 раз)

Оффлайн nialiv

  • Давно тут
  • **
  • Сообщений: 106
    • Email
У меня установлена Alt Linux Kworkststion 10.2, при старте каждый раз выводится сообщение: "SGX disabled by BIOS" и загрузка приостанавливается. Попытался включить SGX в BIOS, но там только два варианта: "Disabled" и  "Software controlled" (управляется программно), установлен "Software controlled".
На одном из сайтов нашёл информацию, что сделать можно, через настройки файла /etc/default/grub, но не сообщается как. Такую, или похожую строку в файле не нашёл.
Если кто-то знает, как это сделать, пожалуйста, сообщите.
« Последнее редактирование: 04.12.2023 07:19:53 от nialiv »

Оффлайн rits

  • Завсегдатай
  • *
  • Сообщений: 1 076
  • ITS
Ответ ИИ справочника:
1. Откройте терминал и введите команду `su -l`, затем введите пароль суперпользователя.

2. После успешного входа в систему в режиме суперпользователя вы можете выполнить команду
для редактирования файла конфигурации GRUB:

nano /etc/default/grub

3. Найдите строку, начинающуюся с `GRUB_CMDLINE_LINUX_DEFAULT`, и добавьте `nosgx`
к существующим параметрам. Например, строка может выглядеть так:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nosgx"

4. Сохраните изменения, нажав `Ctrl+O`, а затем закройте редактор, нажав `Ctrl+X`.

5. Обновите конфигурацию GRUB, выполнив команду:

grub-mkconfig -o /boot/grub/grub.cfg

6. Перезагрузите систему:

reboot


Теперь при загрузке сообщение "SGX disabled by BIOS" больше не должно появляться.
« Последнее редактирование: 04.12.2023 09:40:16 от rits »

Оффлайн nialiv

  • Давно тут
  • **
  • Сообщений: 106
    • Email
У меня эта строка выглядит так:
GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=/dev/disk/by-uuid/aa31e92d-0640-4193-afab-bedd1fa1500c panic=30 splash psi=1"Она относится к Swap файлу Debian 12, возможно это потому, что система установлена на внешний винчестер USB3_HDD и при установке инсталлятор "подхватил" раздел Swap другой, ранее установленной на SSD системы Debian 12.
Я эту строку в fstab закомментировал, но очевидно, упоминание о нём осталось в системе.
У меня более 12 лет основная система Debian и я изучаю и осваиваю Alt Linux с перспективой перевода её в статус основной системы.
Попробую закомментировать в /default/grub Альта существующую строку и вписать предлагаемую Вами, если получится, обязательно сообщу.
PS: Большое спасибо, всё получилось, система стала загружаться примерно на 30 секунд быстрее.
« Последнее редактирование: 04.12.2023 09:58:40 от nialiv »

Оффлайн Nicom

  • Завсегдатай
  • *
  • Сообщений: 700
Если Вы не пользуетесь спящим режимом, нужно убрать из вашей строки resume=/dev/disk/by-uuid/aa31e92d-0640-4193-afab-bedd1fa1500cи добавить в конец nosgx

Оффлайн nialiv

  • Давно тут
  • **
  • Сообщений: 106
    • Email
Ещё раз спасибо, я вообще всю свою строку, на всякий случай, закомментировал, чтобы вспомнить, при необходимости, что было ранее и вписал Вашу, всё работает нормально.