Автор Тема: Как установить последнюю версию php?  (Прочитано 733 раз)

Оффлайн Garrett

  • Начинающий
  • *
  • Сообщений: 7
Добрый вечер.
Установлена AltLinux XFCE Starter.
Как установить последнюю версию php (на сегодня это 8.3.4)?
В других дистрибутивах(Дебиан,Минт,Федора...) добавляется репозиторий Ондрея и проблем с установкой/обновлением последних версий php нет.
А как это сделать в Альте?
Если не трудно, распишите по шагам.
Спасибо.

Оффлайн буратино-42

  • Давно тут
  • **
  • Сообщений: 100
Как установить последнюю версию php (на сегодня это 8.3.4)?
...
А как это сделать в Альте?
Если не трудно, распишите по шагам.

решение в ОДИН шаг:
1. устанавливаете
 http://nightly.altlinux.org/sisyphus/tested/regular-xfce-latest-x86_64.iso

и проблем с установкой/обновлением последних версий php нет.

Оффлайн gosts 87

  • Завсегдатай
  • *
  • Сообщений: 2 730
  • Дмитрий/Dmitry/德米特里/दिमित्री
решение в ОДИН шаг:
1.
Варианты без смены дистрибутива:
2. Попросить в Багзилле, чтобы из Сизифа перенесли в p10
3. Попытаться собрать самостоятельно
4. Перейти с репозитория p10 на репозиторий Sisyphus (действие аналогично первому варианту, но без переустановки дистрибутива).

Оффлайн Garrett

  • Начинающий
  • *
  • Сообщений: 7
Т.е. нет варианта подключить репозиторий Ондрея и пользоваться его билдами php?

Оффлайн gosts 87

  • Завсегдатай
  • *
  • Сообщений: 2 730
  • Дмитрий/Dmitry/德米特里/दिमित्री
Т.е. нет варианта подключить репозиторий Ондрея и пользоваться его билдами php?
Нет. Архитектуры пакетов в AltLinux и Fedora отличаются. Некоторые пакеты из репозиториев Fedora теоретически можно установить (без пересборки) в AltLinux, но не факт, что этим Вы не сломаете систему и не факт, что установленная (без пересборки) из такого репозитория программа будет корректно работать.
Хотя, кто знает...
« Последнее редактирование: 26.03.2024 01:39:54 от gosts 87 »

Оффлайн Garrett

  • Начинающий
  • *
  • Сообщений: 7
4. Перейти с репозитория p10 на репозиторий Sisyphus (действие аналогично первому варианту, но без переустановки дистрибутива).
Пошел по этому пути. Пока работает)
Спасибо всем.

Оффлайн Garrett

  • Начинающий
  • *
  • Сообщений: 7
Выскажу крамольную мысль.
Если хотите популярности Alt Linux, то надо приложить максимум усилий, чтобы всегда были доступны последние версии языков программирования и средств разработки в текущем репозитории. Не надо на следующий день, но течении недели желательно должны быть доступны без всяких бубнов.
Не надо спрашивать, а зачем вам gcc11(при наличии в природе gcc13!), есть же gcc10. (это по мотивам соседнего топика)
git в Сизифе 2.42.1, это 2-3 месяца назад, если не больше вышел. Текущая версия 2.44 вышла месяц назад. Почему недоступна в основном репозитории?

Да, почти любой пакет (например, git) можно собрать из исходников самому, но зачем?
Берите примеры с мейнтейнеров репо git для Ubuntu, сборки доступны практически сразу.
Ондрей собирает пакеты на последний php для многих дистибутивов мгновенно...

Оффлайн gosts 87

  • Завсегдатай
  • *
  • Сообщений: 2 730
  • Дмитрий/Dmitry/德米特里/दिमित्री
Берите примеры с мейнтейнеров репо git для Ubuntu, сборки доступны практически сразу.
В Альте столько мейнтейнеров нет, сколько в Дебианах и Убунтах...

Оффлайн GrishaDm

  • Давно тут
  • **
  • Сообщений: 345
Цитировать
Если хотите популярности Alt Linux, то надо приложить максимум усилий, чтобы всегда были доступны последние версии языков программирования и средств разработки в текущем репозитории.
Лучшее - враг хорошего. Пусть сначала составят рейтинги языков программирования и ИСР - и топ 10 того  и другого поддерживают. Не надо гнаться за подверсиями, но чтоб версия была последняя. А сейчас допустим какого-нибудь android studio не поддерживается вообще. Это значит сразу многие потенциальные клиенты тупо сразу не выберут альт (никто не будет долбиться - настраивать в сизифе это).

Оффлайн буратино-42

  • Давно тут
  • **
  • Сообщений: 100
Ондрей собирает пакеты на последний php для многих дистибутивов мгновенно...

ещё одно решение:
 5. попросите Ондрея собирать для Альта.

вопрос:
 зачем нужны ПОСЛЕДНИЕ версии php?

Оффлайн Garrett

  • Начинающий
  • *
  • Сообщений: 7
вопрос:
 зачем нужны ПОСЛЕДНИЕ версии php?
8.x.y
x - изменения в языке
y - исправление ошибок.
Релизы выходят в среднем раз в 2-3 месяца.

Я бы вообще бы предложил обновлять не весь зоопарк, а только 2 последние ветки (8.2.y и 8.3.y), если выйдет 8.4, то только 8.3.y и 8.4.y и т.д.

Пусть сначала составят рейтинги языков программирования и ИСР - и топ 10 того  и другого поддерживают.
Если экзотику не брать, то популярных языков немного (~10).
Если выпилить старьё, типа python2, то поддерживать 5-10 компиляторов в актуальном состоянии будет проще.

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 957
    • Домашняя страница
    • Email
Выскажу крамольную мысль.
Если хотите популярности Alt Linux, то надо приложить максимум усилий, чтобы всегда были доступны последние версии языков программирования и средств разработки в текущем репозитории. Не надо на следующий день, но течении недели желательно должны быть доступны без всяких бубнов.
Не надо спрашивать, а зачем вам gcc11(при наличии в природе gcc13!), есть же gcc10. (это по мотивам соседнего топика)
git в Сизифе 2.42.1, это 2-3 месяца назад, если не больше вышел. Текущая версия 2.44 вышла месяц назад. Почему недоступна в основном репозитории?

Да, почти любой пакет (например, git) можно собрать из исходников самому, но зачем?
Берите примеры с мейнтейнеров репо git для Ubuntu, сборки доступны практически сразу.
Ондрей собирает пакеты на последний php для многих дистибутивов мгновенно...
Просто используйте Arch. Там всё самое свежее.
Андрей Черепанов (cas@)

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 957
    • Домашняя страница
    • Email
вопрос:
 зачем нужны ПОСЛЕДНИЕ версии php?
8.x.y
x - изменения в языке
y - исправление ошибок.
Релизы выходят в среднем раз в 2-3 месяца.

Я бы вообще бы предложил обновлять не весь зоопарк, а только 2 последние ветки (8.2.y и 8.3.y), если выйдет 8.4, то только 8.3.y и 8.4.y и т.д.

Пусть сначала составят рейтинги языков программирования и ИСР - и топ 10 того  и другого поддерживают.
Если экзотику не брать, то популярных языков немного (~10).
Если выпилить старьё, типа python2, то поддерживать 5-10 компиляторов в актуальном состоянии будет проще.
python2 не является компилятором. И изменение тулчейна в стабильном репозитории не планируется.
Андрей Черепанов (cas@)

Оффлайн gosts 87

  • Завсегдатай
  • *
  • Сообщений: 2 730
  • Дмитрий/Dmitry/德米特里/दिमित्री
Просто используйте Arch. Там всё самое свежее.
Во-первых, такой совет давать поздно:
Пошел по этому пути. Пока работает)
Во-вторых, лучше-бы пригласили человека в https://www.altlinux.org/Join
 ;-)