Автор Тема: Apache+php  (Прочитано 359 раз)

Оффлайн reiss

  • Давно тут
  • **
  • Сообщений: 208
Apache+php
« : 16.01.2024 12:50:08 »
Появилась необходимость обновить версию ПХП
Установил 8.1
Пытаюсь приучить к ней апач
root@ftpsrv:/etc# a2dismod php8.0
Module php8.0 disabled.
root@ftpsrv:/etc# a2enmod php8.1
Considering dependency mpm_prefork for php8.1:
Considering conflict mpm_event for mpm_prefork:
Considering conflict mpm_worker for mpm_prefork:
Module mpm_prefork already enabled
Considering conflict php5 for php8.1:
Enabling module php8.1.
root@ftpsrv:/etc# service apache2 restart
запускаю phpinfo() а оно как показывало 8.0, так и показывает.
Что я не так делаю? Да, ctrl+F5 жал

Оффлайн GrishaDm

  • Давно тут
  • **
  • Сообщений: 345
Re: Apache+php
« Ответ #1 : 16.01.2024 15:16:47 »
Как установили "php 8.1"? Через Synaptic? Или в командной строке, игнорируя все зависимости?
Честно говоря про подключение вручную в Apache версий php читал в книгах примерно 20-тилетней давности. Вы ими руководствуетесь? Сейчас уже давно это делается автоматически, а в конф. файлах только какую-то тонкую настройку делают.
У меня стоит web-сервер на php 8.2 и установлены следующие пакеты:
apache2-httpd-prefork
apache2-httpd-worker
mariadb
mariadb-server
php8.2-mysqlnd
php8.2-mysqlnd-mysqli
phpMyAdmin
phpMyAdmin-apache2-php8.2
php8.2

Оффлайн reiss

  • Давно тут
  • **
  • Сообщений: 208
Re: Apache+php
« Ответ #2 : 17.01.2024 04:22:29 »
Как установили "php 8.1"?
apt-get install
Сейчас уже давно это делается автоматически,
Ну, как видишь нет. Упрямо видит 8.0

Оффлайн GrishaDm

  • Давно тут
  • **
  • Сообщений: 345
Re: Apache+php
« Ответ #3 : 17.01.2024 06:16:54 »
apt-get install
В этом и проблема. Надо устанавливать из репозиториев, желательно с помощью менеджера, а править конф. файлы только, когда других вариантов нет. Я лично не прописывал ничего (всё через Synaptic), просто сначала поставил версию 8.0, она работала, затем удалил её, тамже установил 8.2 Всё видит и работает.

Оффлайн reiss

  • Давно тут
  • **
  • Сообщений: 208
Re: Apache+php
« Ответ #4 : 18.01.2024 05:21:35 »
Надо устанавливать из репозиториев
Наверное йа криведко, но откуда ставит апт? Не из репозитория ли?
всё через Synaptic
графики нет, как явления

Оффлайн alxl

  • Давно тут
  • **
  • Сообщений: 135
Re: Apache+php
« Ответ #5 : 18.01.2024 14:27:08 »
Не из репозитория ли?
не обязательно. Если скачать с какого нибудь сайта пакет а затем скормить его apt`у, то он его и установит.

Оффлайн reiss

  • Давно тут
  • **
  • Сообщений: 208
Re: Apache+php
« Ответ #6 : 19.01.2024 05:03:43 »
скормить его apt`у, то он его и установит.
ну не балбес же я
apt-get install php8.1
так что все с репы
« Последнее редактирование: 19.01.2024 05:29:51 от reiss »