Автор Тема: ALT Linux LXDEsktop 6.0.0  (Прочитано 137790 раз)

Оффлайн yar007

  • Завсегдатай
  • *
  • Сообщений: 60
    • Email
Re: ALTLinux LXDEsktop 6.0.0
« Ответ #540 : 13.09.2012 21:34:37 »
Сделал service iptables stop и попробовал. То же самое :(
А у вас на LXDesktop только не работает или вообще ?

Потоковый звук в браузере? Только в этом дистрибутиве. На этом же железе и в виндовс и в Simply linux все работает нормально.

Оффлайн berkut_174

  • Мастер
  • ***
  • Сообщений: 7 149
    • Email
Re: ALTLinux LXDEsktop 6.0.0
« Ответ #541 : 14.09.2012 07:20:06 »
Потоковый звук в браузере? Только в этом дистрибутиве. На этом же железе и в виндовс и в Simply linux все работает нормально.
Браузеры какие пробовали ?
Видеоадаптерlspci | grep VGAЯдроrpm -qa | grep kernel | sortxorg.conf сформирован или загружаетесь без него ?

У меня все работает, странно...
Сноси Винду, переходи на Линукс ! :)

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 10 259
Re: ALTLinux LXDEsktop 6.0.0
« Ответ #542 : 14.09.2012 11:46:35 »
Несколько вопросов:
а сам-то ''системный" звук  через usb-гарнитуру идёт или нет?
$ paplay /usr/share/sounds/login.wavили
$ mplayer -nocache -ao pulse /usr/share/sounds/login.wav
pavucontrol знает что звук надо гнать от usb-гарнитуры(card 1; card 0 - "наплатный" чип, вроде б нумерация как-то так) через миксер?
Оффтоп:
бестолковый PA при выборе headphones отрубает _все_ выхода вместо отрубания front с включением headphones.

Может ли как-то влиять наличие/отсутствие
# rpm -qa|grep alsa-plug
alsa-plugins-pulse-1.0.23-alt1.M60T.1

Само потоковое аудио через гарнитуру воспроизводится, что-нибудь из этого?
$ mplayer -nocache http://tuner.country108.com:80$ mplayer -nocache -ao pulse http://scfire-dtc-aa03.stream.aol.com:80/stream/1003$ mplayer -nocache -ao pulse http://nl2.ah.fm:9000!!!: обратите внимание на 'AO:' в первом случае и остальных!

alsamixer только показывает настройки usb-гарнитуры, но не говорит, что soundcard 1, коим и является гарнитура, должна стать приоритетным устройством. ИМХО.

Цитировать
До установки пульс аудио тоже звука не было, зхато после установки - появился регулятор громкости в панели задач.
Местные недоработки с миксером.
« Последнее редактирование: 14.09.2012 15:27:34 от Speccyfighter »

Оффлайн yar007

  • Завсегдатай
  • *
  • Сообщений: 60
    • Email
Re: ALTLinux LXDEsktop 6.0.0
« Ответ #543 : 14.09.2012 18:47:57 »
Потоковый звук в браузере? Только в этом дистрибутиве. На этом же железе и в виндовс и в Simply linux все работает нормально.
Браузеры какие пробовали ?
Видеоадаптерlspci | grep VGAЯдроrpm -qa | grep kernel | sortxorg.conf сформирован или загружаетесь без него ?

У меня все работает, странно...

Пробовал мидори - просто схлопывается. А опера и мозилла - не проигрывают. Там где должно быть изображение плеера на страничке - ничего нет. Исключение составляет, как я уже писал, WMA.

[root@YPL ~]# lspci | grep VGA
01:00.0 VGA compatible controller: NVIDIA Corporation NV34 [GeForce FX 5200] (rev a1)
[root@YPL ~]#

[root@YPL ~]# rpm -qa | grep kernel | sort
kernel-headers-common-1.1.11-alt1
kernel-image-std-def-3.0.24-alt0.M60P.2
kernel-modules-drm-radeon-std-def-3.0.24-alt0.M60P.2
kernel-modules-drm-std-def-3.0.24-alt0.M60P.2
kernel-modules-nvidia-std-def-295.20-alt0.M60P.1.196632.0.M60P.2
kernel-modules-v4l-std-def-3.0.24-alt0.M60P.2
kernel-modules-virtualbox-addition-std-def-4.1.4-alt0.M60P.196632.0.M60P.2
update-kernel-0.9.4-alt2


xorg.conf был подправлен утилитой nvidia-xconfig и после этого разрешение монитора стало нормальным (до этого пытался выставить, почему-то не сохранялось). Но секции о звуке в этом файле нет.
« Последнее редактирование: 14.09.2012 18:50:06 от yar007 »

Оффлайн berkut_174

  • Мастер
  • ***
  • Сообщений: 7 149
    • Email
Re: ALTLinux LXDEsktop 6.0.0
« Ответ #544 : 14.09.2012 19:13:52 »
yar007
А если с LiveCD загрузиться — работает ?
А ещё покажите лог Xorg, да и сам xorg.conf на всякий случай.
Через Chromium попробуйте тоже.
Сноси Винду, переходи на Линукс ! :)

Оффлайн yar007

  • Завсегдатай
  • *
  • Сообщений: 60
    • Email
Re: ALTLinux LXDEsktop 6.0.0
« Ответ #545 : 14.09.2012 19:15:16 »
Несколько вопросов:
а сам-то ''системный" звук  через usb-гарнитуру идёт или нет?
$ paplay /usr/share/sounds/login.wavили
$ mplayer -nocache -ao pulse /usr/share/sounds/login.wav
pavucontrol знает что звук надо гнать от usb-гарнитуры(card 1; card 0 - "наплатный" чип, вроде б нумерация как-то так) через миксер?
Оффтоп:
бестолковый PA при выборе headphones отрубает _все_ выхода вместо отрубания front с включением headphones.

Может ли как-то влиять наличие/отсутствие
# rpm -qa|grep alsa-plug
alsa-plugins-pulse-1.0.23-alt1.M60T.1

Само потоковое аудио через гарнитуру воспроизводится, что-нибудь из этого?
$ mplayer -nocache http://tuner.country108.com:80$ mplayer -nocache -ao pulse http://scfire-dtc-aa03.stream.aol.com:80/stream/1003$ mplayer -nocache -ao pulse http://nl2.ah.fm:9000!!!: обратите внимание на 'AO:' в первом случае и остальных!

alsamixer только показывает настройки usb-гарнитуры, но не говорит, что soundcard 1, коим и является гарнитура, должна стать приоритетным устройством. ИМХО.

Цитировать
До установки пульс аудио тоже звука не было, зхато после установки - появился регулятор громкости в панели задач.
Местные недоработки с миксером.

Просто mp3 с флэшки - проигрываются. А те файлы что вы указали - нет в наличии. Я попообовал те что лежат в соседних папках. Плеер запускается, а результата нет. :(
[root@YPL purple]# paplay /usr/share/sounds/purple/login.wav
[root@YPL purple]# mplayer -nocache -ao pulse /usr/share/sounds/purple/login.wav
Creating config file: /root/.mplayer/config
MPlayer 32772-4.5.3 (C) 2000-2011 MPlayer Team
161 audio & 351 video codecs

Playing /usr/share/sounds/purple/login.wav.
Audio only file format detected.
Load subtitles in /usr/share/sounds/purple/
==========================================================================
Opening audio decoder: [pcm] Uncompressed PCM audio decoder
AUDIO: 22050 Hz, 2 ch, s16le, 705.6 kbit/100.00% (ratio: 88200->88200)
Selected audio codec: [pcm] afm: pcm (Uncompressed PCM)
==========================================================================
AO: [pulse] 22050Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A:   1.8 (01.7) of 2.0 (02.0)  0.2%


Exiting... (End of file)

Насчет pavucontrol - не  знаю как проверить. Это не гарнитура, просто клавиатура со звуковой картой :)

Плагин алса вроде есть (если я правильно понял, что делаю):

[root@YPL ~]# rpm -qa|grep alsa-plug
alsa-plugins-pulse-1.0.23-alt1.M60T.1
[root@YPL ~]#


Все линки на потоковае аудио работают!
[root@YPL ~]# mplayer -nocache -ao pulse http://nl2.ah.fm:9000
MPlayer 32772-4.5.3 (C) 2000-2011 MPlayer Team
161 audio & 351 video codecs

Playing http://nl2.ah.fm:9000.
Resolving nl2.ah.fm for AF_INET...
Connecting to server nl2.ah.fm[62.204.64.8]: 9000...

Name   : AH.FM - Leading Trance Radio
Genre  : Electronic Trance Dance
Website: http://www.AH.FM
Public : yes
Bitrate: 192kbit/s
Cache size set to 0 KBytes
Cannot seek backward in linear streams!
Cannot seek backward in linear streams!
Audio only file format detected.
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
mpg123: Can't rewind stream by 1020 bits!
AUDIO: 44100 Hz, 2 ch, s16le, 192.0 kbit/13.61% (ratio: 24000->176400)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
AO: [pulse] 44100Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A:   0.3 (00.2) of -0.0 (unknown) 80.9%

ICY Info: StreamTitle='Vicky Wood - Dark Energy Radio 003 on AH.FM';StreamUrl='';
A:   9.4 (09.3) of -0.0 (unknown) 179.4%


MPlayer interrupted by signal 2 in module: decode_audio
A:   9.5 (09.5) of -0.0 (unknown) 178.7%

Exiting... (Quit)

ВСЕ ПРОИГРЫВАЕТСЯ! СЛУЧИЛОСЬ ЧУДО? Получается, что не работает просто плагин в браузерах?







Оффлайн yar007

  • Завсегдатай
  • *
  • Сообщений: 60
    • Email
Re: ALTLinux LXDEsktop 6.0.0
« Ответ #546 : 14.09.2012 19:24:33 »
yar007
А если с LiveCD загрузиться — работает ?
А ещё покажите лог Xorg, да и сам xorg.conf на всякий случай.
Через Chromium попробуйте тоже.

LiveCD - не пробовал. Это старенький комп. На нем DVD нет. А в этом дистрибутиве нет загрузки Live CD

А где лог Xorg  посмотреть? Сам xorg.conf
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 304.37  (builder@localhost.localdomain)  Tue Aug 14 15:20:19 UTC 2012

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Через хромиум попробую, но, наверное, уже завтра.
« Последнее редактирование: 15.09.2012 15:04:02 от Skull »

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 10 259
Re: ALTLinux LXDEsktop 6.0.0
« Ответ #547 : 15.09.2012 01:54:47 »
ВСЕ ПРОИГРЫВАЕТСЯ! СЛУЧИЛОСЬ ЧУДО?
Чуда нет.
mplayer если ему не указать через что надо гнать звук, дефолтом гонит его через alsa. Даже если alsa до конца не сконфигурирована. В mplayer через alsa с pulse не работают хоткеи регулировки громкости: '9/0'. Для этого и указывается '-ao pulse'.

Все линки на потоковае аудио работают!
Уже хорошо.

Получается, что не работает просто плагин в браузерах?
А вот это вопрос риторический.

Насчет pavucontrol - не  знаю как проверить. Это не гарнитура, просто клавиатура со звуковой картой :)
Про pavucontrol и pulseaudio вообще.
Я ведь не зря вставил в предыдущее, оффтоп про пульсу.
Вот тому бы студенту который сваял альфа-код и засунул его в продакшн, а потом забил на него, руки бы поотрывать.
Суть в следующем.
В pavucontrol 'Устройства вывода'  переключает выхода. По-идее (две звуковухи не пользовал и конфигов не видел) там должно быть и дополнительное звуковое устройство. Но поскольку там непреодолимый баг, даже если устройство отображается, нет никакой гарантии что оно переключится, чтобы стать дефолтно активным выводом.
Кратко суть описывал в xfce издаёт звук.
Но если выбор в pavucontrol у вас заработает, то будет совсем замечательно.
У меня с HDA не пашет.

Цитировать
Это старенький комп.
Что значит старенький комп? :)
Уже на первопнях в TX98 некоторых моделей был саундчип.
Тут бы с картами разобраться...
Сложность в том, что грабли надо курить по двум дорогам. Вторая - связка браузер/плагин-контейнер/флеш.

Я попообовал те что лежат в соседних папках. Плеер запускается, а результата нет. :(
[root@YPL purple]# paplay /usr/share/sounds/purple/login.wav[root@YPL purple]# mplayer -nocache -ao pulse /usr/share/sounds/purple/login.wav
...
==========================================================================
Opening audio decoder: [pcm] Uncompressed PCM audio decoder
AUDIO: 22050 Hz, 2 ch, s16le, 705.6 kbit/100.00% (ratio: 88200->88200)
Selected audio codec: [pcm] afm: pcm (Uncompressed PCM)
==========================================================================
AO: [pulse] 22050Hz 2ch s16le (2 bytes per sample)
...
А вот это уже плохонько...

Тут наверное надо еще посмотреть содержимое
$ cat /proc/asound/cards
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xfebf8000 irq 44
$ ls -F /dev/snd/
by-path/  controlC0  hwC0D0  pcmC0D0c  pcmC0D0p  pcmC0D1c  pcmC0D1p  seq  timer
У меня карта одна - дефолтная 0. pcmКарта/Девайс
Наверняка ваш вывод покажет две.
Надо смотреть какая дефолтная. Она - 0.

Как вывести звук через alsa через произвольный девайс, - наверное как-то так:
$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: AD198x Digital [AD198x Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
$ aplay -L
null
    Discard all samples (playback) or generate zero samples (capture)
front:CARD=Intel,DEV=0
    HDA Intel, AD198x Analog
    Front speakers
surround40:CARD=Intel,DEV=0
    HDA Intel, AD198x Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=Intel,DEV=0
    HDA Intel, AD198x Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=Intel,DEV=0
    HDA Intel, AD198x Analog
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=Intel,DEV=0
    HDA Intel, AD198x Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=Intel,DEV=0
    HDA Intel, AD198x Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=Intel,DEV=0
    HDA Intel, AD198x Digital
    IEC958 (S/PDIF) Digital Audio Output
$ aplay --device=plughw:CARD=Intel,DEV=0 /usr/share/sounds/login.wav
Playing WAVE '/usr/share/sounds/login.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
$ mplayer -nocache -ao alsa:device=hw=0 /usr/share/sounds/login.wav
MPlayer 32772-4.5.3 (C) 2000-2011 MPlayer Team
161 audio & 351 video codecs

Playing /usr/share/sounds/login.wav.
Audio only file format detected.
Load subtitles in /usr/share/sounds/
==========================================================================
Opening audio decoder: [pcm] Uncompressed PCM audio decoder
AUDIO: 44100 Hz, 2 ch, s16le, 1411.2 kbit/100.00% (ratio: 176400->176400)
Selected audio codec: [pcm] afm: pcm (Uncompressed PCM)
==========================================================================
AO: [alsa] 44100Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A:   4.7 (04.6) of 5.0 (05.0)  0.1%


Exiting... (End of file)
# fuser -v /dev/snd/*
                     ПОЛЬЗ-ЛЬ    PID ДОСТУП КОМАНДА
/dev/snd/controlC0:  user    10335 F.... pulseaudio
/dev/snd/pcmC0D0p:   user     7872 F...m mplayer
# fuser -v /dev/snd/*
                     ПОЛЬЗ-ЛЬ    PID ДОСТУП КОМАНДА
/dev/snd/controlC0:  user    10335 F.... pulseaudio
/dev/snd/pcmC0D0p:   user    10433 F...m aplay
Карта одна, поэтому и выбирать не из чего.
Но как это же сделать к примеру через paplay+pulseaudio да леший его знает.
Наверное надо смотреть куда-то в поиск гугла на предмет '--device=' чтобы задать принудительно устройство вывода.
Ну и предварительно наверное надо глянуть в
$ pactl listчтобы знать имя этого девайса.

Для меня проигрывание наверное будет выглядеть как
$ paplay --device=alsa_output.pci-0000_00_1b.0.analog-stereo /usr/share/sounds/login.wav# fuser -v /dev/snd/*
                     ПОЛЬЗ-ЛЬ    PID ДОСТУП КОМАНДА
/dev/snd/controlC0:  user    10335 F.... pulseaudio
/dev/snd/pcmC0D0p:   user    10335 F...m pulseaudio

Была бы вторая карта, можно было бы перенаправить звук в другую.
Зачем нужен этот бубен?
Чтобы выяснить:
если опции и параметры для вывода через другой девайс заданы правильно и звук в нужном девайсе есть, то задать дефолтом его. В alsa делалось индексированием в системном конфиге. Если всё правильно и звука нет, значит смотреть в сторону флеша.
Т.е. определиться, где грабли-то лежат.

Принципиальной разницы между usb-ушами и usb-клавиатурой со звуком нет. Всё равно это вторая карта.

Поскольку с двумя звуковухами сразу дела иметь не приходилось выкуривались ресурсы:
Документация Gentoo Linux -- Руководство ALSA в Gentoo Linux
http://www.gentoo.org/doc/ru/alsa-guide.xml
"aplay -device=" - Поиск в Google
[ALSA] dmix работает только с default device - General - Форум
http://www.linux.org.ru/forum/general/7003731
Отсутствие звука. Да, я видел FAQ и 4 способа решения...
http://forum.ubuntu.ru/index.php?topic=188576.0
Форум программистов [Powered by Invision Power Board]
http://forum.vingrad.ru/act-Print/client/printer/f-135/t-351347.html
"paplay -device=" - Поиск в Google
[pulseaudio-discuss] No source (typo, should be sound) from pulseaudio.. alsa is working fine though..
http://lists.freedesktop.org/archives/pulseaudio-discuss/2012-February/012744.html
Всё о немногом и немного обо всём: Март 2011
http://all-abouts-all.blogspot.com/2011_03_01_archive.html
как сделать стриминг и решить Audio : No sound - unixforum.org
http://unixforum.org/index.php?showtopic=130235
usb headphones linux - Поиск в Google
usb гарнитура linux - Поиск в Google
[РЕШЕНО] Как вывести звук на USB-наушники? • Русскоязычное сообщество Arch Linux
http://archlinux.org.ru/forum/viewtopic.php?f=18&t=8907
USB-наушники и alsa - Desktop - Форум
http://www.linux.org.ru/forum/desktop/6910911?lastmod=1319530418873#comment-6912033
Deciphering Glyph: The Dark Art of Sound on Linux
http://glyph.twistedmatrix.com/2009/01/dark-art-of-sound-on-linux.html
ru_ubuntu: USB наушники на Ubuntu
http://ru-ubuntu.livejournal.com/434598.html
Linux.MD • Vezi subiect - USB Headset - с чего начать ?
http://forum.linux.md/viewtopic.php?f=19&t=697
Logitech PC 960 USB Stereo Headset — Gentoo Linux Wiki
http://ru.gentoo-wiki.com/wiki/Logitech_PC_960_USB_Stereo_Headset
Debian Lenny + USB Audio HeadPhones - unixforum.org
http://unixforum.org/index.php?showtopic=115859
[РЕШЕНО] Перестали работать usb наушники в 10.04
http://forum.ubuntu.ru/index.php?topic=93912.0
« Последнее редактирование: 15.09.2012 02:45:05 от Speccyfighter »

Оффлайн yar007

  • Завсегдатай
  • *
  • Сообщений: 60
    • Email
Re: ALTLinux LXDEsktop 6.0.0
« Ответ #548 : 15.09.2012 14:10:01 »
ВСЕ ПРОИГРЫВАЕТСЯ! СЛУЧИЛОСЬ ЧУДО?
Чуда нет.
mplayer если ему не указать через что надо гнать звук, дефолтом гонит его через alsa. Даже если alsa до конца не сконфигурирована. В mplayer через alsa с pulse не работают хоткеи регулировки громкости: '9/0'. Для этого и указывается '-ao pulse'.

Все линки на потоковае аудио работают!
Уже хорошо.

Получается, что не работает просто плагин в браузерах?
А вот это вопрос риторический.

Насчет pavucontrol - не  знаю как проверить. Это не гарнитура, просто клавиатура со звуковой картой :)
Про pavucontrol и pulseaudio вообще.
Я ведь не зря вставил в предыдущее, оффтоп про пульсу.
Вот тому бы студенту который сваял альфа-код и засунул его в продакшн, а потом забил на него, руки бы поотрывать.
Суть в следующем.
В pavucontrol 'Устройства вывода'  переключает выхода. По-идее (две звуковухи не пользовал и конфигов не видел) там должно быть и дополнительное звуковое устройство. Но поскольку там непреодолимый баг, даже если устройство отображается, нет никакой гарантии что оно переключится, чтобы стать дефолтно активным выводом.
Кратко суть описывал в xfce издаёт звук.
Но если выбор в pavucontrol у вас заработает, то будет совсем замечательно.
У меня с HDA не пашет.

Цитировать
Это старенький комп.
Что значит старенький комп? :)
Уже на первопнях в TX98 некоторых моделей был саундчип.
Тут бы с картами разобраться...
Сложность в том, что грабли надо курить по двум дорогам. Вторая - связка браузер/плагин-контейнер/флеш.

Я попообовал те что лежат в соседних папках. Плеер запускается, а результата нет. :(
[root@YPL purple]# paplay /usr/share/sounds/purple/login.wav[root@YPL purple]# mplayer -nocache -ao pulse /usr/share/sounds/purple/login.wav
...
==========================================================================
Opening audio decoder: [pcm] Uncompressed PCM audio decoder
AUDIO: 22050 Hz, 2 ch, s16le, 705.6 kbit/100.00% (ratio: 88200->88200)
Selected audio codec: [pcm] afm: pcm (Uncompressed PCM)
==========================================================================
AO: [pulse] 22050Hz 2ch s16le (2 bytes per sample)
...
А вот это уже плохонько...

Тут наверное надо еще посмотреть содержимое
$ cat /proc/asound/cards
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xfebf8000 irq 44
$ ls -F /dev/snd/
by-path/  controlC0  hwC0D0  pcmC0D0c  pcmC0D0p  pcmC0D1c  pcmC0D1p  seq  timer
У меня карта одна - дефолтная 0. pcmКарта/Девайс
Наверняка ваш вывод покажет две.
Надо смотреть какая дефолтная. Она - 0.

Как вывести звук через alsa через произвольный девайс, - наверное как-то так:
$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: AD198x Digital [AD198x Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
$ aplay -L
null
    Discard all samples (playback) or generate zero samples (capture)
front:CARD=Intel,DEV=0
    HDA Intel, AD198x Analog
    Front speakers
surround40:CARD=Intel,DEV=0
    HDA Intel, AD198x Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=Intel,DEV=0
    HDA Intel, AD198x Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=Intel,DEV=0
    HDA Intel, AD198x Analog
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=Intel,DEV=0
    HDA Intel, AD198x Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=Intel,DEV=0
    HDA Intel, AD198x Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=Intel,DEV=0
    HDA Intel, AD198x Digital
    IEC958 (S/PDIF) Digital Audio Output
$ aplay --device=plughw:CARD=Intel,DEV=0 /usr/share/sounds/login.wav
Playing WAVE '/usr/share/sounds/login.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
$ mplayer -nocache -ao alsa:device=hw=0 /usr/share/sounds/login.wav
MPlayer 32772-4.5.3 (C) 2000-2011 MPlayer Team
161 audio & 351 video codecs

Playing /usr/share/sounds/login.wav.
Audio only file format detected.
Load subtitles in /usr/share/sounds/
==========================================================================
Opening audio decoder: [pcm] Uncompressed PCM audio decoder
AUDIO: 44100 Hz, 2 ch, s16le, 1411.2 kbit/100.00% (ratio: 176400->176400)
Selected audio codec: [pcm] afm: pcm (Uncompressed PCM)
==========================================================================
AO: [alsa] 44100Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A:   4.7 (04.6) of 5.0 (05.0)  0.1%


Exiting... (End of file)
# fuser -v /dev/snd/*
                     ПОЛЬЗ-ЛЬ    PID ДОСТУП КОМАНДА
/dev/snd/controlC0:  user    10335 F.... pulseaudio
/dev/snd/pcmC0D0p:   user     7872 F...m mplayer
# fuser -v /dev/snd/*
                     ПОЛЬЗ-ЛЬ    PID ДОСТУП КОМАНДА
/dev/snd/controlC0:  user    10335 F.... pulseaudio
/dev/snd/pcmC0D0p:   user    10433 F...m aplay
Карта одна, поэтому и выбирать не из чего.
Но как это же сделать к примеру через paplay+pulseaudio да леший его знает.
Наверное надо смотреть куда-то в поиск гугла на предмет '--device=' чтобы задать принудительно устройство вывода.
Ну и предварительно наверное надо глянуть в
$ pactl listчтобы знать имя этого девайса.

Для меня проигрывание наверное будет выглядеть как
$ paplay --device=alsa_output.pci-0000_00_1b.0.analog-stereo /usr/share/sounds/login.wav# fuser -v /dev/snd/*
                     ПОЛЬЗ-ЛЬ    PID ДОСТУП КОМАНДА
/dev/snd/controlC0:  user    10335 F.... pulseaudio
/dev/snd/pcmC0D0p:   user    10335 F...m pulseaudio

Была бы вторая карта, можно было бы перенаправить звук в другую.
Зачем нужен этот бубен?
Чтобы выяснить:
если опции и параметры для вывода через другой девайс заданы правильно и звук в нужном девайсе есть, то задать дефолтом его. В alsa делалось индексированием в системном конфиге. Если всё правильно и звука нет, значит смотреть в сторону флеша.
Т.е. определиться, где грабли-то лежат.

Принципиальной разницы между usb-ушами и usb-клавиатурой со звуком нет. Всё равно это вторая карта.

Поскольку с двумя звуковухами сразу дела иметь не приходилось выкуривались ресурсы:
Документация Gentoo Linux -- Руководство ALSA в Gentoo Linux
http://www.gentoo.org/doc/ru/alsa-guide.xml
"aplay -device=" - Поиск в Google
[ALSA] dmix работает только с default device - General - Форум
http://www.linux.org.ru/forum/general/7003731
Отсутствие звука. Да, я видел FAQ и 4 способа решения...
http://forum.ubuntu.ru/index.php?topic=188576.0
Форум программистов [Powered by Invision Power Board]
http://forum.vingrad.ru/act-Print/client/printer/f-135/t-351347.html
"paplay -device=" - Поиск в Google
[pulseaudio-discuss] No source (typo, should be sound) from pulseaudio.. alsa is working fine though..
http://lists.freedesktop.org/archives/pulseaudio-discuss/2012-February/012744.html
Всё о немногом и немного обо всём: Март 2011
http://all-abouts-all.blogspot.com/2011_03_01_archive.html
как сделать стриминг и решить Audio : No sound - unixforum.org
http://unixforum.org/index.php?showtopic=130235
usb headphones linux - Поиск в Google
usb гарнитура linux - Поиск в Google
[РЕШЕНО] Как вывести звук на USB-наушники? • Русскоязычное сообщество Arch Linux
http://archlinux.org.ru/forum/viewtopic.php?f=18&t=8907
USB-наушники и alsa - Desktop - Форум
http://www.linux.org.ru/forum/desktop/6910911?lastmod=1319530418873#comment-6912033
Deciphering Glyph: The Dark Art of Sound on Linux
http://glyph.twistedmatrix.com/2009/01/dark-art-of-sound-on-linux.html
ru_ubuntu: USB наушники на Ubuntu
http://ru-ubuntu.livejournal.com/434598.html
Linux.MD • Vezi subiect - USB Headset - с чего начать ?
http://forum.linux.md/viewtopic.php?f=19&t=697
Logitech PC 960 USB Stereo Headset — Gentoo Linux Wiki
http://ru.gentoo-wiki.com/wiki/Logitech_PC_960_USB_Stereo_Headset
Debian Lenny + USB Audio HeadPhones - unixforum.org
http://unixforum.org/index.php?showtopic=115859
[РЕШЕНО] Перестали работать usb наушники в 10.04
http://forum.ubuntu.ru/index.php?topic=93912.0

Не все понятно, что здесь написано, но, попытаюсь :)

Вроде бы в pavucontrol есть выбор: Analog Speakers и Аналоговый выход.

Старенький комп - это PIII-800 Mhz 512 Mb

[root@YPL ~]# cat /proc/asound/cards
 0 [Set            ]: USB-Audio - C-Media USB Headphone Set
                      C-Media USB Headphone Set at usb-0000:00:07.2-2.1, full speed

[root@YPL ~]# ls -F /dev/snd/
by-id/  by-path/  controlC0  pcmC0D0c  pcmC0D0p  seq  timer
[root@YPL ~]#

Дальше пытаюсь делать - что-то непонятное
[yar@YPL ~]$ aplay -l
bash: aplay: команда не найдена
[yar@YPL ~]$


Команда pactl list выдает слишком много всего. Не знаю как это сюда вставить.

По моему скромному мнению надо идти по второй дороге - в сторону флеша, ведь звук WMA через браузер работает, хотя и не долго :)

P.S. В хромиуме тоже звука нет. Но там на том место где должен быть плеер на страничке - надпись "Плагин не загружен".

Оффлайн berkut_174

  • Мастер
  • ***
  • Сообщений: 7 149
    • Email
Re: ALTLinux LXDEsktop 6.0.0
« Ответ #549 : 15.09.2012 14:24:54 »
yar007
Лог /var/log/Xorg.0.log

У меня такое предположение, что вы на vesa загружаетесь... я вот не знаю на ней флэш работает или нет...
Сноси Винду, переходи на Линукс ! :)

Оффлайн yar007

  • Завсегдатай
  • *
  • Сообщений: 60
    • Email
Re: ALTLinux LXDEsktop 6.0.0
« Ответ #550 : 15.09.2012 14:29:56 »
yar007
Лог /var/log/Xorg.0.log

У меня такое предположение, что вы на vesa загружаетесь... я вот не знаю на ней флэш работает или нет...

« Последнее редактирование: 15.09.2012 14:46:07 от yar007 »

Оффлайн berkut_174

  • Мастер
  • ***
  • Сообщений: 7 149
    • Email
Re: ALTLinux LXDEsktop 6.0.0
« Ответ #551 : 15.09.2012 14:32:12 »
Модераторы ругаться не будут? Он длинный :)
Лучше вложением сделайте, отредактировав свой пост.
Сноси Винду, переходи на Линукс ! :)

Оффлайн berkut_174

  • Мастер
  • ***
  • Сообщений: 7 149
    • Email
Re: ALTLinux LXDEsktop 6.0.0
« Ответ #552 : 15.09.2012 14:44:24 »
Вообще я бы поступил так.
Установил # apt-get update
# apt-get install kernel-modules-drm-nouveau-std-def
(тут ядро ещё обновится) после обновить остальные модули# update-kernelНа время убрал xorg.conf # mv /etc/X11/xorg.conf /etc/X11/xorg.conf.defСоздал нового пользователя.
Перезапустил систему.
И зашел бы под новым пользователем выполнил # alsactl restore и проверил — работает или нет.

Больше даже не знаю что посоветовать... какая-то чертовщина творится...
Сноси Винду, переходи на Линукс ! :)

Оффлайн yar007

  • Завсегдатай
  • *
  • Сообщений: 60
    • Email
Re: ALTLinux LXDEsktop 6.0.0
« Ответ #553 : 16.09.2012 14:01:08 »
Вообще я бы поступил так.
Установил # apt-get update
# apt-get install kernel-modules-drm-nouveau-std-def
(тут ядро ещё обновится) после обновить остальные модули# update-kernelНа время убрал xorg.conf # mv /etc/X11/xorg.conf /etc/X11/xorg.conf.defСоздал нового пользователя.
Перезапустил систему.
И зашел бы под новым пользователем выполнил # alsactl restore и проверил — работает или нет.

Больше даже не знаю что посоветовать... какая-то чертовщина творится...

Неа :(. После этих телодвижений загрузка системы перестала быть алфавитно-цифровой и появился графический прогресс-бар.

Оффлайн berkut_174

  • Мастер
  • ***
  • Сообщений: 7 149
    • Email
Re: ALTLinux LXDEsktop 6.0.0
« Ответ #554 : 16.09.2012 14:08:06 »
Неа :(. После этих телодвижений загрузка системы перестала быть алфавитно-цифровой и появился графический прогресс-бар.
А у вас звуковая USB что ли ?
Может вам тогда ядра поновее попробовать ? Например un-def или un-test (самое новое).
update-kernel -t un-def
Сноси Винду, переходи на Линукс ! :)