Автор Тема: ALT 4.1 Lite Beta: totem-gstreamer: не поддерживает проприоритарные форматы?  (Прочитано 9247 раз)

kda

  • Гость
Всем привет,

Установил вчера на ноутбук ALT 4.1 Lite Beta. Вместо идущего по умолчанию xine-ui поставил totem-gstreamer. У него наблюдаются 2 проблемы:

1. Нет звука при просмотре Video в проприоритарных форматах. Только в .ogv.
2. Не проигрывает mp3. Выдается сообщение "Для воспроизведения этого видео требуется модуль Декодер MPEG-1 Layer 3 (MP3), который не установлен в системе".

Установленные плагины gstreamer:

libgst-plugins-0.10.20-alt0.M41.1
gst-plugins-container-formats-0.10.0-alt2
gst-plugins-tags-0.10.0-alt2
gst-plugins-subtitle-0.10.0-alt2
libgstreamer-0.10.20-alt0.M41.1
gst-plugins-ugly-0.10.8-alt0.M41.1
gst-ffmpeg-0.10.3-alt3.M41.1
gst-plugins-audio-filters-0.10.0-alt2
gst-plugins-network-0.10.0-alt2
gst-plugins-gconf-0.10.9-alt0.M41.1
gst-plugins-bad-0.10.8-alt0.M41.1
gst-plugins-good-0.10.9-alt0.M41.1
gst-plugins-gnomevfs-0.10.20-alt0.M41.1
gst-plugins-video-formats-0.10.0-alt2
gstreamer-pitfdll-0.9.1.1-alt2.20080215
gstreamer-0.10.20-alt0.M41.1
gst-plugins-video-filters-0.10.0-alt2
gst-plugins-base-0.10.20-alt0.M41.1
gst-plugins-audio-formats-0.10.0-alt2

А так же ffmpeg.
w32codecs в репозиториях не нашел.
В чем может быть проблема? Неужели так же как и в Fedora  "вырезали" из gstreamer  поддержку проприоритарных форматов?
Спасибо.

NotHAM

  • Гость
Всем привет,

Установил вчера на ноутбук ALT 4.1 Lite Beta. Вместо идущего по умолчанию xine-ui поставил totem-gstreamer. У него наблюдаются 2 проблемы:

1. Нет звука при просмотре Video в проприоритарных форматах. Только в .ogv.
2. Не проигрывает mp3. Выдается сообщение "Для воспроизведения этого видео требуется модуль Декодер MPEG-1 Layer 3 (MP3), который не установлен в системе"

Пробовал totem в ALT 4.1 Gnome Beta - для .mp3 был тот-же вопрос, файлов .ogv не имею - ничего не могу сказать.
Для себя проблему решил просто. В ALT 4.0.2 Lite и в ALT 4.1 Lite Beta вместо xine/xmms просто устанавливаю
SMplayer. Для ALT 4.0.2 - из бранча 4.0, а для ALT 4.1 - из сизифа (в бранче 4.1 был с небольшим глюком).
И никаких проблем. И выглядит очень хорошо.
Totem - он вообще-то гномовский, не знаю как под lite себя ведет, не пробовал.

kda

  • Гость
totem-gstreamer прекрасно работает в XFCE. Да и нравится он мне гораздо больше чем любой другой плейер. Спрашиваю потому, что в 4.0.3 у меня все работало.

Оффлайн ab

  • alt linux team
  • ***
  • Сообщений: 36
  • Непарный валенок
    • Email
Покажите вывод команды gst-inspect.

kda

  • Гость
Покажите вывод команды gst-inspect.

Т.е gst-inspector? Не знаю какой вывод имелся ввиду, но при запуске его в консоли можно наблюдать следующие ошибки:
(gst-inspector:19470): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstmpegaudioparse.so': /usr/lib/gstreamer-0.10/libgstmpegaudioparse.so: undefined symbol: __gst_debug_min

(gst-inspector:19470): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstasf.so': /usr/lib/gstreamer-0.10/libgstasf.so: undefined symbol: __gst_debug_min

(gst-inspector:19470): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstmad.so': /usr/lib/gstreamer-0.10/libgstmad.so: undefined symbol: __gst_debug_min

(gst-inspector:19470): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstmpeg2dec.so': /usr/lib/gstreamer-0.10/libgstmpeg2dec.so: undefined symbol: __gst_debug_min

(gst-inspector:19470): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstmpegstream.so': /usr/lib/gstreamer-0.10/libgstmpegstream.so: undefined symbol: __gst_debug_min

(gst-inspector:19470): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgsta52dec.so': /usr/lib/gstreamer-0.10/libgsta52dec.so: undefined symbol: __gst_debug_min

(gst-inspector:19470): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libpitfdll.so': /usr/lib/gstreamer-0.10/libpitfdll.so: undefined symbol: __gst_debug_min

(gst-inspector:19470): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstiec958.so': /usr/lib/gstreamer-0.10/libgstiec958.so: undefined symbol: __gst_debug_min

(gst-inspector:19470): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstrmdemux.so': /usr/lib/gstreamer-0.10/libgstrmdemux.so: undefined symbol: __gst_debug_min

(gst-inspector:19470): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstdvdsub.so': /usr/lib/gstreamer-0.10/libgstdvdsub.so: undefined symbol: __gst_debug_min

(gst-inspector:19470): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstdvdread.so': /usr/lib/gstreamer-0.10/libgstdvdread.so: undefined symbol: __gst_debug_min

(gst-inspector:19470): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstlame.so': /usr/lib/gstreamer-0.10/libgstlame.so: undefined symbol: __gst_debug_min

(gst-inspector:19470): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstdvdlpcmdec.so': /usr/lib/gstreamer-0.10/libgstdvdlpcmdec.so: undefined symbol: __gst_debug_min


P.S Кстати, модуль gst-inspector собран без поддержки необходимого ему для работы python-module-gst.

Оффлайн ab

  • alt linux team
  • ***
  • Сообщений: 36
  • Непарный валенок
    • Email
Нет, команды /usr/bin/gst-inspect из пакета gstreamer-tools.

kda

  • Гость
Нет, команды /usr/bin/gst-inspect из пакета gstreamer-tools.

gstreamer-utils?  Файл с выводом команды присоединил.

Оффлайн ab

  • alt linux team
  • ***
  • Сообщений: 36
  • Непарный валенок
    • Email
Судя по выводу, поддержка mp3 (в виде кода из ffmpeg) есть.

kda

  • Гость
Судя по выводу, поддержка mp3 (в виде кода из ffmpeg) есть.

Не знаю, у меня не работает. И, видимо, из-за проблем указанных мной при выводе gst-inspector.
Нашел даже баг: https://bugzilla.altlinux.org/show_bug.cgi?id=16703#c0. Только вот написано что fixed - а у меня совсем не fixed. Как раз ставил из сборки от 18-го числа.

Оффлайн ab

  • alt linux team
  • ***
  • Сообщений: 36
  • Непарный валенок
    • Email
Подозреваю, что это все взаимосвязано -- отсутствие символа в зависимых библиотеках не дает возможность загрузить плагин.

kda

  • Гость
С сегодняшним обновлением все заработало. Ура! :)