Автор Тема: Обновление с дистрибутивов p7 до p8  (Прочитано 77773 раз)

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 31 739
  • Учиться .... Телепатами не рождаются, ими ....
    • Email

Оффлайн eddy

  • Начинающий
  • *
  • Сообщений: 1
    • Email
Re: Обновление с дистрибутивов p7 до p8
« Ответ #136 : 10.06.2017 17:12:20 »
Недавно перешёл на p8, обновился с p7. Обновилось ядро, репозитории, но остались старые кеды, ещё 4. Вручную установил новые, старые удалил. Заметил, что нет никаких обновлений уже третий день, это немного странно. Также более странно то, что пакет branding-basealt-* вообще не находит в репозиториях по команде:
apt-cache search branding-basealtВот содержимое sources.list:
rpm [updates] http://ftp.altlinux.org/pub/distributions/ALTLinux/ p8/branch/x86_64 classic
rpm [updates] http://ftp.altlinux.org/pub/distributions/ALTLinux/ p8/branch/noarch classic
rpm [updates] http://ftp.altlinux.org/pub/distributions/ALTLinux/ p8/branch/x86_64-i586 classic

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 495
    • Домашняя страница
    • Email
Re: Обновление с дистрибутивов p7 до p8
« Ответ #137 : 15.06.2017 14:11:47 »
Недавно перешёл на p8, обновился с p7. Обновилось ядро, репозитории, но остались старые кеды, ещё 4. Вручную установил новые, старые удалил. Заметил, что нет никаких обновлений уже третий день, это немного странно. Также более странно то, что пакет branding-basealt-* вообще не находит в репозиториях по команде:
apt-cache search branding-basealtВот содержимое sources.list:
rpm [updates] http://ftp.altlinux.org/pub/distributions/ALTLinux/ p8/branch/x86_64 classic
rpm [updates] http://ftp.altlinux.org/pub/distributions/ALTLinux/ p8/branch/noarch classic
rpm [updates] http://ftp.altlinux.org/pub/distributions/ALTLinux/ p8/branch/x86_64-i586 classic
Потому что дистрибуттвы называются alt (это компания называется Basealt):
8 Branch
branding-alt-education-8.1-alt0.M80P.1
branding-alt-server-8.1-alt0.M80P.1
branding-alt-sisyphus-20161130-alt2
branding-alt-spserver-8.0-alt0.M80P.2
branding-alt-spworkstation-8.0-alt0.M80P.2
branding-alt-starterkit-p8-alt0.M80P.3
branding-alt-workstation-8.1-alt0.M80P.3
А обновления в стабильный бранч и не должны часто попадать. По определению.
Сравните https://packages.altlinux.org/ru/p8/home и https://packages.altlinux.org/ru/Sisyphus/home
« Последнее редактирование: 15.06.2017 14:14:01 от Skull »
Андрей Черепанов (cas@)

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 9 955
Re: Обновление с дистрибутивов p7 до p8
« Ответ #138 : 11.07.2017 14:51:29 »
Вдогонку.
1. После просыпания NetworkManager перестает видеть сети. Чекбокс "Сеть" снят и не включается.

А если чекбокс рулезом подтолкнуть?
# cat /etc/polkit-1/rules.d/60-sysvinit-nm.rules
polkit.addRule(function(action, subject) {
    if (subject.isInGroup("_nmconnect") && (action.id.indexOf("org.freedesktop.NetworkManager.") == 0 )) {
        return polkit.Result.YES;
    }
});
- на альтовых системах с sysv этот рулез обязателен.
Пользователь должен находиться в системной группе _nmconnect:
# groupadd -r _nmconnect
# gpasswd -a  $USER  _nmconnect

Перезагрузка не требуется. Требуется релогин пользователя добавленного в группу.
Если что, это всё можно будет убрать за минуту.
« Последнее редактирование: 11.07.2017 15:35:02 от Speccyfighter »

Оффлайн Антон Мидюков

  • alt linux team
  • ***
  • Сообщений: 4 819
  • antohami@
Re: Обновление с дистрибутивов p7 до p8
« Ответ #139 : 11.07.2017 18:20:39 »
Можно просто установить пакет polkit-sysvinit

Оффлайн MrFlibble

  • Завсегдатай
  • *
  • Сообщений: 57
Re: Обновление с дистрибутивов p7 до p8
« Ответ #140 : 18.10.2017 14:54:38 »
Добрый день. Собираюсь обновиться до p8 с KDesktop 7.0.5. В вики указано, что для старых видеокарт nVidia необходимо установить другой драйвер. Не могу разобраться, старая ли карта у меня: NVIDIA GeForce 710M. Я посмотрел в списке поддерживаемых устройств драйвера 304.131 (вот тут), эта модель там не упомянута. Ставить ли мне драйвер nouveau или всё-таки моя карта поддерживается?

Оффлайн asy

  • alt linux team
  • ***
  • Сообщений: 7 785
Re: Обновление с дистрибутивов p7 до p8
« Ответ #141 : 18.10.2017 15:30:40 »
Не могу разобраться, старая ли карта у меня: NVIDIA GeForce 710M.
Вот MX/400 - это старая. Или 440. А это - новьё, пять лет всего, как вышла. :-) 6600 GT ещё работает в p8.

UPD: "FX5500 (хотя уточню ближе к ночи, что там стоит у меня)" - не помню, когда на 6600 поменял... *-)
« Последнее редактирование: 18.10.2017 22:07:58 от asy »

Оффлайн MrFlibble

  • Завсегдатай
  • *
  • Сообщений: 57
Re: Обновление с дистрибутивов p7 до p8
« Ответ #142 : 18.10.2017 15:33:45 »
Спасибо! Я десять лет пользовался компьютером, купленным в 2003 г., и представления о том, что старое, а что нет, у меня немного сбиты :)

Оффлайн MrFlibble

  • Завсегдатай
  • *
  • Сообщений: 57
Re: Обновление с дистрибутивов p7 до p8
« Ответ #143 : 18.10.2017 16:10:24 »
У меня возник ещё один вопрос: здесь говорится, что по умолчанию в p7 стоит несовместимая тема gtk3-theme-clearlooks-phenix, однако у меня установлена другая: gtk3-theme-oxygen-gtk. Мне нужно менять её на что-то ещё?

UPD: Я так понял, проблема относилась к дистрибутивам, использующим GNOME.
« Последнее редактирование: 18.10.2017 19:56:55 от MrFlibble »

Оффлайн MrFlibble

  • Завсегдатай
  • *
  • Сообщений: 57
Re: Обновление с дистрибутивов p7 до p8
« Ответ #144 : 18.10.2017 20:19:31 »
Я завершил обновление, но при загрузке получаю сообщения об ошибках:
starting version 230
mount: /root/run: filesystem mounted, but mount(8) failed: No such file or directory.
[FAILED] Failed to start IPv4 firewall with iptables.
При вводе команды systemctl status iptables.service получаю:
● iptables.service - IPv4 firewall with iptables
   Loaded: loaded (/lib/systemd/system/iptables.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Ср 2017-10-18 20:07:42 MSK; 9min ago
  Process: 685 ExecStart=/etc/init.d/iptables start (code=exited, status=1/FAILURE)
 Main PID: 685 (code=exited, status=1/FAILURE)

окт 18 20:07:41 comp-core-i5-3230m-8dc347.localdomain systemd[1]: Starting IPv4 firewall with iptables...
окт 18 20:07:42 comp-core-i5-3230m-8dc347.localdomain iptables[685]: iptables firewall is not configured[PASSED]
окт 18 20:07:42 comp-core-i5-3230m-8dc347.localdomain systemd[1]: iptables.service: Main process exited, code=exited, status=1/FA
окт 18 20:07:42 comp-core-i5-3230m-8dc347.localdomain systemd[1]: Failed to start IPv4 firewall with iptables.
окт 18 20:07:42 comp-core-i5-3230m-8dc347.localdomain systemd[1]: iptables.service: Unit entered failed state.
окт 18 20:07:42 comp-core-i5-3230m-8dc347.localdomain systemd[1]: iptables.service: Failed with result 'exit-code'.

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 495
    • Домашняя страница
    • Email
Re: Обновление с дистрибутивов p7 до p8
« Ответ #145 : 18.10.2017 20:21:24 »
Брандмауэр не настроен.
Андрей Черепанов (cas@)

Оффлайн MrFlibble

  • Завсегдатай
  • *
  • Сообщений: 57
Re: Обновление с дистрибутивов p7 до p8
« Ответ #146 : 18.10.2017 20:42:17 »
Подскажите, пожалуйста, нужно ли это делать. В p7 я использовал настройки по умолчанию и не знаю/не помню, был ли включён брандмауэр.

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 495
    • Домашняя страница
    • Email
Re: Обновление с дистрибутивов p7 до p8
« Ответ #147 : 18.10.2017 20:58:37 »
Если Вы не настраивали брандмауэр, то он Вам определённо не нужен.
Андрей Черепанов (cas@)

Оффлайн MrFlibble

  • Завсегдатай
  • *
  • Сообщений: 57
Re: Обновление с дистрибутивов p7 до p8
« Ответ #148 : 18.10.2017 21:05:05 »
Нужно ли тогда отключить службу iptables в Альтераторе? Если она не была включена в версии p7, можно ли понять, как она включилась после обновления?

У меня есть ещё один вопрос (надеюсь, эта тема для него подходит): на седьмой платформе я использовал программу synaptiks для автоматического отключения сенсорной панели при загрузке, но после обновления synaptiks перестала запускаться. Я пробовал удалить и затем снова установить её, но проблему это не решило.

При запуске synaptiks через терминал выдаётся сообщение "Ошибка сегментирования".

Оффлайн asy

  • alt linux team
  • ***
  • Сообщений: 7 785
Re: Обновление с дистрибутивов p7 до p8
« Ответ #149 : 18.10.2017 22:15:24 »
Нужно ли тогда отключить службу iptables в Альтераторе? Если она не была включена в версии p7, можно ли понять, как она включилась после обновления?
Я плохо ориентируюсь в Альтераторе, но в ALT есть два штатных средства для конфигурирования iptables. Это, собственно, классический вариант с /etc/sysconfig/iptables, что вычитывается и применяется службой iptables, и https://www.altlinux.org/Etcnet_Firewall, чьи правила применяются при старте службы network, если речь не идёт про ненужноsystemd. Альтератор настраивает правила для Etcnet Firewall. Мешать вариант iptables и Etcnet Firewall не следует. По-умолчанию в пакете etcnet файрвол, кажется, отключен. Если включен, то это отдельная настройка со стороны либо релиз-менеджера отдельно взятого дистрибутива (человека), либо Альтератора.
« Последнее редактирование: 18.10.2017 22:21:35 от asy »