Автор Тема: Клиент Citrix на AltLinux 4.1 [РЕШЕНО]  (Прочитано 2280 раз)

Оффлайн 24pm

  • Начинающий
  • *
  • Сообщений: 22
    • Страница сисадмина
    • Email
Устанавливаю сабж, получаю ошибку зависимости:
error: failed dependencies:
        libXm.so.4 is needed by ICAClient-11.0-1
Выяснил, что это библиотека относится к Motif.
apt-get предложил следующие пакеты:
# apt-cache search libXm.so
openmotif - The Open Motif
lesstif - LessTif - a free replacement of OSF/Motif
Установил openmotif, openmotif-clients, openmotif-mwm, openmotif-devel, libXm.so.4 - не помогло.
Кто-нибудь знает какой пакет содержит эту библиотеку?
« Последнее редактирование: 22.04.2009 10:08:52 от kda »

Оффлайн tvm

  • Начинающий
  • *
  • Сообщений: 2
    • Email
Re: Клиент Citrix на AltLinux 4.1
« Ответ #1 : 20.04.2009 11:10:35 »
11 версия клиента требует библиотеку, версии большей, чем есть в ALD. Я использую клиента версии 10.6

Оффлайн 24pm

  • Начинающий
  • *
  • Сообщений: 22
    • Страница сисадмина
    • Email
Re: Клиент Citrix на AltLinux 4.1
« Ответ #2 : 20.04.2009 11:38:54 »
А где можно его взять?  А то на сайте Citrix лежит только 11-я.

kda

  • Гость
Re: Клиент Citrix на AltLinux 4.1
« Ответ #3 : 20.04.2009 14:23:02 »
А где можно его взять?  А то на сайте Citrix лежит только 11-я.

Ссылка есть в Web-интерфейсе Citrix установленного в Вашей организации.

Оффлайн 24pm

  • Начинающий
  • *
  • Сообщений: 22
    • Страница сисадмина
    • Email
Re: Клиент Citrix на AltLinux 4.1
« Ответ #4 : 22.04.2009 06:53:34 »
Нашёл на rpmfind.net 9-ю версию клиента, установилась нормально, но при запуске wfcmgr выдаёт:
Warning: Cannot convert string "-*-helvetica-medium-r-*-*-*-120-75-75-*-*-iso8859-1" to type FontStructДалее загружается менеджер, но с проблемой в шрифтах: вместо русского - квадратики.
Пытался наудачу заменить упоминания iso8859-1 на utf-8 в файлах Wfcmgr.ad  Wfica.ad - не помогло.

metabot.ru со своей замечательной опцией "поиск файлов" помог найти 10-ю версию. Вот одна из ссылок:
http://results.metabot.ru/?sd=49ee8819.3ba7&mv=ftp://ftp.dvo.ru/pub/Gentoo/distfiles/ICAClient-10.6-1.i386.rpm
Этот пакет установился и запустился без проблем.
« Последнее редактирование: 22.04.2009 07:39:59 от 24pm »