Автор Тема: Яндекс.браузер (Yandex.browser) что-нибудь поменялось ?  (Прочитано 40284 раз)

Оффлайн latigid

  • Завсегдатай
  • *
  • Сообщений: 286
    • Email
http://repo.yandex.ru/yandex-browser/rpm/beta/x86_64/
Пробовал - требует те же библиотеки:
Depends: libstdc++.so.6(GLIBCXX_3.4.18)(64bit) but it is not installable
Depends: libstdc++.so.6(GLIBCXX_3.4.19)(64bit) but it is not installable
которых у меня нет в пакете i586-libstdc++6-4.7.2-alt7
А можно где либо взять такой пакет но с нужными библиотеками? Или вставить библиотеки  в пакет?
Уважаемый Kalt, а вы где этот пакет "взяли", почему у вас есть, а у меня нет?
Сизиф это версия Альта или репозитория?

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 31 727
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
i586-libstdc++6-4.7.2-alt7
А с чего в этом пакете, если у них 64-битное приложение?

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 31 727
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Сизиф это версия Альта или репозитория?
Что такое Сизиф

Оффлайн latigid

  • Завсегдатай
  • *
  • Сообщений: 286
    • Email
Цитировать
А с чего в этом пакете, если у них 64-битное приложение?
Выше уже писал.
$ rpm -qf /usr/lib/libstdc++.so.6
i586-libstdc++6-4.7.2-alt7
« Последнее редактирование: 24.10.2017 19:09:19 от latigid »

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 9 955
Цитировать
А с чего в этом пакете, если у них 64-битное приложение?
Выше уже писал.
$ rpm -qf /usr/lib/libstdc++.so.6
i586-libstdc++6-4.7.2-alt7
$ rpm -qpvl ./libstdc++6-5.3.1-alt3.x86_64.rpm|grep stdc++
lrwxrwxrwx    1 root    root                       19 мар 11  2016 /usr/lib64/libstdc++.so.6 -> libstdc++.so.6.0.21
-rw-r--r--    1 root    root                  1545704 мар 11  2016 /usr/lib64/libstdc++.so.6.0.21
-rw-r--r--    1 root    root                     2383 мар 11  2016 /usr/share/gdb/auto-load/usr/lib64/libstdc++.so.6.0.21-gdb.py

А то что вы вывели, это для поддержки 32бит приложений в 64бит системах.
А яндекс-браузер приложение 64-рёхбитное.
« Последнее редактирование: 24.10.2017 19:30:03 от Speccyfighter »

Оффлайн latigid

  • Завсегдатай
  • *
  • Сообщений: 286
    • Email
$ rpm -qpvl ./libstdc++6-5.3.1-alt3.x86_64.rpm|grep stdc++
ошибка: невозможно открыть ./libstdc++6-5.3.1-alt3.x86_64.rpm: Нет такого файла или каталога

Оффлайн Kalt

  • Завсегдатай
  • *
  • Сообщений: 996
Пишите на Яндекс - пусть соберут совместимую с ALT версию.
...То есть мне её уже предоставили?.. :-\ Или таки у latigid что то криво стоит?.. ??? Могу ещё конечно попробовать на Simply 8.2 c древним железом поставить, а вдруг?.. ;-D
Intel Xeon X3440 2,53GHz, MSI H55- G43, DDR3- 4x2GB, GF GT710

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 9 955
$ rpm -qpvl ./libstdc++6-5.3.1-alt3.x86_64.rpm|grep stdc++
ошибка: невозможно открыть ./libstdc++6-5.3.1-alt3.x86_64.rpm: Нет такого файла или каталога

Покажите вывод этих команд вместе с командами и всем тем что выведет, ничего не убирая и не добавляя, даже если будут ошибки, вместе с ошибками:
rpm -q --provides libstdc++6|grep -v set|grep GLIBCXX
apt-repo

Оффлайн latigid

  • Завсегдатай
  • *
  • Сообщений: 286
    • Email
rpm -q --provides libstdc++6|grep -v set|grep GLIBCXX
Спойлер
[oleg@pppoe ~]$ rpm -q --provides libstdc++6|grep -v set|grep GLIBCXX
libstdc++.so.6(GLIBCXX_3.4)(64bit) 
libstdc++.so.6(GLIBCXX_3.4.1)(64bit) 
libstdc++.so.6(GLIBCXX_3.4.10)(64bit) 
libstdc++.so.6(GLIBCXX_3.4.11)(64bit) 
libstdc++.so.6(GLIBCXX_3.4.12)(64bit) 
libstdc++.so.6(GLIBCXX_3.4.13)(64bit) 
libstdc++.so.6(GLIBCXX_3.4.14)(64bit) 
libstdc++.so.6(GLIBCXX_3.4.15)(64bit) 
libstdc++.so.6(GLIBCXX_3.4.16)(64bit) 
libstdc++.so.6(GLIBCXX_3.4.17)(64bit) 
libstdc++.so.6(GLIBCXX_3.4.2)(64bit) 
libstdc++.so.6(GLIBCXX_3.4.3)(64bit) 
libstdc++.so.6(GLIBCXX_3.4.4)(64bit) 
libstdc++.so.6(GLIBCXX_3.4.5)(64bit) 
libstdc++.so.6(GLIBCXX_3.4.6)(64bit) 
libstdc++.so.6(GLIBCXX_3.4.7)(64bit) 
libstdc++.so.6(GLIBCXX_3.4.8)(64bit) 
libstdc++.so.6(GLIBCXX_3.4.9)(64bit) 
[oleg@pppoe ~]$
apt-repo
Спойлер

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 493
    • Домашняя страница
    • Email
p7. Мда...
Нужно искать древние версии закрытого браузера Яндекс. И зачем люди ищут себе проблемы и стремятся в рабство?
Андрей Черепанов (cas@)

Оффлайн latigid

  • Завсегдатай
  • *
  • Сообщений: 286
    • Email
Цитировать
p7. Мда...
Может мне еще и компьютер каждый год менять?

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 9 955
Skull сказал м.б. и резко, но справедливо.
latigid, обращайтесь в техподдержку яндекса и просите (умоляйте) дать вам ссылку на 64бит rpm пакет браузера требующий максимум GLIBCXX_3.4.17, но не свежее.
Правда есть вариант, что в ответ они вам посоветуют установить более новый Линукс.
Но я это называю, дипломатично послать очень далеко.
В общем пытайтесь, пробуйте обратиться, авось повезёт.

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 9 955
Цитировать
p7. Мда...
Может мне еще и компьютер каждый год менять?

:-) Да. Новомодные програмёры в этом абсолютно уверены.

Оффлайн latigid

  • Завсегдатай
  • *
  • Сообщений: 286
    • Email
Не туда все это едет.
Из за этого г... перешол на Линукс.
Сначала, посоветовали, на Убунту 9,10 было все отлично. Потом понеслось. Старые версии не оддерживаются. Задачи не меняются, а машина уже тормозит!
Перешел на Альт. Тоже нездоровые тенденции...
И куда бедному пользователю податься...

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 493
    • Домашняя страница
    • Email
Совет: использовать то, что в репозиториях. Проблема была в рабской зависимости от закрытой программы и Вы сами увидели, к чему это привело.
Андрей Черепанов (cas@)