Автор Тема: Не удаётся обновить до Сизифа alt-p10-cinnamon-20230910-x86_64  (Прочитано 6612 раз)

Оффлайн gosts 87

  • Завсегдатай
  • *
  • Сообщений: 2 784
  • Дмитрий/Dmitry/德米特里/दिमित्री
Всё!!! Я его сделал!!! :-D
Спойлер

И какой был порядок действий? :-)

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 32 300
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
ВСЁ!!! Я ЕГО СДЕЛАЛ!!! :-D
Поздравляю ;-)

Оффлайн drake63

  • Начинающий
  • *
  • Сообщений: 46
И какой был порядок действий?
Танец с бубном, в принципе можно было не удалять синамон, вся проблема в том что удаляются при обновлении часть пакетов, из-за зависимостей, пока я не добрался этих зависимостей так ничего и не получалось всё упирается в пакет realmd, отсюда слетают гномовские пакеты, за ними cinnamon-control-center и соответственно сам cinnamon.
Надо будет вытащить из журнала, всё что делалось.

Оффлайн drake63

  • Начинающий
  • *
  • Сообщений: 46

Оффлайн drake63

  • Начинающий
  • *
  • Сообщений: 46
И какой был порядок действий?

вот лог, что устанавливал

Спойлер
фев 02 21:48:37 host-137 apt-get[7300]: gst-plugins-base1.0-1.22.9-alt1 sisyphus+338851.300.2.2 1706187121 installed
фев 02 21:48:38 host-137 apt-get[7300]: libwebkit2gtk-2.42.4-alt1 sisyphus+336569.100.1.2 1702680031 installed
фев 02 21:48:38 host-137 apt-get[7300]: libyelp-42.2-alt1 sisyphus+307148.200.1.1 1663736242 installed
фев 02 21:48:39 host-137 apt-get[7300]: yelp-42.2-alt1 sisyphus+307148.200.1.1 1663736242 installed
фев 02 21:48:39 host-137 apt-get[7300]: orca-45.2-alt1 sisyphus+337786.100.1.1 1704544213 installed
фев 02 21:48:40 host-137 apt-get[7300]: lightdm-1.32.0-alt4 sisyphus+321122.100.1.1 1684381482 installed
фев 02 21:48:40 host-137 apt-get[7300]: slick-greeter-2.0.3-alt1 sisyphus+337722.200.1.1 1704453025 installed
фев 02 22:07:39 host-137 apt-get[16537]: libwebkit2gtk4.1-2.42.4-alt1 sisyphus+336570.100.1.2 1702680154 installed
фев 02 22:07:39 host-137 apt-get[16537]: libgnome-online-accounts-3.48.0-alt1.2 sisyphus+337814.200.1.1 1704637251 installed
фев 02 22:19:37 host-137 apt-get[1820]: libgsasl-2.2.0-alt1 sisyphus+333173.100.1.1 1698696954 installed
фев 02 22:19:37 host-137 apt-get[1820]: openldap-common-2.6.6-alt1 sisyphus+330946.100.2.1 1696432854 installed
фев 02 22:19:37 host-137 apt-get[1820]: libldap2-2.6.6-alt1 sisyphus+330946.100.2.1 1696432854 installed
фев 02 22:19:38 host-137 apt-get[1820]: gnupg2-2.4.3-alt1 sisyphus+327229.100.1.1 1692102992 installed
фев 02 22:19:38 host-137 apt-get[1820]: libcurl-8.6.0-alt1 sisyphus+339478.100.2.2 1706721193 installed
фев 02 22:19:38 host-137 apt-get[1820]: curl-8.6.0-alt1 sisyphus+339478.100.2.2 1706721193 installed
фев 02 22:19:38 host-137 apt-get[1820]: seahorse-43.0-alt3 sisyphus+327255.200.1.2 1692179025 installed
фев 02 22:19:38 host-137 apt-get[1820]: libldb-2.8.0-alt1 sisyphus+333513.50340.73.1 1704644969 installed
фев 02 22:19:38 host-137 apt-get[1820]: seahorse-40.0-alt3 p10+314960.100.2.1 1676991168 removed
фев 02 22:19:38 host-137 apt-get[1820]: gnupg2-2.2.33-alt1 p10+291675.100.2.1 1640165663 removed
фев 02 22:19:38 host-137 apt-get[1820]: curl-8.5.0-alt1 p10+336240.100.1.1 1702282197 removed
фев 02 22:19:38 host-137 apt-get[1820]: libcurl-8.5.0-alt1 p10+336240.100.1.1 1702282197 removed
фев 02 22:19:38 host-137 apt-get[1820]: libldb-2.6.2-alt1 p10+332201.70.12.1 1701727209 removed
фев 02 22:19:38 host-137 apt-get[1820]: libldap-2.4.59-alt1.p10.2 p10+322965.300.3.1 1687183733 removed
фев 02 22:19:38 host-137 apt-get[1820]: openldap-common-2.4.59-alt1.p10.2 p10+322965.300.3.1 1687183733 removed
фев 02 22:19:38 host-137 apt-get[1820]: libgsasl-1.8.0-alt3 sisyphus+275307.100.1.2 1624478543 removed
фев 02 22:20:55 host-137 apt-get[12860]: libpackagekit-glib-1.2.5.0.0.30-alt1 sisyphus+325531.700.5.1 1690395607 installed
фев 02 22:20:55 host-137 apt-get[12860]: packagekit-1.2.5.0.0.30-alt1 sisyphus+325531.700.5.1 1690395607 installed
фев 02 22:20:56 host-137 apt-get[12860]: realmd-0.17.1-alt7 sisyphus+328648.40.2.1 1693823763 installed
фев 02 22:20:56 host-137 apt-get[12860]: libpackagekit-glib-1.2.5.0.0.30-alt1 p10+321804.400.5.2 1691482381 removed
фев 02 22:25:14 host-137 apt-get[22630]: libgtk4-gir-4.12.5-alt1 sisyphus+338236.300.2.3 1705674827 installed
фев 02 22:25:14 host-137 apt-get[22630]: gnome-online-accounts-3.48.0-alt1.2 sisyphus+337814.200.1.1 1704637251 installed
фев 02 22:25:14 host-137 apt-get[22630]: cinnamon-screensaver-6.0.3-alt1 sisyphus+339234.100.1.1 1706472965 installed
фев 02 22:25:14 host-137 apt-get[22630]: libgnome-desktop3-44-alt1 sisyphus+317076.1500.1.1 1679346542 installed
фев 02 22:25:14 host-137 apt-get[22630]: libmutter-1:45.3-alt1 sisyphus+337814.100.1.1 1704637161 installed
фев 02 22:25:14 host-137 apt-get[22630]: libmutter-gir-1:45.3-alt1 sisyphus+337814.100.1.1 1704637161 installed
фев 02 22:25:14 host-137 apt-get[22630]: cinnamon-control-center-6.0.0-alt2 sisyphus+336615.100.1.1 1702796941 installed
фев 02 22:25:14 host-137 apt-get[22630]: gvfs-backend-goa-1.52.2-alt1 sisyphus+337738.100.1.1 1704465504 installed
фев 02 22:25:15 host-137 apt-get[22630]: evolution-data-server-3.50.3-alt1 sisyphus+337730.100.1.1 1704454658 installed
фев 02 22:25:15 host-137 apt-get[22630]: evolution-data-server-gir-3.50.3-alt1 sisyphus+337730.100.1.1 1704454658 installed
фев 02 22:25:15 host-137 apt-get[22630]: python3-module-webencodings-0.5.1-alt2 sisyphus+276020.100.1.1 1624812421 installed
фев 02 22:25:15 host-137 apt-get[22630]: python3-module-tinycss2-1.2.1-alt1 sisyphus+308598.100.1.1 1666081847 installed
фев 02 22:25:15 host-137 apt-get[22630]: geoclue2-2.7.1-alt1 sisyphus+329419.100.1.1 1694540118 installed
фев 02 22:25:15 host-137 apt-get[22630]: gst-plugins-libcamera1.0-1:0.2.0-alt1 sisyphus+338024.100.2.2 1705663844 installed
фев 02 22:25:15 host-137 apt-get[22630]: rtkit-0.13-alt1 sisyphus+278998.100.1.1 1626351819 installed
фев 02 22:25:16 host-137 apt-get[22630]: pipewire-1.0.2-alt1 sisyphus+339496.100.1.1 1706710047 installed
фев 02 22:25:16 host-137 apt-get[22630]: fuse-2.9.9-alt4 sisyphus+298379.100.1.1 1649860866 installed
фев 02 22:25:16 host-137 apt-get[22630]: xdg-desktop-portal-1.18.2-alt1 sisyphus+334956.100.1.1 1700733211 installed
фев 02 22:25:16 host-137 apt-get[22630]: xdg-desktop-portal-gtk-1.15.1-alt1 sisyphus+332835.200.1.1 1698348428 installed
фев 02 22:25:17 host-137 apt-get[22630]: xdg-desktop-portal-xapp-1.0.4-alt1 sisyphus+335468.300.5.1 1701581902 installed
фев 02 22:25:17 host-137 apt-get[22630]: libgdata-0.18.1-alt2 sisyphus+328578.100.1.1 1693644797 installed
фев 02 22:25:17 host-137 apt-get[22630]: gvfs-backend-google-1.52.2-alt1 sisyphus+337738.100.1.1 1704465504 installed
фев 02 22:25:17 host-137 apt-get[22630]: samba-common-libs-4.19.4-alt1 sisyphus+338344.100.3.1 1705888726 installed
фев 02 22:25:17 host-137 apt-get[22630]: samba-libs-4.19.4-alt1 sisyphus+338344.100.3.1 1705888726 installed
фев 02 22:25:17 host-137 apt-get[22630]: libsmbclient-4.19.4-alt1 sisyphus+338344.100.3.1 1705888726 installed
фев 02 22:25:17 host-137 apt-get[22630]: samba-client-4.19.4-alt1 sisyphus+338344.100.3.1 1705888726 installed
фев 02 22:25:17 host-137 apt-get[22630]: gvfs-backend-smb-1.52.2-alt1 sisyphus+337738.100.1.1 1704465504 installed
фев 02 22:25:17 host-137 apt-get[22630]: gvfs-backends-1.52.2-alt1 sisyphus+337738.100.1.1 1704465504 installed
фев 02 22:25:17 host-137 apt-get[22630]: cinnamon-translations-6.0.2-alt1 sisyphus+337721.100.1.1 1704452165 installed
фев 02 22:25:17 host-137 apt-get[22630]: cinnamon-session-6.0.3-alt2 sisyphus+339531.100.1.1 1706765849 installed
фев 02 22:25:18 host-137 apt-get[22630]: cinnamon-6.0.4-alt1 sisyphus+337720.100.1.1 1704451764 installed
фев 02 22:25:18 host-137 apt-get[22630]: libmutter-gir-1:40.10-alt1 p10+297741.500.2.1 1649403974 removed
фев 02 22:25:18 host-137 apt-get[22630]: libmutter-1:40.10-alt1 p10+297741.500.2.1 1649403974 removed
фев 02 22:25:18 host-137 apt-get[22630]: libgnome-desktop3-40.7-alt1 p10+293321.240.4.1 1643613389 removed
фев 02 22:26:54 host-137 apt-get[32995]: cinnamon-default-6.0.4-alt1 sisyphus+338101.500.5.1 1705113571 installed
фев 02 22:41:56 host-137 apt-get[3180]: libraw-0.21.2-alt1 sisyphus+336806.100.1.1 1703007432 installed
фев 02 22:41:56 host-137 apt-get[3180]: libsixel1-1.10.3-alt2 sisyphus+336514.600.7.1 1702672532 installed
фев 02 22:41:56 host-137 apt-get[3180]: sixel-utils-1.10.3-alt2 sisyphus+336514.600.7.1 1702672532 installed
фев 02 22:41:56 host-137 apt-get[3180]: libmpdclient-2.20-alt1 sisyphus+333310.40.7.1 1698855110 installed
фев 02 22:41:56 host-137 apt-get[3180]: mpc-0.33-alt1 sisyphus+278401.100.1.2 1626202660 installed
фев 02 22:41:56 host-137 apt-get[3180]: jp2a-1.1.1-alt1 sisyphus+290559.100.1.1 1637842526 installed
фев 02 22:41:56 host-137 apt-get[3180]: perl-Locale-gettext-1.07-alt1.2 sisyphus+335067.10500.2.2 1701154168 installed
фев 02 22:41:56 host-137 apt-get[3180]: help2man-1.48.5-alt1 sisyphus+283596.100.1.1 1629673489 installed
фев 02 22:41:56 host-137 apt-get[3180]: libcaca-0.99-alt23 sisyphus+328092.100.2.1 1693282272 installed
фев 02 22:41:56 host-137 apt-get[3180]: libid3tag-0.16.3-alt1 sisyphus+339332.100.2.1 1706589330 installed
фев 02 22:41:56 host-137 apt-get[3180]: libgif-4.1.6-alt3 sisyphus+276911.100.1.3 1625273979 installed
фев 02 22:41:56 host-137 apt-get[3180]: imlib2-1.12.1-alt1 sisyphus+330535.100.1.1 1695909087 installed
фев 02 22:41:56 host-137 apt-get[3180]: caca-utils-0.99-alt23 sisyphus+328092.100.2.1 1693282272 installed
фев 02 22:41:56 host-137 apt-get[3180]: libImageMagick7-common-7.1.1.24-alt1 sisyphus+337350.100.1.1 1703679389 installed
фев 02 22:41:56 host-137 apt-get[3180]: libwmflite-0.2.8.4-alt13 sisyphus+275127.100.1.1 1624406837 installed
фев 02 22:41:56 host-137 apt-get[3180]: libraqm-0.7.1-alt1 sisyphus+279320.100.1.2 1626503395 installed
фев 02 22:41:56 host-137 apt-get[3180]: liblqr-0.4.2-alt1 sisyphus+276247.100.1.2 1624927461 installed
фев 02 22:41:56 host-137 apt-get[3180]: libgts-0.7.6-alt2.drc20130205.1 sisyphus+275722.100.1.1 1624749869 installed
фев 02 22:41:56 host-137 apt-get[3180]: liblasi-1.1.3-alt3 sisyphus+286812.100.2.1 1633968131 installed
фев 02 22:41:57 host-137 apt-get[3180]: libgraphviz-9.0.0-alt2 sisyphus+333513.1540.72.1 1704584261 installed
фев 02 22:41:57 host-137 apt-get[3180]: libImageMagick7.10-7.1.1.24-alt1 sisyphus+337350.100.1.1 1703679389 installed
фев 02 22:41:57 host-137 apt-get[3180]: ImageMagick-tools-7.1.1.24-alt1 sisyphus+337350.100.1.1 1703679389 installed
фев 02 22:41:57 host-137 apt-get[3180]: neofetch-7.1.0-alt3 sisyphus+307663.100.1.1 1664569420 installed
фев 02 22:41:57 host-137 apt-get[3180]: libcaca-0.99-alt23 p10+307833.72200.205.1 1693932457 removed
фев 02 23:37:46 host-137 apt-get[9309]: numlockx-1.2-alt1.qa1 1366169347 installed
фев 02 23:42:06 host-137 apt-get[9617]: lightdm-settings-2.0.2-alt1 sisyphus+337722.100.1.1 1704452971 installed

начиная с neofetch, это все после, хотя он тоже не мало пакетов подтянул ImateMagic-tools - точно он :-)
« Последнее редактирование: 03.02.2024 00:03:22 от drake63 »

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 32 300
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
А как решил проблему с realmd ?

Оффлайн drake63

  • Начинающий
  • *
  • Сообщений: 46
фев 02 22:20:56 host-137 apt-get[12860]: realmd-0.17.1-alt7 sisyphus+328648.40.2.1 1693823763 installed

вот строчка, но перед ним пакеты есть, без которого он не становился

Оффлайн drake63

  • Начинающий
  • *
  • Сообщений: 46
я пока ещё не разобрался, но чёт по-моему система кривовато работает, даже обычного текстового редактора нет, только vim, хотя меня он вполне устраивает, ладно будем разбираться дальше. главное что получилось, а то некоторые товарищи приговорили сразу ))). Спасибо вам за помощь. :-)

Оффлайн gosts 87

  • Завсегдатай
  • *
  • Сообщений: 2 784
  • Дмитрий/Dmitry/德米特里/दिमित्री
вот строчка, но перед ним пакеты есть, без которого он не становился
Спойлер
Сборочные зависимости:
python3-devel
/usr/bin/krb5-config
/usr/bin/net
pkgconfig(gio-2.0) >= 2.32.0
pkgconfig(gio-unix-2.0)
pkgconfig(glib-2.0) >= 2.32.0
pkgconfig(libsystemd)
pkgconfig(polkit-gobject-1)
pkgconfig(systemd)
libldap-devel
xmlto
xsltproc
intltool >= 0.35.0
libldap-devel
https://packages.altlinux.org/ru/sisyphus/srpms/realmd/#:~:text=%D0%A1%D0%B1%D0%BE%D1%80%D0%BE%D1%87%D0%BD%D1%8B%D0%B5%20%D0%B7%D0%B0%D0%B2%D0%B8%D1%81%D0%B8%D0%BC%D0%BE%D1%81%D1%82%D0%B8%3A,intltool%20%3E%3D%200.35.0
« Последнее редактирование: 03.02.2024 00:14:39 от gosts 87 »

Оффлайн drake63

  • Начинающий
  • *
  • Сообщений: 46
libldap-devel
нет не devel, кажется openlibldap что-то в этом роде, там две библиотеки libldap и libldap2 они обе в этот пакет входят, без них realmd не ставится

Оффлайн gosts 87

  • Завсегдатай
  • *
  • Сообщений: 2 784
  • Дмитрий/Dmitry/德米特里/दिमित्री
нет не devel, кажется openlibldap что-то в этом роде, там две библиотеки libldap и libldap2 они обе в этот пакет входят, без них realmd не ставится
https://packages.altlinux.org/ru/sisyphus/binary/realmd/x86_64/depends/
https://bugzilla.altlinux.org/45783
« Последнее редактирование: 03.02.2024 00:25:50 от gosts 87 »

Оффлайн gosts 87

  • Завсегдатай
  • *
  • Сообщений: 2 784
  • Дмитрий/Dmitry/德米特里/दिमित्री
« Последнее редактирование: 03.02.2024 00:35:56 от gosts 87 »

Оффлайн drake63

  • Начинающий
  • *
  • Сообщений: 46
libldap.so.2()(64bit) >= set:niWZgQ2L5d9vZydDaMgOpWhFZ0ZI208hDEmcqh6O3Gmko…
libldap.so.2(OPENLDAP_2.200)(64bit)
вот этих двух не было и ещё каких-то двух, они установились в одном пакете, и потом установилась realmd, я уже путаюсь, метод научного тыка, очень утомительная вещь, не хватало 4-х библиотек ей, и они установились одним пакетом потом, ну то есть я устанавливал один, а он за собой потянул все эти

Оффлайн drake63

  • Начинающий
  • *
  • Сообщений: 46
openldap-common вот это вроде, я не знаю, там можно из журнала вытащить ещё команды, которые я в терминал вводил, так понятней было бы, надо посмотреть

Оффлайн gosts 87

  • Завсегдатай
  • *
  • Сообщений: 2 784
  • Дмитрий/Dmitry/德米特里/दिमित्री
Теперь Вам нужно изучить структуру. Изучить, что такое - пакет, какой он бывает. Что такое - исходник. Что такое - бинарник. Что такое - библиотека. Что такое - сборочная зависимость. Что такое - установочная зависимость и т.д. и т.п. ;-D