Автор Тема: планшет Wacom Bamboo Pen CTL-460  (Прочитано 5770 раз)

Оффлайн tux

  • Начинающий
  • *
  • Сообщений: 20
    • Email
планшет Wacom Bamboo Pen CTL-460
« : 28.11.2010 01:54:55 »
Здравствуйте!
у меня ALT Linux 5.0 x86-64
Я купил графический планшет Wacom Bamboo Pen CTL-460, установил сначала пакеты из репозитария:
libwacomcfg-0.8.2
libwacomxi-0.8.2
linuxwacom-0.8.2
xorg-drv-wacom-0.8.2 (xorg-x11-drv-wacom-0,8,0 не ставил, он конфликтует с xorg-drv-wacom-0.8.2)

планшет виден в usbview, но в GIMPe его нету (там есть Маковская мышь, которой у меня нет и не было и обычная мышь которая у меня есть). Устройства /dev/input/wacom - нет. wacomcpl и xsetwacom - планшет не видят.

 Попробовал установить linuxwacom-0.8.8-10 с исходников скаченных с http://linuxwacom.sourceforge.net
(устанавливал по статье http://welinux.ru/post/3631/) после этого у меня появилось устройство /dev/input/wacom, но wacomcpl и xsetwacom - планшет по-прежнему не видят. В GIMPe в настройке даполнительных устройств ввода всё по-прежнему, но в разделе "способы управления" в контролере Linux Input стал доступен  Wacom Bamboo 4х5 Finger и Wacom Bamboo 4х5 Pen! Если выбрать последний, то при запуске  gimp из консоли, в консоле появляются строки:
linux_input_get_device_info: #keys = 0
linux_input_get_device_info: #ext_keys = 0
linux_input_get_device_info: button 0x140 present
linux_input_get_device_info: button 0x141 present
linux_input_get_device_info: button 0x14a present
linux_input_get_device_info: button 0x14b present
linux_input_get_device_info: button 0x14c present
linux_input_get_device_info: #buttons = 5
linux_input_get_device_info: abs 0x00 present [0..14720]
linux_input_get_device_info: abs 0x01 present [0..9200]
linux_input_get_device_info: abs 0x18 present [0..1023]
linux_input_get_device_info: abs 0x28 present [0..0]
linux_input_get_device_info: #abs = 4

А если поводить пером по планшету то:
inux_input_read_event: EV_ABS code = 0x00 (value = 4000)
linux_input_read_event: EV_ABS code = 0x01 (value = 6528)
linux_input_read_event: EV_ABS code = 0x00 (value = 4012)
linux_input_read_event: EV_ABS code = 0x01 (value = 6503)
linux_input_read_event: EV_ABS code = 0x00 (value = 3998)
linux_input_read_event: EV_ABS code = 0x01 (value = 6463)
linux_input_read_event: EV_ABS code = 0x01 (value = 6430)
linux_input_read_event: EV_ABS code = 0x00 (value = 3988)
linux_input_read_event: EV_ABS code = 0x01 (value = 6393)
linux_input_read_event: EV_ABS code = 0x00 (value = 3996)
linux_input_read_event: EV_ABS code = 0x01 (value = 6350)
linux_input_read_event: EV_ABS code = 0x01 (value = 6307)
linux_input_read_event: EV_ABS code = 0x00 (value = 4006)
linux_input_read_event: EV_ABS code = 0x01 (value = 6254)
linux_input_read_event: EV_ABS code = 0x00 (value = 4020)
linux_input_read_event: EV_ABS code = 0x01 (value = 6216)
linux_input_read_event: EV_ABS code = 0x00 (value = 4054)
linux_input_read_event: EV_ABS code = 0x01 (value = 6174)
linux_input_read_event: EV_ABS code = 0x00 (value = 4088)
linux_input_read_event: EV_ABS code = 0x01 (value = 6134)
linux_input_read_event: EV_ABS code = 0x00 (value = 4109)
linux_input_read_event: EV_ABS code = 0x01 (value = 6093)
linux_input_read_event: EV_KEY code = 0x140
linux_input_read_event: EV_ABS code = 0x28 (value = 0)
и т.д.
 Но при этом курсор на перо ни как не реагирует.
Попробовал добавить в xorg.conf строки (копию оригинального xorg.conf сделал):

Section "InputDevice"     
  Driver       "wacom"   
  Identifier   "cursor"     
  Option       "Device" "/dev/input/wacom"
  Option       "SendCoreEvents" "on"   
  Option       "Type" "cursor"     
  Option       "USB" "on"
  Option       "Vendor" "WACOM"
EndSection 

Section "InputDevice"     
   Driver       "wacom"     
   Identifier   "stylus"   
   Option       "Device" "/dev/input/wacom"
  Option       "SendCoreEvents" "on"     
  Option       "Type" "stylus"   
  Option       "USB" "on"
  Option       "Vendor" "WACOM"
EndSection

Ситуация не изменилась (перезагрузиться не забыл), меня так же поразил, тот факт, что в xorg.conf почему-то не было ни каких упоминаний о клавиатуре и мыши (но не спотря на это они отлично работают) Сейчас мой xorg.conf выглядит так:

Section "ServerLayout"
   Identifier     "Minimal layout"
   Screen         "Screen0" 0 0
EndSection

Section "Module"
   SubSection "extmod"
      Option       "omit xfree86-dga"
   EndSubSection
EndSection

Section "InputDevice"     
  Driver       "wacom"   
  Identifier   "cursor"     
  Option       "Device" "/dev/input/wacom"
  Option       "SendCoreEvents" "on"   
  Option       "Type" "cursor"     
  Option       "USB" "on"
  Option       "Vendor" "WACOM"
EndSection 

Section "InputDevice"     
   Driver       "wacom"     
   Identifier   "stylus"   
   Option       "Device" "/dev/input/wacom"
  Option       "SendCoreEvents" "on"     
  Option       "Type" "stylus"   
  Option       "USB" "on"
  Option       "Vendor" "WACOM"
EndSection

Section "Monitor"
   Identifier   "LG F920P|0"
   HorizSync    30.0 - 111.0
   VertRefresh  50.0 - 160.0
EndSection

Section "Device"
   Identifier  "Card0|0"
   Driver      "nvidia"
EndSection

Section "Screen"
   Identifier "Screen0"
   Device     "Card0|0"
   Monitor    "LG F920P|0"
   DefaultDepth     24
   SubSection "Display"
      Modes    "1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1280x720" "1152x870" "1152x864" "1120x840" "1024x768" "1024x736" "1024x600" "960x720" "848x480" "832x624" "800x600" "720x576" "640x480"
   EndSubSection
EndSection

 Что делать дальше я не знаю.

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 32 095
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Re: планшет Wacom Bamboo Pen CTL-460
« Ответ #1 : 28.11.2010 02:37:39 »
Цитировать
Ситуация не изменилась (перезагрузиться не забыл), меня так же поразил, тот факт, что в xorg.conf почему-то не было ни каких упоминаний о клавиатуре и мыши
Да, в последних дистрибутивах используется /etc/X11/xorg.conf.d

Оффлайн tux

  • Начинающий
  • *
  • Сообщений: 20
    • Email
Re: планшет Wacom Bamboo Pen CTL-460
« Ответ #2 : 28.11.2010 09:20:40 »
Файла xorg.conf.d у меня нет.

# ls -a /etc/X11
.              starthere                Xresources-site
..             sysconfig                Xresources-site.be_BY.CP1251
app-defaults   wmsession.d              Xresources-site.ru_RU.CP1251
applnk         wms-methods.d            Xresources-site.ru_RU.KOI8-R
enlightenment  xdm                      Xresources-site.uk_UA.CP1251
fontpath.d     xinit                    Xresources-site.uk_UA.KOI8-U
kdm4           xinit.d                  Xresources.uk_UA.CP1251
lib            xorg.conf                Xresources.uk_UA.KOI8-U
lib_nvidia     Xresources               xscreensaver
prefdm         Xresources.be_BY.CP1251  Xsession
profile.d      Xresources.ru_RU.CP1251
serverconfig   Xresources.ru_RU.KOI8-R
« Последнее редактирование: 29.11.2010 19:56:36 от Skull »

Оффлайн tux

  • Начинающий
  • *
  • Сообщений: 20
    • Email
Re: планшет Wacom Bamboo Pen CTL-460
« Ответ #3 : 28.11.2010 11:29:13 »
Наткнулся на ещё одну инструкцию по настройке планшета: http://unixforum.org/index.php?showtopic=96930
 Там о wacomcpl, пишут, что для неё нужно запустить сценарий /etc/init.d/wacomtohal, содержание данного файла приводится, но я не могу выполнить "update-rc.d wacomtohal defaults 27", поскольку у меня почему-то нет update-rc.d. В репозитарии я не нашёл update-rc.d. Как быть?
Как я понял, мой планшет работает, но не видет в иксах. Поскольку после запуска "wacdump /dev/input/wacom" все движения пером отображаются в консоли ввиде цифр.
 Но в выводе "xsetpointer -l" и "xidump -l" нет ни слова о планшете.
Как это можно вылечить?

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 32 095
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Re: планшет Wacom Bamboo Pen CTL-460
« Ответ #4 : 28.11.2010 14:37:34 »
Советую спросить в рассылке

https://lists.altlinux.org/mailman/listinfo/hardware