Автор Тема: Alt Linux 10.1 не запускается с ядром 6 версии  (Прочитано 752 раз)

Оффлайн gosts 87

  • Завсегдатай
  • *
  • Сообщений: 2 013
  • Дмитрий/Dmitry/德米特里/दिमित्री
При загрузке с ядром 5.10.177 - ошибок не наблюдается...
Никаких записей вроде:
modprobe: FATAL: Module efivarfs not found in directory /lib/modules/5.10.177-std-def-alt1при старте системы нет!
« Последнее редактирование: 10.05.2023 22:13:10 от gosts 87 »

Оффлайн nialiv

  • Давно тут
  • **
  • Сообщений: 64
    • Email
Спасибо, я понял, однако, исходя из принципа "лучшее - враг хорошего", ничего делать не буду. Просто сохранил систему в образ и некоторое время понаблюдаю, не хочу портить вполне работоспособную систему, а дальше, "будем посмотреть".
PS: Кстати, Debian при старте выводит сообщение об ошибках, это началось ещё с 10-й версии, вот они:
[4.052067] sd 7:0:0:0: [sdh] No caching mode page found
[4.052097] sd 7:0:0:0: [sdh] Assuming drive cache: write trough
[4.102117] scsi 7:0:0:1: Wrong diahnostic page: asked for 1 got 8
[4.102160] scsi 7:0:0:1: Failed to get diagnostic page 0x1
[4.102193] scsi 7:0:0:1: Failed to bind enclosure -19 debian10: clean, 214204/1220608 files, 1750542/4882176 bloks
Однако, на работу это не влияет и я перестал обращать внимание.

Оффлайн gosts 87

  • Завсегдатай
  • *
  • Сообщений: 2 013
  • Дмитрий/Dmitry/德米特里/दिमित्री
исходя из принципа "лучшее - враг хорошего", ничего делать не буду.
У меня на такие случаи, в системе всегда хранится два ядра. :-)

Оффлайн nialiv

  • Давно тут
  • **
  • Сообщений: 64
    • Email
Конечно, очень хотелось бы остаться на Альте, всё-таки российская система, к тому же очень стабильная, хотя и довольно сложная для изучения.
У меня есть несколько Linux систем, полностью настроенные и отлаженные, но ни одна не работает так же стабильно, как Alt Linux, даже Debian, к тому же Alt Linux я уже неплохо изучил и привык к нему.
Думаю, проблему можно считать, если не решённой, то не влияющей на работу системы, во всяком случае, пока.
А там разработчики что-нибудь сделают, но переходить на GPT не планирую, в крайнем случае вернусь на ядро 5-й версии.

Оффлайн nialiv

  • Давно тут
  • **
  • Сообщений: 64
    • Email
У меня на такие случаи, в системе всегда хранится два ядра.
Дело в том, что у меня несколько систем и все они, кроме основной, расположены на отдельных USB_HDD и, чтобы можно было оперативно сменить систему, я устанавливаю их в одинаковые разделы, /boot - 1GB, / (корневой) - 20 GB, swap - 8 GB и /home - 11 GB, в сумме это составляет 40 GB.
Это очень удобно, когда надо поменять систему, просто разворачиваю посекторно в те же разделы другую с образа и пользуюсь. На всё, про всё не более 8 минут.
А вот с Альтом вышла промашка, для него не хватает места в корневом разделе и приходится проводить глобальную чистку системы, буквально после каждого чиха. Даже при одном ядре свободное место в корневом разделе не более 3 GB, иногда невозможно даже произвести обновление системы, приходится до и после обновления проводить глобальную чистку.
Очевидно, придётся пересматривать размер корневого раздела в сторону его увеличения.
Кстати, такая же проблема "нарисовалась" и в Fedora 38.

Оффлайн gosts 87

  • Завсегдатай
  • *
  • Сообщений: 2 013
  • Дмитрий/Dmitry/德米特里/दिमित्री
20 ГБ для Альт 10 - это слишком мало. Рекомендую не менее 30-и.

Оффлайн Nicom

  • Давно тут
  • **
  • Сообщений: 405
    • Email
Дело в том, что у меня несколько систем и все они, кроме основной, расположены на отдельных USB_HDD
Может Вам имеет смысл подумать в сторону виртуализации, хотя-бы в рамках VirtualBox?
Или, смотреть сразу в сторону отдельного сервера виртуализации, например, с proxmox?

Поставить в компьютер HDD на 2-4-8Тб и перенести все необходимые системы в виртуальные с USB дисков. Можно поставить 2 диска одинакового объёма и с помощью md сделать RAID1 для отказоустойчивости.
А если добавить RAM, то и возможность одновременной работы сразу в нескольких ОС появится.
« Последнее редактирование: 11.05.2023 22:24:00 от Nicom »

Оффлайн nialiv

  • Давно тут
  • **
  • Сообщений: 64
    • Email
Как говорится, "Факир был пьян и фокус не удался". Буквально полчаса назад во время обновления Alt Linux с ядром 6.1.26-un-def-alt1 система перестала загружаться. Загрузка остановилась и "замёрзла", после вывода сообщений
 "modprobe: FATAL: Module efivarfs not found in directory /lib/modules/6.1.26-un-def-alt1
  modprobe: FATAL: Module efivarfs not found in directory /lib/modules/6.1.26-un-def-alt1".
Система даже не загружается с ядром 5-й версии.
Что самое смешное, недавно установленная система Simply Linux, с новым ядром той же версии и сегодняшним обновлением, загружается и прекрасно работает и при загрузке не выводится ни каких сообщений об ошибках.


Оффлайн Антон Мидюков

  • alt linux team
  • ***
  • Сообщений: 5 083
  • antohami@
Как говорится, "Факир был пьян и фокус не удался". Буквально полчаса назад во время обновления Alt Linux с ядром 6.1.26-un-def-alt1 система перестала загружаться. Загрузка остановилась и "замёрзла", после вывода сообщений
 "modprobe: FATAL: Module efivarfs not found in directory /lib/modules/6.1.26-un-def-alt1
  modprobe: FATAL: Module efivarfs not found in directory /lib/modules/6.1.26-un-def-alt1".
Система даже не загружается с ядром 5-й версии.
Что самое смешное, недавно установленная система Simply Linux, с новым ядром той же версии и сегодняшним обновлением, загружается и прекрасно работает и при загрузке не выводится ни каких сообщений об ошибках.

Уберите splash quiet из параметров загрузки, чтобы увидеть проблему.

Оффлайн nialiv

  • Давно тут
  • **
  • Сообщений: 64
    • Email
Уберите splash quiet из параметров загрузки, чтобы увидеть проблему.
Восстановил систему с образа, всё стало работать нормально. Система снова предложила обновление, для эксперимента снова стандартно обновил систему. После перезагрузки система снова не стала загружаться.
Точнее, до обновления системы дело не дошло, загрузились только файлы, система предложила перезагрузиться для обновления и перестала загружаться, последнее, что я увидел.
Это сообщение об ошибке отправляю из Simply Linux с последними обновлениями и ядром 6.1.28-un-def-alt1 (64-бита).
PS: После очередного обновления ядра до версии 6.1.32-un-def-alt1 (64-бита), Simply тоже перестала грузиться, а ведь  Simply, по сути та же Alt Linux, только с интерфейсом Xfce. Получается, что это системная ошибка разработчика.
Кстати, Debian 11 с ядром 6-й версии работает гораздо лучше, чем с ядром 5-й версии, после установки нового ядра в Debian прекратились проблемы с локальной сетью.
PS: Смысла убирать splash quiet из параметров загрузки просто нет, достаточно во время загрузки нажать клавишу "Esc" и в любой Linux весь процесс загрузки, как на ладони, однако, в этом нет ни какого смысла, во-первых, попробуйте умудриться увидеть, прочитать и проанализировать нужную строку, а во-вторых, в моём случае в этом просто нет смысла по причине того, что загрузка системы останавливается в самом начале, на стадии загрузки ядра, светодиод HDD загорается и стабильно горит не моргая, самое большое время, которое я выдержал - полчаса.
« Последнее редактирование: 12.06.2023 07:36:29 от nialiv »