Автор Тема: Перестал работать Lutris  (Прочитано 962 раз)

Оффлайн hasculdr

  • Завсегдатай
  • *
  • Сообщений: 658
Перестал работать Lutris
« : 06.11.2022 17:17:16 »
Установленный несколько месяцев назад на новую установку kWorkstation прекрасно работал, после своего последнего обновления (из Flatpak-репозитория) выдает сообщение:
Цитировать
Missing vulkan libraries
Lutris was unable to detect Vulkan support for the i386 architecture.
This will prevent many games and programs from working.
To install it, please use the folowing guide: Installing Graphics Drivers
В системе присутствуют такие пакеты:
$ rpm -qa | grep libdrm
i586-libdrm-2.4.109-alt1.i586
libdrm-2.4.109-alt1.x86_64
$ rpm -qa | grep amdgpu
vulkan-amdgpu-2021.Q4.1-alt1.x86_64
xorg-drv-amdgpu-19.1.0-alt3.x86_64
i586-xorg-drv-amdgpu-19.1.0-alt3.i586
i586-vulkan-amdgpu-2021.Q4.1-alt1.i586
$ rpm -qa | grep radeon
xorg-drv-radeon-19.1.0-alt2.x86_64
i586-xorg-drv-radeon-19.1.0-alt2.i586
i586-xorg-dri-radeon-22.0.4-alt1.i586
xorg-dri-radeon-22.0.4-alt1.x86_64
$ rpm -qa | grep vulkan
i586-libvulkan1-1.3.211-alt1.i586
vulkan-amdgpu-2021.Q4.1-alt1.x86_64
vulkan-tools-1.3.211-alt1.x86_64
libvulkan1-1.3.211-alt1.x86_64
vulkan-filesystem-1.3.211-alt1.noarch
i586-vulkan-amdgpu-2021.Q4.1-alt1.i586
Некоторые i586-пакеты ставил дополнительно, пытаясь решить проблему, не получилось. В альтах есть какой-нибудь нюанс с поддержкой 32 бит вулканом?

Оффлайн hasculdr

  • Завсегдатай
  • *
  • Сообщений: 658
Re: Перестал работать Lutris
« Ответ #1 : 07.11.2022 19:16:52 »
Посмотрел ~/.xsession-errors:0, поискал libvulkan.so.1, у лутриса была в том числе и своя собственная. Почему-то был подключен разом и к стабильному репозиторию, и к бета-версии, хотя ранее делал все по оф. инструкции. Удалил репозитории, и еще раз выполнил инструкцию, все работает. Дело было не в бобине (с).