Автор Тема: Проблемы с ноутбуком Depo VIP C1530 (не работает звук изкоробки)  (Прочитано 4642 раз)

Оффлайн miv

  • Начинающий
  • *
  • Сообщений: 8
Добрый день!
По программе импортозамещения закупили нам ноутбуки которые вошли в Единый реестр.
Alt linux 9 версии был установлен без проблем. Но не работал звук.
Нашел на сайте производителя  драйвер Depo для ATL Linux. В инструкции написано что нужно пропатчить ядро и запускать пропатченое ядро. Причем что бы работал звук нужно при каждой загрузки, запускаться через дополнительные параметры загрузки.
При запуске пропатченного ядра, пропадает сетевой адаптер, просто нет в списке оборудования. Звук работает, нет сети проводной, Wi-Fi вроде видит сети(не пробовал подключить). Запускаешь старое ядро, нет звука, есть сеть.
Установил ALT 10 версии, звука так же нет.
Что можно сделать что бы работал и звук и сеть?

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 957
    • Домашняя страница
    • Email
Добрый день!
По программе импортозамещения закупили нам ноутбуки которые вошли в Единый реестр.
Alt linux 9 версии был установлен без проблем. Но не работал звук.
Нашел на сайте производителя  драйвер Depo для ATL Linux. В инструкции написано что нужно пропатчить ядро и запускать пропатченое ядро. Причем что бы работал звук нужно при каждой загрузки, запускаться через дополнительные параметры загрузки.
При запуске пропатченного ядра, пропадает сетевой адаптер, просто нет в списке оборудования. Звук работает, нет сети проводной, Wi-Fi вроде видит сети(не пробовал подключить). Запускаешь старое ядро, нет звука, есть сеть.
Установил ALT 10 версии, звука так же нет.
Что можно сделать что бы работал и звук и сеть?
Обратиться в техподдержку DEPO за разъяснениями. Потому что использование сторонних ядер нет смысла обсуждать здесь, на форуме сообщества.
Андрей Черепанов (cas@)

Оффлайн miv

  • Начинающий
  • *
  • Сообщений: 8
Обратиться в техподдержку DEPO за разъяснениями. Потому что использование сторонних ядер нет смысла обсуждать здесь, на форуме сообщества.
Добрый день!
Сразу говорю, я ещё только разбираюсь в linux, поэтому могут быть глупые вопросы или действия.
Что я делал до этого.
Нет звука на ноутбуке, инструкция от DEPO, что бы заработал звук.
Спойлер
# Обновление списков репозиториев.
1. apt-get update

# Установка linux-firmware.
2. apt-get install linux-firmware

# Распаковка архива с ядром.
3. Распаковать es8336-kernel.tar.gz в домашнюю директорию пользолвателя.

# Войти в каталог.
4. cd ~/es8336-kernel

# Установка ядра с зависимостями.
5. \cp -r kernel/* /

# Копирование файлов прошивки для поддержки es8336.
6. cp sof-cml.ri /lib/firmware/intel/sof/
7. cp sof-cml.ldc /lib/firmware/intel/sof/
8. cp sof-glk-es8336-ssp0.tplg /lib/firmware/intel/sof-tplg/

# Обновление grub и initrd.
9. make-initrd -k 5.12.6-cnl
10. update-grub
11. Перезагрузитесь и при включении ноутбука выберите новый пункт 5.12.6-cnl для работы звука.


Для возможности выбора в списке устройств вывода звука HDMI:
nano /etc/pulse/default.pa
Добавить в конце файла
load-module module-alsa-sink device=hw:0,5 sink_name=HDMI sink_properties=device.description=HDMI

Выполнить от пользователя:
pulseaudio -k
pulseaudio --start

После того как сделал все по инструкции, появился звук но пропал сетевой адаптер полностью, система его не видит.

Связался с техподдержкой DEPO, там мне просто дали ссылку на драйвер сетевого адаптера (без VPN туда не зайти) для ноутбука. Там есть инструкция установки драйвера адаптера.
Спойлер
1. Move the base driver tar file to the directory of your choice.
   For example, use '/home/username/e1000e' or '/usr/local/src/e1000e'.

2. Untar/unzip the archive, where <x.x.x> is the version number for the
   driver tar file:

   # tar zxf e1000e-<x.x.x>.tar.gz

3. Change to the driver src directory, where <x.x.x> is the version number
   for the driver tar:

   # cd e1000e-<x.x.x>/src/

4. Compile the driver module:

   # make install

   The binary will be installed as:
   /lib/modules/<KERNEL VER>/updates/drivers/net/ethernet/intel/e1000e/e1000e.ko

   The install location listed above is the default location. This may differ
   for various Linux distributions.

5. Load the module using the modprobe command.

   To check the version of the driver and then load it:

   # modinfo e1000e
   # modprobe e1000e
Сделал как там написано, в итоге когда ввожу в консоле modprobe e1000e, сетевой адаптер поднимается, все работает. Но после перезагрузки сеть пропадает, пока опять не ввести modprobe e1000e из под su -.

Версия alt у меня была 10. Снес систему полностью, установил новую версию alt 10.1. Звук не работал. Выполнил инструкцию от DEPO, которая настраивает звук, сеть и звук появились. Проверил доп меню загрузки там появилось меню ALT Workstation 10.1, 5.12.6-cnl (это которое создается по инструкции от DEPO), а так же стандартные меню:
ALT Workstation 10.1, 5.15.89-un-def-alt1 (Если выбрать это меню то звук работает и сеть тоже) +
ALT Workstation 10.1, 5.10.164-std-def-alt1(Если выбрать это меню то звука нет, сеть работает) -

Если кто столкнулся с этими ноутами, могу скинуть драйвера которые скачал с сайта DEPO, через личные сообщения.


Оффлайн miv

  • Начинающий
  • *
  • Сообщений: 8
Удивительно увлекательная детективная история... - с неослабевающим интересом прочёл.  ;-D
Долго тренировался что бы было увлекательно;-D

Только есть у меня подозрение (? это не обязательно), что при первейшем же стандартном обновлении ALT Linux - всё кино повторится по новой силе.  :-X
Интересное подозрение, спасибо за подсказку, понаблюдаю.

Оффлайн miv

  • Начинающий
  • *
  • Сообщений: 8

Так я же не возражаю - я вижу и понимаю, по шагам, какая это работа проделана...
(И пытаюсь себе угадать? что же там такого "накулёмили" эти DEPO ... "по программе импортозамещения"  :-o ... Н-да ... : "Бабло пилить - не поле перейти" ;-D)
А мне вот интересно что там за аудио чип, который не может работать из коробки, а нужно ещё устанавливать. Могли бы сразу связаться с производителями alt, astra и т.д. и предоставить свои драйвера, что бы они были уже в составе дистрибутива. С другой стороны, это опыт для меня, хоть ещё не все понимаю но в памяти останется :-D

Оффлайн Rollo

  • Начинающий
  • *
  • Сообщений: 17
    • Email
Версия alt у меня была 10. Снес систему полностью, установил новую версию alt 10.1. Звук не работал. Выполнил инструкцию от DEPO, которая настраивает звук, сеть и звук появились. Проверил доп меню загрузки там появилось меню ALT Workstation 10.1, 5.12.6-cnl (это которое создается по инструкции от DEPO), а так же стандартные меню:
ALT Workstation 10.1, 5.15.89-un-def-alt1 (Если выбрать это меню то звук работает и сеть тоже) +
ALT Workstation 10.1, 5.10.164-std-def-alt1(Если выбрать это меню то звука нет, сеть работает) -

Если кто столкнулся с этими ноутами, могу скинуть драйвера которые скачал с сайта DEPO, через личные сообщения.
Не надо сторонние драйвера, достаточно поставить ядро un-def 5.15

Оффлайн N0rbert

  • alt linux team
  • ***
  • Сообщений: 231
  • snk@
поставить ядро un-def 5.15

И пакет с прошивкой - firmware-alsa-sof .
А еще может потребоваться пакет firmware-alsa-sof-debug из-за файла /lib/firmware/intel/sof/sof-cml.ldc .
« Последнее редактирование: 13.03.2023 23:02:30 от N0rbert »

Оффлайн Pavel P

  • Начинающий
  • *
  • Сообщений: 47
    • Email
Если кто столкнулся с этими ноутами, могу скинуть драйвера которые скачал с сайта DEPO, через личные сообщения.
Зачем нужны эти драйверы, если на официальном ядре 5.15 все работает?

Оффлайн miv

  • Начинающий
  • *
  • Сообщений: 8
Зачем нужны эти драйверы, если на официальном ядре 5.15 все работает?
Сейчас поставил с нуля систему на другой ноутбук. Через ядро 5.15.89-un-def-alt1, все работает. Значит сидеть и устанавливать драйвер на звук не нужно, уже лучше.
Тогда может кто подскажет как поставить что бы это ядро загружалось по умолчанию?

Оффлайн Александр Ерещенко

  • Завсегдатай
  • *
  • Сообщений: 1 177
Зачем нужны эти драйверы, если на официальном ядре 5.15 все работает?
Сейчас поставил с нуля систему на другой ноутбук. Через ядро 5.15.89-un-def-alt1, все работает. Значит сидеть и устанавливать драйвер на звук не нужно, уже лучше.
Тогда может кто подскажет как поставить что бы это ядро загружалось по умолчанию?
Можно просто убрать ядро std-def, т.к. оно точно не понадобится.
remove-old-kernels -t std-defну и на всякий случай повторить
apt-get update
update-kernel -t un-def

Оффлайн Pavel P

  • Начинающий
  • *
  • Сообщений: 47
    • Email
Тогда может кто подскажет как поставить что бы это ядро загружалось по умолчанию?
Я с терминалом на Вы, поэтому пользуюсь графическими программами.
Открываем "Центр управления системой". В разделе "система" заходим в "обновление ядра", выбираем ядро в выпадающем меню, нажимаем на кнопку "загружать по-умолчанию".
Там же можно удалить ненужные ядра.

Оффлайн miv

  • Начинающий
  • *
  • Сообщений: 8
Можно просто убрать ядро std-def, т.к. оно точно не понадобится.
Код: [Выделить]

remove-old-kernels -t std-def

ну и на всякий случай повторить
Код: [Выделить]

apt-get update
update-kernel -t un-def


Я с терминалом на Вы, поэтому пользуюсь графическими программами.
Открываем "Центр управления системой". В разделе "система" заходим в "обновление ядра", выбираем ядро в выпадающем меню, нажимаем на кнопку "загружать по-умолчанию".
Там же можно удалить ненужные ядра.


Спасибо что помогли и подсказали!