Автор Тема: Не удаётся установить koodo-reader под Альтлинукс 10  (Прочитано 1188 раз)

Оффлайн GrishaDm

  • Давно тут
  • **
  • Сообщений: 290
Попробовал установить продвинутую читалку для книг (отсюда https://github.com/koodo-reader/koodo-reader) и не смог. Очень жаль, пишут, что она сравнима по возможностям в встроенной читалкой в виндовc (там их около десятка разных, но под Линукс нет версий).
А те 5 простеньких, что есть в репозитории (Bookworm, calibre, E-book viewer, FBReader, Foliate) - рядом и близко не стоят.

Оффлайн asa

  • Начинающий
  • *
  • Сообщений: 41
, но под Линукс нет версий)
Там под линукс несколько вариантов. Попробуйте например по этой инструкции запустить https://www.altlinux.org/Appimage

Оффлайн ASte

  • Мастер
  • ***
  • Сообщений: 1 552
оно вроде бы есть на флатхабе, а флатак у альта есть в репах

Оффлайн GrishaDm

  • Давно тут
  • **
  • Сообщений: 290
Там под линукс несколько вариантов.
Имелось в виду нет версий у продвинутых читалок от МС только под виндовс (справа по ссылке там целый список их): https://apps.microsoft.com/detail/9WZDNCRDM0S9?hl=ru-ru&gl=RU
Почему данная программа продвинутая - она, к примеру, имеет возможность подключения переводчиков, озвучки текстов и т. п.
Всё-таки удалось поставить программу, но теперь она не запускается.
[a@lureenvoy ~]$ koodo-reader
LaunchProcess: failed to execvp:
/opt/Koodo
Ловушка трассировки/останова
[a@lureenvoy ~]$ [9070:0100/000000.664113:ERROR:zygote_linux.cc(647)] write: Обрыв канала (32)

То же самое, но из-под root:
[a@lureenvoy ~]$ su -
Password:
[root@lureenvoy ~]# koodo-reader
[1219/203937.990366:FATAL:electron_main_delegate.cc(297)] Running as root without --no-sandbox is not supported. See https://crbug.com/638180.
Ловушка трассировки/останова
[root@lureenvoy ~]#
Установлен вот этот rpm-пакет: https://objects.githubusercontent.com/github-production-release-asset-2e65be/245049028/9e6b5019-8c2d-4972-b04e-0238a9388653?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAIWNJYAX4CSVEH53A%2F20231219%2Fus-east-1%2Fs3%2Faws4_request&X-Amz-Date=20231219T134202Z&X-Amz-Expires=300&X-Amz-Signature=48eddb207a7fc62ad310f907741df1a513887d32f9fc21a5b607e81f70329dca&X-Amz-SignedHeaders=host&actor_id=0&key_id=0&repo_id=245049028&response-content-disposition=attachment%3B%20filename%3DKoodo.Reader-1.5.1.rpm&response-content-type=application%2Foctet-stream
« Последнее редактирование: 19.12.2023 16:43:04 от GrishaDm »

Оффлайн Виктор Дуб

  • Завсегдатай
  • *
  • Сообщений: 533
А те 5 простеньких, что есть в репозитории (Bookworm, calibre, E-book viewer, FBReader, Foliate) - рядом и близко не стоят.
Перечисленные может и не стоят.
Но,я юзаю новый FBReader, не реповый.

И потом...
Вам что нужно - читалка или прелесть? :)
« Последнее редактирование: 19.12.2023 18:52:59 от Виктор Дуб »

Оффлайн asa

  • Начинающий
  • *
  • Сообщений: 41
Всё-таки удалось поставить программу, но теперь она не запускается.
Запускай так koodo-reader --no-sandbox
Установлен вот этот rpm-пакет
Правильнее было бы скачать appimage или deb  перепаковать его с помощью epm в правильный rpm. Инструкцию выше давал.

« Последнее редактирование: 19.12.2023 17:40:49 от asa »

Оффлайн GrishaDm

  • Давно тут
  • **
  • Сообщений: 290
Запускай так
Код: [Выделить]

koodo-reader --no-sandbox
Спасибо. Действительно запустилась программа.

Оффлайн artenaki

  • Давно тут
  • **
  • Сообщений: 192
Но, я юзаю новый FBReader, не реповый
Из snap? Странная прога. Требует новейших либ (Qt 6.5, libzip5, glibc и т.д.). Потому Deb дистрибутивы никаким боком не поддерживаются, кроме snap, который не все хотят использовать.
« Последнее редактирование: 21.12.2023 03:47:11 от artenaki »

Оффлайн Виктор Дуб

  • Завсегдатай
  • *
  • Сообщений: 533
Из snap? Странная прога.
Да, снаповая. Поставить RPM пока руки не дошли :)
Работает хорошо - никаких странностей не наблюдаю. Или у вас в идеологическом смысле недоумение?  :-D

Оффлайн artenaki

  • Давно тут
  • **
  • Сообщений: 192
Или у вас в идеологическом смысле недоумение?
Идеологическое. Лишние процессы, автоматически обновляется. В том же Минте snapd отключают.

Хинт: можно установить fbreader в snapd, а потом отключить службу:
sudo systemctl stop snapd
sudo systemctl disable snapd
sudo systemctl mask snapd

и запускать вручную (пути могут быть немного другими):
Цитировать
/snap/core20/2105/usr/lib/x86_64-linux-gnu/ld-2.31.so --library-path /snap/fbreader/29/lib/x86_64-linux-gnu:/snap/fbreader/29/usr/lib/x86_64-linux-gnu:/snap/fbreader/29/usr/lib:/snap/core20/2105/usr/lib/x86_64-linux-gnu:/snap/core20/2105/usr/lib /snap/fbreader/29/bin/FBReader

Или подправив ярлык /var/lib/snapd/desktop/applications/fbreader_fbreader.desktop вписав команду выше после Exec=
Правда, лог сообщает, что не будет работать dbus.

Когда потребуется включить snapd обратно:
sudo systemctl unmask snapd
sudo systemctl enable snapd
sudo systemctl start snapd

Новый FBReader, в принципе, симпатичный.
А что делать дистрибутивам, где нет snap (Mageia, OpenMandriva), а системные библиотеки старые или некошерные (qt6 clang'овый)?
Отвечаю сам себе: утащить из убунты папки /snap (1,9 ГБ) и может быть /var/lib/snapd (626M) и запускать предложенной командой. Но это непроверено.
« Последнее редактирование: 23.12.2023 15:14:24 от artenaki »

Оффлайн artenaki

  • Давно тут
  • **
  • Сообщений: 192
Поставить RPM пока руки не дошли
А и не получится. Разве что в Сизифе.

Оффлайн Виктор Дуб

  • Завсегдатай
  • *
  • Сообщений: 533
Разве что в Сизифе.
Второй год на регулярке с гномом катаюсь :)

Оффлайн Виктор Дуб

  • Завсегдатай
  • *
  • Сообщений: 533
А что делать дистрибутивам, где нет snap (Mageia, OpenMandriva), а системные библиотеки старые или некошерные (qt6 clang'овый)?
Они сами в состоянии, искать себе филантропов.

Оффлайн artenaki

  • Давно тут
  • **
  • Сообщений: 192
Не знаю в какой читалке можно настроить, чтобы был одностраничный режим (не двухстраничный), но чтобы окно было развернуто/максимизировано и при этом глаза не бегали влево вправо. Т.е. добито большими паддингами слева и справа, но все-таки окно максимизировано. Особенно актуально на 16:9 мониторах, но и на 5:4 тоже. Две страницы как-то непривычно, хочется одну. Но тогда нужны паддинги, чтобы строки не были слишком широкими или не разворачивать на максимум (но в этом случае будут мешать фоновые окна и некрасиво смотрится).
В CoolReader (собрал) можно задать максимум паддинг 60 слева и справа.
В FBReader можно больше, но если окно развернуть, будет две страницы.
Что интересно, в мобильном FBReader на планшете с этим не было проблем, задаешь паддинги какие надо с одной страницей.

Оффлайн artenaki

  • Давно тут
  • **
  • Сообщений: 192
А разобрался. Надо в настройке "разбивать текст, если ширина окна больше" задать значение чуть больше разрешения экрана.