Автор Тема: Подключение МФУ HP_LaserJet_Professional_M1132_MFP  (Прочитано 50943 раз)

Оффлайн kon-dv

  • Завсегдатай
  • *
  • Сообщений: 722
    • Заметки учителя
    • Email
Доброго всем времени суток. Проблема такая:
Недавно купили МФУ HP_LaserJet_Professional_M1132_MFP ( в описании черным по белому было написано, что Linux его поддерживает). Радостно подключил к компу, зашел в cups, выполнил все поэтапно. Однако принтер не печатает, сканер не определяется! Google молчит...
Даже и не знаю с чего начать. Help.
Дистр: Школьный Мастер 5.0
Бранч: 5.1
Ядро: 2.6.32-std-def-alt20.M50P.1
Морфиус на меня обиделся...

Оффлайн kon-dv

  • Завсегдатай
  • *
  • Сообщений: 722
    • Заметки учителя
    • Email
Принтер заработал на драйвере HP LaserJet M1319 MFP Foomatic/foo2zjs-z1. Приступаю к сканеру.
[root@kon-dv ~]# sane-find-scanner

  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x03f0 [Hewlett-Packard], product=0x042a [HP LaserJet Professional M1132 MFP]) at libusb:002:011
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.
« Последнее редактирование: 18.01.2011 12:13:45 от kon-dv »
Морфиус на меня обиделся...

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 31 743
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Попробуйте установить пакет hplip-sane

Оффлайн kon-dv

  • Завсегдатай
  • *
  • Сообщений: 722
    • Заметки учителя
    • Email
Уже есть  :(
[root@kon-dv ~]# apt-get install hplip-sane
Reading Package Lists... Done
Building Dependency Tree... Done
hplip-sane is already the newest version.
0 upgraded, 0 newly installed, 0 removed and 0 not upgraded.
При сканировании под root получаю вот это:
[root@kon-dv ~]# scanimage > test.png
scanimage: open of device hpaio:/usb/HP_LaserJet_Professional_M1132_MFP?serial=000000000QH32D2PPR1a failed: Error during device I/O
« Последнее редактирование: 18.01.2011 13:14:03 от kon-dv »
Морфиус на меня обиделся...

Оффлайн kon-dv

  • Завсегдатай
  • *
  • Сообщений: 722
    • Заметки учителя
    • Email
Еще вот такой момент:
Нашел вот такое руководство http://freeschool.nnov.ru/node/37, но при установке получаю:
[root@kon-dv ~]# sh  /root/hplip-3.10.9-plugin.run
Verifying archive integrity... All good.
Uncompressing HPLIP 3.10.9 Plugin Self Extracting Archive.........................................

HP Linux Imaging and Printing System (ver. 3.10.9)
Plugin Installer ver. 3.0

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Plug-in version: 3.10.9
Installed HPLIP version: 3.10.9
Number of files to install: 36

error: Unable to load Qt4 support. Is it installed? Try running with -i or --qt3 instead.
Help..
Морфиус на меня обиделся...

Оффлайн yaleks

  • Мастер
  • ***
  • Сообщений: 6 157
hplip-gui поставьте

Оффлайн kon-dv

  • Завсегдатай
  • *
  • Сообщений: 722
    • Заметки учителя
    • Email
[root@kon-dv ~]# apt-get install hplip-gui
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  hplip-gui: Depends: hplip (= 3.10.6-alt0.M51.1)
E: Broken packages
Морфиус на меня обиделся...

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 31 743
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Настройте правильно репозитории, из которых обновляетесь.

$ grep -R ^rpm  /etc/apt

Оффлайн kon-dv

  • Завсегдатай
  • *
  • Сообщений: 722
    • Заметки учителя
    • Email
Решение было найдено следующее (благодаря одному оччень классному гуру):
в hplip-3.10.9-plugin.run исправили строчку scriptargs="-v 3.10.9 -c 36" на scriptargs="-v 3.10.9 -c 36 -i". В результате лицензия и процесс установки вышел в консоль. Все заработало.
Морфиус на меня обиделся...

Оффлайн kon-dv

  • Завсегдатай
  • *
  • Сообщений: 722
    • Заметки учителя
    • Email
[root@kon-dv ~]# grep -R ^rpm  /etc/apt
/etc/apt/sources.list:rpm http://ftp.altlinux.org/pub/distributions/ALTLinux/5.1/branch/ i586 classic 
/etc/apt/sources.list:rpm http://ftp.altlinux.org/pub/distributions/ALTLinux/5.1/branch/ noarch classic 
Морфиус на меня обиделся...

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 31 743
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
rpm -qa | grep hplip

Оффлайн kon-dv

  • Завсегдатай
  • *
  • Сообщений: 722
    • Заметки учителя
    • Email
[root@kon-dv ~]# rpm -qa | grep hplip
hplip-PPDs-3.10.9-alt0.M50P.1
hplip-common-3.10.9-alt0.M50P.1
hplip-3.10.9-alt0.M50P.1
hplip-sane-3.10.9-alt0.M50P.1
hplip-hpijs-3.10.9-alt0.M50P.1
Морфиус на меня обиделся...

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 31 743
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Я понял - вы воспользовались рецептом для p5. а у вас бренч 5.1.

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 31 743
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
http://www.sisyphus.ru/ru/srpm/Sisyphus/hplip
5.1:  3.10.6-alt0.M51.1
p5:  3.10.9-alt0.M50P.1

Оффлайн str07str

  • Завсегдатай
  • *
  • Сообщений: 72
принтер настроил http://forum.altlinux.org/index.php/topic,9574.msg129300.html#msg129300
сканер тоже не работает
заменил scriptargs="-v 3.10.9 -c 36" на scriptargs="-v 3.10.9 -c 36 -i"
запускаю, получаю ошибку MD5 не соответсвует.
Как это обойти или может есть более ровные дрова?