Автор Тема: Помогите новичку разобраться  (Прочитано 11951 раз)

Оффлайн МИНЗДРАВ

  • Странник_
  • *
  • Сообщений: 3 045
  • ALWK8 х64 Branch sysd & server-light_1.9.3sysV noX
    • http://yx-kak.ru/linux.htm
Re: Помогите новичку разобраться
« Ответ #15 : 04.07.2013 21:14:06 »
Почему скриншот не работаетет? Где искать его исполняемые файлы?
KHotKeys was unable to execute 'ksnapshot'
Please verify existence and permissions of the executable file

Оффлайн worktowork

  • Завсегдатай
  • *
  • Сообщений: 365
Re: Помогите новичку разобраться
« Ответ #16 : 04.07.2013 21:50:57 »
Ответьте , на  вопрос чем Вы будете заниматься на ПК и технические данные вашего ПК?

Оффлайн БарсSc

  • alt linux team
  • ***
  • Сообщений: 1 089
  • Intel_i7/nVidia_Optimus, AMD Ryzen 3 2200
Re: Помогите новичку разобраться
« Ответ #17 : 04.07.2013 21:56:18 »
Почему скриншот не работаетет? Где искать его исполняемые файлы?
KHotKeys was unable to execute 'ksnapshot'
Please verify existence and permissions of the executable file
Да переустановите вы уже систему (и не лезьте особо никуда в дебри), ksnapshot в р7 работает прекрасно, а разбираться в том что вы там с системой натворили уже наверно никто не хочет (т.к. форум по поводу р7 завален вашими темами и вопросами, в основном необоснованно, тем самым создается впечатление, что р7 еще сыроват).
« Последнее редактирование: 09.07.2013 19:34:56 от BarsSc »

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 10 259
Re: Помогите новичку разобраться
« Ответ #18 : 05.07.2013 02:01:01 »
Почему скриншот не работаетет? Где искать его исполняемые файлы?
KHotKeys was unable to execute 'ksnapshot'
Please verify existence and permissions of the executable file
Цитировать
KHotKeys не смог выполнить 'KSnapshot'
Пожалуйста проверьте наличие и права доступа исполняемого файла.

В p6 с XFCE где-то так:
# xfce4-session --version
xfce4-session 4.8.2 (Xfce 4.8)
# aptitude search ~i~dscreen~dshot
i   kdegraphics-ksnapshot                       - A KDE applet for taking snapshots of the desktop     
i   shotwell                                    - digital photo organizer designed for the GNOME desktop
i   xfce4-screenshooter                         - Дополнение для панели XFCE позволяющее делать снимки э
# rpm -ql xfce4-screenshooter|grep bin
/usr/bin/xfce4-screenshooter
# ls -l $(rpm -ql xfce4-screenshooter|grep bin)
-rwxr-xr-x 1 root root 72684 Май  2  2011 /usr/bin/xfce4-screenshooter
$ echo $P <Tab>
$PATH            $PPID            $PS1             $PS4             
$PIPESTATUS      $PROMPT_COMMAND  $PS2             $PWD             
$ echo $PATH
/home/user/bin:/bin:/usr/bin:/usr/X11R6/bin:/usr/games

На других DE в p7/branch и p8/branch как-то так же.
« Последнее редактирование: 05.07.2013 02:05:59 от Speccyfighter »

Оффлайн МИНЗДРАВ

  • Странник_
  • *
  • Сообщений: 3 045
  • ALWK8 х64 Branch sysd & server-light_1.9.3sysV noX
    • http://yx-kak.ru/linux.htm
Re: Помогите новичку разобраться
« Ответ #19 : 09.07.2013 11:12:27 »
Хватит пугать-то!

Спасибо написали как пакет называется ksnapshot
просто установил его, и всё заработало.

Оффлайн МИНЗДРАВ

  • Странник_
  • *
  • Сообщений: 3 045
  • ALWK8 х64 Branch sysd & server-light_1.9.3sysV noX
    • http://yx-kak.ru/linux.htm
Re: Помогите новичку разобраться
« Ответ #20 : 09.07.2013 13:17:20 »
Подскажите пожалуйста вместо опенофиса, в P7 что надо использовать? В синаптике ничё знакомого не нахожу.
« Последнее редактирование: 09.07.2013 13:58:45 от МИНЗДРАВ »

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 920
    • Домашняя страница
    • Email
Re: Помогите новичку разобраться
« Ответ #21 : 09.07.2013 14:33:54 »
Подскажите пожалуйста вместо опенофиса, в P7 что надо использовать? В синаптике ничё знакомого не нахожу.
apt-get install LibreOffice4-full LibreOffice4-langpack-ru LibreOffice4-gnome
Андрей Черепанов (cas@)

Оффлайн МИНЗДРАВ

  • Странник_
  • *
  • Сообщений: 3 045
  • ALWK8 х64 Branch sysd & server-light_1.9.3sysV noX
    • http://yx-kak.ru/linux.htm
Re: Помогите новичку разобраться
« Ответ #22 : 09.07.2013 18:49:48 »
apt-get install LibreOffice4-full LibreOffice4-langpack-ru LibreOffice4-gnome
чё-то не пашет
[root@host-242 ~]# apt-get update
Получено: 1 ftp://ftp.altlinux.org i586 release [913B]
Получено: 2 ftp://ftp.altlinux.org noarch release [707B]
Получено 1620B за 0s (2890B/s).
Найдено ftp://ftp.altlinux.org i586/classic pkglist
Найдено ftp://ftp.altlinux.org i586/classic release
Найдено ftp://ftp.altlinux.org noarch/classic pkglist
Найдено ftp://ftp.altlinux.org noarch/classic release
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
[root@host-242 ~]# apt-get install LibreOffice4-full LibreOffice4-langpack-ru LibreOffice4-gnome
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Некоторые пакеты установить невозможно. Это может означать, что Вы
потребовали невозможного, либо пользуетесь нестабильным репозиторием.
Часть необходимых пакетов либо ещё не создана, либо была удалена
из каталога 'Входящие'.
Эти сведения могут помочь найти выход из ситуации:

Следующие пакеты имеют неудовлетворенные зависимости:
  LibreOffice4-full: Требует: LibreOffice4-integrated (= 4.0-alt7.1)
  LibreOffice4-gnome: Требует: libreoffice4 (= 4.0-alt7.1)
                      Требует: libicule.so.50
                      Требует: libicuuc.so.50
                      Требует: LibreOffice4-common (= 4.0-alt7.1)
  LibreOffice4-langpack-ru: Требует: libreoffice4 (= 4.0-alt7.1)
E: Извините, `битые' пакеты
[root@host-242 ~]# apt-repo
rpm ftp://ftp.altlinux.org/pub/distributions/ALTLinux/p7/branch i586 classic
rpm ftp://ftp.altlinux.org/pub/distributions/ALTLinux/p7/branch noarch classic
[root@host-242 ~]# 
чем ему помочь можно?

Оффлайн montigomo

  • Давно тут
  • **
  • Сообщений: 359
  • Montigomo
    • Email
Re: Помогите новичку разобраться
« Ответ #23 : 10.07.2013 23:35:43 »
Я предпочитаю устанавливать программные продукты с установочных дисков - так надёжнее и стабильнее. А главное, что на диске собраны именно те вспомогательные библиотеки, которые нужны этому релизу.
Из репозитория устанавливать здорово, но очень часто для того, чтобы установить одну программу необходимо установить или обновить два десятка библиотек, после чего часто перестают работать другие приложения.
Алексей ЕФАНОВ, г. СПб.; ноутбук Lenovo Т420;
BaseAlt Workstation 10.1 МАТЕ (x86_64)

Оффлайн МИНЗДРАВ

  • Странник_
  • *
  • Сообщений: 3 045
  • ALWK8 х64 Branch sysd & server-light_1.9.3sysV noX
    • http://yx-kak.ru/linux.htm
Re: Помогите новичку разобраться
« Ответ #24 : 11.07.2013 15:45:49 »
Я предпочитаю устанавливать программные продукты с установочных дисков - так надёжнее и стабильнее.
В случае обновления, Ваш способ плох, тем что
Очень долго, перефирию заново нужно настраивать!

чайник

  • Гость
Re: Помогите новичку разобраться
« Ответ #25 : 11.07.2013 15:58:23 »
Подскажите пожалуйста вместо опенофиса, в P7 что надо использовать? В синаптике ничё знакомого не нахожу.

Я чего то пропустил? так ведь вместо опенофиса и стоит LibreOffice. Опенофис, если память не отшибла мне, стояла только в р5 и ниже.
bash-3.2$ rpm -qa | grep LibreOffice
LibreOffice4-mimetypes-4.0-alt7.1
LibreOffice4-kde4-4.0-alt7.1
LibreOffice4-common-4.0-alt7.1
LibreOffice4-langpack-uk-4.0-alt7.1
LibreOffice4-full-4.0-alt7.1
LibreOffice4-langpack-ru-4.0-alt7.1
LibreOffice4-integrated-4.0-alt7.1

bash-3.2$ apt-cache search libreoffice
LibreOffice4 - LibreOffice Productivity Suite
LibreOffice4-common - Basic installation of LibreOffice4
LibreOffice4-extensions - Additional extensions for LibreOffice4
LibreOffice4-full - LibreOffice Productivity Suite
LibreOffice4-gnome - GNOME Extensions for LibreOffice4
LibreOffice4-integrated - Binaries, icons and desktop files for LibreOffice4
LibreOffice4-kde4 - KDE4 Extensions for LibreOffice4
LibreOffice4-langpack-de - German language pack for LibreOffice4
LibreOffice4-langpack-es - Espanian language pack for LibreOffice4
LibreOffice4-langpack-fr - French language pack for LibreOffice4
LibreOffice4-langpack-kk - Kazakh language pack for LibreOffice4
LibreOffice4-langpack-pt-BR - Brazilian language pack for LibreOffice4
LibreOffice4-langpack-ru - Russian language pack for LibreOffice4
LibreOffice4-langpack-uk - Ukrainian language pack for LibreOffice4
LibreOffice4-standalone - Renamed binaries, icons and desktop files for LibreOffice4
libreoffice - LibreOffice Productivity Suite
libreoffice-gnome - GNOME Extensions for LibreOffice
libreoffice-langpack-de - Language-specific files, German
libreoffice-langpack-es - Language-specific files, Spanish
libreoffice-langpack-fr - Language-specific files, French
libreoffice-langpack-pt-BR - Language-specific files, Brazil Portuguese
libreoffice-langpack-ru - Language-specific files, Russian
libreoffice-langpack-uk - Language-specific files, Ukrainian
libreoffice-languagetool - LibreOffice/OpenOffice.org extension for proofreading
i586-LibreOffice4-common - Basic installation of LibreOffice4
i586-LibreOffice4-extensions - Additional extensions for LibreOffice4
i586-LibreOffice4-gnome - GNOME Extensions for LibreOffice4
i586-LibreOffice4-kde4 - KDE4 Extensions for LibreOffice4
i586-libreoffice - LibreOffice Productivity Suite
i586-libreoffice-gnome - GNOME Extensions for LibreOffice
LibreOffice4-mimetypes - Mimetype keys support for LibreOffice4
hunspell-ru-lebedev - Словарь русского языка для myspell/hunspell, разрешена замена "ё" на "е"
hunspell-ru-lebedev-ie - Словарь русского языка для myspell/hunspell без поддержки буквы "ё"
hunspell-ru-lebedev-io - Словарь русского языка для myspell/hunspell с обязательным употреблением буквы "ё"
unoconv - Tool to convert between any document format supported by LibreOffice
writer2latex - Flexible tool to convert OpenOffice documents into LaTeX2e and XHTML formats

« Последнее редактирование: 11.07.2013 16:04:16 от чайник »

Оффлайн МИНЗДРАВ

  • Странник_
  • *
  • Сообщений: 3 045
  • ALWK8 х64 Branch sysd & server-light_1.9.3sysV noX
    • http://yx-kak.ru/linux.htm
Re: Помогите новичку разобраться
« Ответ #26 : 11.07.2013 16:09:41 »
LibreOffice
Хорошо-бы!
Но у меня он требует какие-то страшнын неудовлетворённные зависимости.

Оффлайн МИНЗДРАВ

  • Странник_
  • *
  • Сообщений: 3 045
  • ALWK8 х64 Branch sysd & server-light_1.9.3sysV noX
    • http://yx-kak.ru/linux.htm
Re: Помогите новичку разобраться
« Ответ #27 : 11.07.2013 16:12:30 »
Вообще у меня какая-то проблема странная - после обновления был нормально работающая система. А потом пульсу удалил и половина программм из меню запуска пропала...
У меня этот либреофис давно стоять должен.

Подскажите пожплуйста, можно как-то  к дефолтному виду систему привести?
Если пакет kde4 поставить, подобные баги изчезнут?

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 920
    • Домашняя страница
    • Email
Re: Помогите новичку разобраться
« Ответ #28 : 11.07.2013 17:09:46 »
очень часто для того, чтобы установить одну программу необходимо установить или обновить два десятка библиотек, после чего часто перестают работать другие приложения.
В ALT Linux такая ситуация скорее исключение. Давненько я такого не припомню.
Андрей Черепанов (cas@)

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 920
    • Домашняя страница
    • Email
Re: Помогите новичку разобраться
« Ответ #29 : 11.07.2013 17:11:50 »
Если пакет kde4 поставить, подобные баги изчезнут?
На вашем бы месте я бы поставил дистрибутив и ничего бы самостоятельно не делал под root. С неуёмной инициативой без знаний можно легко что-то сломать, а потом опять будете всех просить починить.
Андрей Черепанов (cas@)