Автор Тема: Не запускается графическая оболочка  (Прочитано 3137 раз)

Оффлайн odinokiyklaus

  • Начинающий
  • *
  • Сообщений: 10
apt-get remove
Скажу больше, удалять надо так:
apt-get -D --purge remove <имя пакета>

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 956
    • Домашняя страница
    • Email
Странный совет. В Альте purge для apt-get бессмысленен: он ничего не делает.
Андрей Черепанов (cas@)

Оффлайн sib

  • Начинающий
  • *
  • Сообщений: 7
ГРАФИКА: intel UHD 610 (думаю дело в ней и драйверах, но не факт)
Сборка: Alt Regular - GNOME x86_64
У меня тоже графика Intel. Пробовал собрать минимальную систему с DWM несколько недель назад (перед этим проверял на виртуалке, всё - получилось). На железе с xorg,ом непонятное что то творилось. После установки сервера, драйвера и попытке запуска startx погас экран и компьютер вообще не реагировал на нажатия кнопок. Потом я установил другие драйвера x11 (не относящиеся к интел), mesa. Удалось его запустить, собрал DWM. Потом оказалось, что нельзя завершить выполнение xorg. Даже командой systemctl poweroff не удавалось завершить работу xorg (killall xinit тоже не работал) - компьютер зависал. Также сегодня пробовал установить gnome regular. При работе GNOME под Wayland остаются следы от курсора - копии (на других дистрибутивах такое не видел). А при работе под Xorg - опять при выходе компьютер завис.
На других дистрибутивах такое не наблюдалось.
Без графических систем regular-jeos-systemd нормально работал (по крайней мере нормально выключался/включался).

upd Процессор Intel(R) Core(TM) i5-4440 CPU @ 3.10GHz - на нём были проблемы. Отчетов никаких нет - систему удалил.
« Последнее редактирование: 03.11.2023 21:29:18 от sib »

Оффлайн sib

  • Начинающий
  • *
  • Сообщений: 7
У меня тоже графика Intel. Пробовал собрать минимальную систему с DWM несколько недель назад (перед этим проверял на виртуалке, всё - получилось). На железе с xorg,ом непонятное что то творилось. После установки сервера, драйвера и попытке запуска startx погас экран и компьютер вообще не реагировал на нажатия кнопок. Потом я установил другие драйвера x11 (не относящиеся к интел), mesa. Удалось его запустить, собрал DWM. Потом оказалось, что нельзя завершить выполнение xorg. Даже командой systemctl poweroff не удавалось завершить работу xorg (killall xinit тоже не работал) - компьютер зависал. Также сегодня пробовал установить gnome regular. При работе GNOME под Wayland остаются следы от курсора - копии (на других дистрибутивах такое не видел). А при работе под Xorg - опять при выходе компьютер завис.
На других дистрибутивах такое не наблюдалось.
Без графических систем regular-jeos-systemd нормально работал (по крайней мере нормально выключался/включался).

upd Процессор Intel(R) Core(TM) i5-4440 CPU @ 3.10GHz - на нём были проблемы. Отчетов никаких нет - систему удалил.

Устранили проблему с работой графики. Проверял на Alt Regular Gnome (tested),  https://mirror.yandex.ru/altlinux-nightly/tested/regular-gnome-latest-x86_64.iso. И wayland и xorg работают нормально.