Автор Тема: после обновления исчез сетевой интерфейс  (Прочитано 608 раз)

Оффлайн XBM

  • Давно тут
  • **
  • Сообщений: 478
  • Бэкап - акт проявления трусости.
    • Email
Сегодня обновил систему (P10, установилось ядро 5.10.208-std-def-alt1) и обнаружил, что в компе не стало сетевой карты.
[root@twin7those ~]# inxi -N
Network:
  Message: No PCI device data found.
  Device-1: D-Link DUB-E100 Fast Ethernet Adapter(rev.C1) [ASIX AX88772]
    driver: asix type: USB
[root@twin7those ~]#
Device-1: это я подключил внешнюю сетевую usb-карту

Загрузка c предыдущим ядром сеть не вернула.

Подскажите пожалуйста, как вернуть сетевой интерфейс?
Спойлер
[root@twin7those ~]# inxi -Fxz
System:
  Kernel: 5.10.179-std-def-alt1 arch: x86_64 bits: 64 compiler: N/A
    Console: pty pts/0 Distro: starter kit 10
Machine:
  Type: Desktop Mobo: Gigabyte model: B760M H DDR4 v: x.x serial: N/A
    UEFI: American Megatrends LLC. v: F5 date: 07/24/2023
CPU:
  Info: quad core model: 12th Gen Intel Core i3-12100 bits: 64 type: MT MCP
    arch: Alder Lake rev: 5 cache: L1: 320 KiB L2: 5 MiB L3: 12 MiB
  Speed (MHz): avg: 800 min/max: 800/5500 cores: 1: 800 2: 800 3: 800 4: 800
    5: 800 6: 800 7: 800 8: 800 bogomips: 52838
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: Intel Alder Lake-S GT1 [UHD Graphics 730] vendor: Gigabyte
    driver: N/A arch: Gen-12.2 bus-ID: 00:02.0
  Display: x11 server: X.Org v: 1.20.14 with: Xwayland v: 23.1.1 driver: X:
    loaded: N/A unloaded: fbdev gpu: N/A resolution: 1920x1080
  API: OpenGL v: 4.5 vendor: mesa v: 23.1.9 glx-v: 1.4 direct-render: yes
    renderer: llvmpipe (LLVM 15.0.7 256 bits)
  API: EGL Message: EGL data requires eglinfo. Check --recommends.
Audio:
  Device-1: Intel vendor: Gigabyte driver: snd_hda_intel v: kernel
    bus-ID: 00:1f.3
  API: ALSA v: k5.10.179-std-def-alt1 status: kernel-api
  Server-1: PulseAudio v: 16.1 status: active (root, process)
Network:
  Message: No PCI device data found.
  Device-1: D-Link DUB-E100 Fast Ethernet Adapter(rev.C1) [ASIX AX88772]
    driver: asix type: USB bus-ID: 1-9:5
  IF: enp0s20f0u9 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 953.88 GiB used: 85.19 GiB (8.9%)
  ID-1: /dev/nvme0n1 vendor: Seagate model: XPG GAMMIX S50 Lite
    size: 476.94 GiB temp: 36 ° (309 K) C
  ID-2: /dev/nvme1n1 vendor: Silicon Power model: SPCC M.2 PCIe SSD
    size: 476.94 GiB temp: 45 ° (318 K) C
...

Оффлайн N0rbert

  • alt linux team
  • ***
  • Сообщений: 231
  • snk@
Mobo: Gigabyte model: B760M H DDR4

Укажите, пожалуйста, полное название материнской платы и ее ревизию.
Беглый поиск на linux-hardware.org дает два вариант сетевых плат в семействе B760M - Realtek Semiconductor RTL8125 2.5GbE Controller (драйвер r8169) и Intel Ethernet Controller I225-V (драйвер igc) - у вас какая?

Видится ли (и включена ли) сетевая плата в BIOS, с какого-нибудь загрузочного диска с Linux или из второй системы?

Только что проверил - сетевые карты на драйверах r8168 и e1000e нормально работают на ядре 5.10.208-std-def-alt1, а r8169 и igc у меня нет.
« Последнее редактирование: 26.01.2024 22:43:00 от N0rbert »

Оффлайн XBM

  • Давно тут
  • **
  • Сообщений: 478
  • Бэкап - акт проявления трусости.
    • Email
GIGABYTE B760M H DDR4
chipset: Intel Raptor Lake-S PCH
BIOS Date 07/24/2023 Version F5

В биосе сетевая карта в состоянии ENABLE,
но там же: LAN MAC ADDRESS    N/A
В winPE и в апрельской инсталяшке ubuntu сеть не видится.

Вероятно, совпадение двух событий: обновление системы и отказ встроенной сетевой карты.
Обновление ни при чём.
Извиняюсь за поднятую панику.