Автор Тема: Не получается обновить Calibre  (Прочитано 626 раз)

Оффлайн Yellow Moon

  • Начинающий
  • *
  • Сообщений: 18
Добрый день,
После установки Calibre из репозитория Simply Linux программа предлагает обновиться с версии 5.23 до 7.7.0 с помощью командной строки. При вводе команды Терминал выдает предупреждение:
You are missing the system library libxcb-cursor.so.0. Try installing packages such as libxcb-cursor0 or xcb-cursor

Что следует предпринять для решения этой проблемы? Спасибо.

Оффлайн gosts 87

  • Завсегдатай
  • *
  • Сообщений: 2 724
  • Дмитрий/Dmitry/德米特里/दिमित्री
Re: Не получается обновить Calibre
« Ответ #1 : 27.03.2024 22:10:05 »
После установки Calibre из репозитория Simply Linux программа предлагает обновиться с версии 5.23 до 7.7.0
Не следует с этим соглашаться. Версии 7.7.0 даже в Сизифе нет.
You are missing the system library libxcb-cursor.so.0. Try installing packages such as libxcb-cursor0 or xcb-cursor
А так, для корректного обновления не хватает нескольких установочных зависимостей...
« Последнее редактирование: 27.03.2024 22:19:06 от gosts 87 »

Оффлайн Yellow Moon

  • Начинающий
  • *
  • Сообщений: 18
Re: Не получается обновить Calibre
« Ответ #2 : 28.03.2024 18:33:30 »
А так, для корректного обновления не хватает нескольких установочных зависимостей...

Вопрос к знатокам: каким образом можно установить недостающие пакеты?

На другом моем компьютере, тоже под управление Simply Linux, установлена Calibre версии 6.29. Работает великолепно даже несмотря на то, как Вы выразились, ее нет в Сизифе. Обновление производил через Терминал путем ввода командной строки с сайта разработчика Calibre. Обновление до версии 7.7.0 невозможно по той же причине.

Оффлайн буратино-42

  • Давно тут
  • **
  • Сообщений: 100
Re: Не получается обновить Calibre
« Ответ #3 : 28.03.2024 19:03:29 »
1.
You are missing the system library libxcb-cursor.so.0.

попробуйте установить пакет libxcbutil-cursor
  в нём есть требуемая библиотека: libxcb-cursor.so.0

2.
Try installing packages such as libxcb-cursor0 or xcb-cursor

на это не обращайте внимания
« Последнее редактирование: 28.03.2024 19:06:07 от буратино-42 »

Оффлайн Yellow Moon

  • Начинающий
  • *
  • Сообщений: 18
Re: Не получается обновить Calibre
« Ответ #4 : 29.03.2024 00:14:38 »
попробуйте установить пакет libxcbutil-cursor

Спасибо большое за подсказку! После установки пакета  libxcbutil-cursor удалось без проблем обновить Calibre до версии 7.7.0.

Оффлайн gosts 87

  • Завсегдатай
  • *
  • Сообщений: 2 724
  • Дмитрий/Dmitry/德米特里/दिमित्री
Re: Не получается обновить Calibre
« Ответ #5 : 29.03.2024 00:33:45 »
установлена Calibre версии 6.29. Работает великолепно даже несмотря на то, как Вы выразились, ее нет в Сизифе.
Я сказал, что в Сизифе нет конкретной версии этой программы:
Версии 7.7.0 даже в Сизифе нет.
Есть Версия: 7.5.1-alt1.1
https://packages.altlinux.org/ru/search/?branch=sisyphus&q=Calibre
« Последнее редактирование: 29.03.2024 00:37:17 от gosts 87 »