Автор Тема: PHP 7.3.31 как установить на P10 ?  (Прочитано 462 раз)

Оффлайн reshta

  • Давно тут
  • **
  • Сообщений: 94
Здравствуйте, переношу хостинг на другой сервер.
На старом сервере работает сайт под управлением древней 1c-Bitrix на Apache + PHP 7.3.31-1~deb10u1.
На новом сервере поставил php 8.2, php 7.4 и php-fpm для управления версией php для конкретного сайта.
Но данный сайт криво работает под php 7.4 и не работает совсем под php 8.2 (ругается на несовместимость кода).
Хотел поставить конкретно  PHP 7.3.31, но в репозитории именно этой сборки не нашёл, есть PHP 7.2.34 в P8 и PHP 7.3.33 в P9
Скачал исходник PHP 7.3.31, но не уверен, что смогу заставить его работать с Apache2 и php-fpm.
Что делать?

Оффлайн gosts 87

  • Завсегдатай
  • *
  • Сообщений: 2 785
  • Дмитрий/Dmitry/德米特里/दिमित्री
Re: PHP 7.3.31 как установить на P10 ?
« Ответ #1 : 20.03.2024 15:38:42 »
Попробуйте:
epm repack PHP 7.3.31-1~deb10u1(от обычного пользователя!)
и если перепакуется, то попробуйте установить (от Рута).

Оффлайн reshta

  • Давно тут
  • **
  • Сообщений: 94
Re: PHP 7.3.31 как установить на P10 ?
« Ответ #2 : 21.03.2024 05:02:10 »
epm repack PHP 7.3.31-1~deb10u1
хорошо, но в системе есть установленные пакеты c именем php7-* . Что произойдёт при попытке epm установить другой пакет с таким же именем?
Ещё php7 разбит на много пакетов, и многие из них нужно установить другой версии. Я хочу попробовать откатить в P10 PHP7.4 на PHP7.2.38 из p8.
Думаю, добавить репозиторий P8, поставить пакеты PHP7 из него, зафиксировать их.
Нашел такую инструкцию https://www.altlinux.org/Downgrade там написано, как понизить целую систему. Но как понизить отдельный пакет?
« Последнее редактирование: 21.03.2024 05:27:56 от reshta »

Оффлайн reshta

  • Давно тут
  • **
  • Сообщений: 94
Re: PHP 7.3.31 как установить на P10 ?
« Ответ #3 : 21.03.2024 07:07:43 »
Этот старый сайт оказался не нужен. Вопрос отпал.
Прошу прощения за пустое беспокойство.
Спасибо!

Оффлайн asy

  • alt linux team
  • ***
  • Сообщений: 8 139
Re: PHP 7.3.31 как установить на P10 ?
« Ответ #4 : 21.03.2024 09:46:03 »
Попробуйте:
epm repack PHP 7.3.31-1~deb10u1(от обычного пользователя!)
и если перепакуется, то попробуйте установить (от Рута).
Только правильнее было бы попробовать php7 из старого репозитория ALT поставить, или архива. Может быть сработало бы.

Оффлайн asy

  • alt linux team
  • ***
  • Сообщений: 8 139
Re: PHP 7.3.31 как установить на P10 ?
« Ответ #5 : 21.03.2024 09:47:21 »
Нашел такую инструкцию https://www.altlinux.org/Downgrade там написано, как понизить целую систему. Но как понизить отдельный пакет?
Просто не dist-upgrade делать, а install <пакет>. Или удалить и поставить заново, php точно можно удалять в этом варианте, его удаление систему не вынесет.

Оффлайн gosts 87

  • Завсегдатай
  • *
  • Сообщений: 2 785
  • Дмитрий/Dmitry/德米特里/दिमित्री
Re: PHP 7.3.31 как установить на P10 ?
« Ответ #6 : 21.03.2024 15:45:32 »
хорошо, но в системе есть установленные пакеты c именем php7-* . Что произойдёт при попытке epm установить другой пакет с таким же именем?
Имя после перепаковки будет не совсем такое-же.

Оффлайн gosts 87

  • Завсегдатай
  • *
  • Сообщений: 2 785
  • Дмитрий/Dmitry/德米特里/दिमित्री
Re: PHP 7.3.31 как установить на P10 ?
« Ответ #7 : 21.03.2024 15:47:58 »
Только правильнее было бы попробовать php7 из старого репозитория ALT поставить
ТС, насколько я понимаю, нужен пакет определённой версии, которой нет и не было в репозиториях Альта.