Автор Тема: Smart Board Software и Simply Linux 7  (Прочитано 16034 раз)

Оффлайн berkut_174

  • Мастер
  • ***
  • Сообщений: 7 009
    • Email
Smart Board Software и Simply Linux 7
« : 13.03.2014 07:45:43 »
Всем привет!

При установке программы Smart Notebook 11 на Simply 6 создавалась отдельная директория в меню "SMART Technologies" внутри создавались ещё поддиректории и т.д.
В Simply 7 ситуация изменилась, все значки помещаются в директорию "Другие". Конечно, может в этом есть свои преимущества, но всё же хотелось бы иметь отдельный пункт меню, как это было в Simply 6. Полагаю, что дело в пакете altlinux-freedesktop-menu-xfce. Но зачем так сделали ? Быть может можно более лояльно отнестись к стороннему софту... Хотя и вручную внести необходимые правки можно...
Спасибо.
Сноси Винду, переходи на Линукс ! :)

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 18 691
    • Домашняя страница
    • Email
Re: Smart Board Software и Simply Linux 7
« Ответ #1 : 13.03.2014 15:01:41 »
Всем привет!

При установке программы Smart Notebook 11 на Simply 6 создавалась отдельная директория в меню "SMART Technologies" внутри создавались ещё поддиректории и т.д.
В Simply 7 ситуация изменилась, все значки помещаются в директорию "Другие". Конечно, может в этом есть свои преимущества, но всё же хотелось бы иметь отдельный пункт меню, как это было в Simply 6. Полагаю, что дело в пакете altlinux-freedesktop-menu-xfce. Но зачем так сделали ? Быть может можно более лояльно отнестись к стороннему софту... Хотя и вручную внести необходимые правки можно...
Спасибо.
Попробуйте по очереди все altlinux-freedesktop-*-menu
Андрей Черепанов (cas@)

Оффлайн XBM

  • Давно тут
  • **
  • Сообщений: 463
  • Бэкап - акт проявления трусости.
    • Email
Re: Smart Board Software и Simply Linux 7
« Ответ #2 : 27.08.2014 13:01:51 »
Ув. berkut_174!
Поделитесь опытом, как Вы устанавливали smartnotebook на SL (7.04, актуальный p7)?

Мой опыт неудачен :(
Скачал, распаковал:
http://downloads.smarttech.com/software/nb/11linux/11sp1/smartnotebook11sp1_rpm_filesv2.tar.gz
При установке:
[root@celeron-m 1]# apt-get install dkms-2.1.1.2-1.noarch.rpm nwfermi-0.6.5.1-1.i386.rpm
smart-activation-1.1.2033.1-1.i686.rpm smart-common-10.3.1778.1-1.i686.rpm
smart-gallerysetup-1.3.6133.1-1.i686.rpm smart-hwr-11.3.2087.1-1.i686.rpm
smart-languagesetup-2.2.2034.4-1.i686.rpm smart-notebook-11.0.6457.0-1.i686.rpm
smart-product-drivers-11.3.2088.1-1.i686.rpm xf86-input-nextwindow-0.3.6-1.i686.rpm
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Выбрано dkms для 'dkms-2.1.1.2-1.noarch.rpm'
Выбрано nwfermi для 'nwfermi-0.6.5.1-1.i386.rpm'
Выбрано smart-activation для 'smart-activation-1.1.2033.1-1.i686.rpm'
Выбрано smart-common для 'smart-common-10.3.1778.1-1.i686.rpm'
Выбрано smart-gallerysetup для 'smart-gallerysetup-1.3.6133.1-1.i686.rpm'
Выбрано smart-hwr для 'smart-hwr-11.3.2087.1-1.i686.rpm'
Выбрано smart-languagesetup для 'smart-languagesetup-2.2.2034.4-1.i686.rpm'
Выбрано smart-notebook для 'smart-notebook-11.0.6457.0-1.i686.rpm'
Выбрано smart-product-drivers для 'smart-product-drivers-11.3.2088.1-1.i686.rpm'
Выбрано xf86-input-nextwindow для 'xf86-input-nextwindow-0.3.6-1.i686.rpm'
Некоторые пакеты установить невозможно. Это может означать, что Вы
потребовали невозможного, либо пользуетесь нестабильным репозиторием.
Часть необходимых пакетов либо ещё не создана, либо была удалена
из каталога 'Входящие'.
Эти сведения могут помочь найти выход из ситуации:

Следующие пакеты имеют неудовлетворенные зависимости:
  dkms: Требует: modutils но пакет не может быть установлен
  nwfermi: Требует: rpmlib(FileDigests) (<= 4.6.0-1) но пакет не может быть установлен
           Требует: or но пакет не может быть установлен
           Требует: kernel-default-devel но пакет не может быть установлен
  smart-activation: Требует: rpmlib(FileDigests) (<= 4.6.0-1) но пакет не может быть установлен
  smart-common: Требует: rpmlib(FileDigests) (<= 4.6.0-1) но пакет не может быть установлен
  smart-gallerysetup: Требует: rpmlib(FileDigests) (<= 4.6.0-1) но пакет не может быть установлен
  smart-hwr: Требует: rpmlib(FileDigests) (<= 4.6.0-1) но пакет не может быть установлен
  smart-languagesetup: Требует: rpmlib(FileDigests) (<= 4.6.0-1) но пакет не может быть установлен
  smart-notebook: Требует: rpmlib(FileDigests) (<= 4.6.0-1) но пакет не может быть установлен
  smart-product-drivers: Требует: rpmlib(FileDigests) (<= 4.6.0-1) но пакет не может быть установлен
  xf86-input-nextwindow: Требует: rpmlib(FileDigests) (<= 4.6.0-1) но пакет не может быть установлен
                         Требует: xorg-x11-server-Xorg но пакет не может быть установлен
E: Извините, `битые' пакеты

[root@celeron-m 1]# uname -r
3.12.26-std-def-alt2.1
[root@celeron-m 1]#

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 18 691
    • Домашняя страница
    • Email
Re: Smart Board Software и Simply Linux 7
« Ответ #3 : 27.08.2014 13:09:35 »
Однако, надо -compat-пакет делать для закрытия неизвестных зависимостей.
Андрей Черепанов (cas@)

Оффлайн berkut_174

  • Мастер
  • ***
  • Сообщений: 7 009
    • Email
Re: Smart Board Software и Simply Linux 7
« Ответ #4 : 27.08.2014 13:09:57 »
Пожалуйста!

Распаковываете архив, переходите в папку, где лежат установочные пакеты и выполняете от рута:
rpm -Uvh smart-*.rpmОстальное устанавливать не нужно, там нужно читать readme, это для старых досок вроде бы пакеты, я их не устанавливал, всё работает норм.
« Последнее редактирование: 27.08.2014 13:13:07 от berkut_174 »
Сноси Винду, переходи на Линукс ! :)

Оффлайн XBM

  • Давно тут
  • **
  • Сообщений: 463
  • Бэкап - акт проявления трусости.
    • Email
Re: Smart Board Software и Simply Linux 7
« Ответ #5 : 27.08.2014 13:37:45 »
Не, не взлетело. :(
[root@celeron-m 1]# rpm -Uvh smart-*.rpm
ошибка: неудовлетворенные зависимости:
    rpmlib(FileDigests) <= 4.6.0-1 нужен для smart-activation-1.1.2033.1-1
    libudev.so.0   нужен для smart-activation-1.1.2033.1-1
    rpmlib(FileDigests) <= 4.6.0-1 нужен для smart-common-10.3.1778.1-1
    libudev.so.0   нужен для smart-common-10.3.1778.1-1
    rpmlib(FileDigests) <= 4.6.0-1 нужен для smart-gallerysetup-1.3.6133.1-1
    libudev.so.0   нужен для smart-gallerysetup-1.3.6133.1-1
    rpmlib(FileDigests) <= 4.6.0-1 нужен для smart-hwr-11.3.2087.1-1
    libudev.so.0   нужен для smart-hwr-11.3.2087.1-1
    rpmlib(FileDigests) <= 4.6.0-1 нужен для smart-languagesetup-2.2.2034.4-1
    libudev.so.0   нужен для smart-languagesetup-2.2.2034.4-1
    rpmlib(FileDigests) <= 4.6.0-1 нужен для smart-notebook-11.0.6457.0-1
    libudev.so.0   нужен для smart-notebook-11.0.6457.0-1
    rpmlib(FileDigests) <= 4.6.0-1 нужен для smart-product-drivers-11.3.2088.1-1
    libudev.so.0   нужен для smart-product-drivers-11.3.2088.1-1
[root@celeron-m 1]#
rpmlib в репозитарии вообще нет.
[root@celeron-m 1]#apt-cache search rpmlib
[root@celeron-m 1]#

Оффлайн berkut_174

  • Мастер
  • ***
  • Сообщений: 7 009
    • Email
Re: Smart Board Software и Simply Linux 7
« Ответ #6 : 27.08.2014 13:38:36 »
Выводls
Сноси Винду, переходи на Линукс ! :)

Оффлайн berkut_174

  • Мастер
  • ***
  • Сообщений: 7 009
    • Email
Re: Smart Board Software и Simply Linux 7
« Ответ #7 : 27.08.2014 13:40:30 »
apt-get install libudev0
rpm -Uvh smart-*.rpm
Сноси Винду, переходи на Линукс ! :)

Оффлайн XBM

  • Давно тут
  • **
  • Сообщений: 463
  • Бэкап - акт проявления трусости.
    • Email
Re: Smart Board Software и Simply Linux 7
« Ответ #8 : 27.08.2014 13:46:49 »
[root@celeron-m 1]# apt-get install libudev0
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Следующие НОВЫЕ пакеты будут установлены:
  libudev0
0 будет обновлено, 1 новых установлено, 0 пакетов будет удалено и 0 не будет обновлено.
Необходимо получить 53,7kB архивов.
После распаковки потребуется дополнительно 59,0kB дискового пространства.
Получено: 1 http://ftp.altlinux.org i586/classic libudev0 181-alt5.M70P.1 [53,7kB]
Получено 53,7kB за 0s (93,4kB/s).
Совершаем изменения...
Preparing...                                      ################################################################################################### [100%]
1: libudev0                                       ################################################################################################### [100%]
Running /usr/lib/rpm/posttrans-filetriggers
Завершено.

[root@celeron-m 1]# rpm -Uvh smart-*.rpm
ошибка: неудовлетворенные зависимости:
    rpmlib(FileDigests) <= 4.6.0-1 нужен для smart-activation-1.1.2033.1-1
    rpmlib(FileDigests) <= 4.6.0-1 нужен для smart-common-10.3.1778.1-1
    rpmlib(FileDigests) <= 4.6.0-1 нужен для smart-gallerysetup-1.3.6133.1-1
    rpmlib(FileDigests) <= 4.6.0-1 нужен для smart-hwr-11.3.2087.1-1
    rpmlib(FileDigests) <= 4.6.0-1 нужен для smart-languagesetup-2.2.2034.4-1
    rpmlib(FileDigests) <= 4.6.0-1 нужен для smart-notebook-11.0.6457.0-1
    rpmlib(FileDigests) <= 4.6.0-1 нужен для smart-product-drivers-11.3.2088.1-1
[root@celeron-m 1]# ls
customization               README                                    smart-hwr-11.3.2087.1-1.i686.rpm              swbuild.asc
customize.sh                smart-activation-1.1.2033.1-1.i686.rpm    smart-languagesetup-2.2.2034.4-1.i686.rpm     VERSION
dkms-2.1.1.2-1.noarch.rpm   smart-common-10.3.1778.1-1.i686.rpm       smart-notebook-11.0.6457.0-1.i686.rpm         xf86-input-nextwindow-0.3.6-1.i686.rpm
nwfermi-0.6.5.1-1.i386.rpm  smart-gallerysetup-1.3.6133.1-1.i686.rpm  smart-product-drivers-11.3.2088.1-1.i686.rpm
[root@celeron-m 1]#

Оффлайн berkut_174

  • Мастер
  • ***
  • Сообщений: 7 009
    • Email
Re: Smart Board Software и Simply Linux 7
« Ответ #9 : 27.08.2014 13:48:38 »
rpm -Uvh smart-*.rpm
Тогда apt-get попробуйте.
apt-get install smart-*.rpm
Сноси Винду, переходи на Линукс ! :)

Оффлайн XBM

  • Давно тут
  • **
  • Сообщений: 463
  • Бэкап - акт проявления трусости.
    • Email
Re: Smart Board Software и Simply Linux 7
« Ответ #10 : 27.08.2014 13:54:02 »
[root@celeron-m 1]# apt-get install smart-*.rpm
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Выбрано smart-activation для 'smart-activation-1.1.2033.1-1.i686.rpm'
Выбрано smart-common для 'smart-common-10.3.1778.1-1.i686.rpm'
Выбрано smart-gallerysetup для 'smart-gallerysetup-1.3.6133.1-1.i686.rpm'
Выбрано smart-hwr для 'smart-hwr-11.3.2087.1-1.i686.rpm'
Выбрано smart-languagesetup для 'smart-languagesetup-2.2.2034.4-1.i686.rpm'
Выбрано smart-notebook для 'smart-notebook-11.0.6457.0-1.i686.rpm'
Выбрано smart-product-drivers для 'smart-product-drivers-11.3.2088.1-1.i686.rpm'
Некоторые пакеты установить невозможно. Это может означать, что Вы
потребовали невозможного, либо пользуетесь нестабильным репозиторием.
Часть необходимых пакетов либо ещё не создана, либо была удалена
из каталога 'Входящие'.
Эти сведения могут помочь найти выход из ситуации:

Следующие пакеты имеют неудовлетворенные зависимости:
  smart-activation: Требует: rpmlib(FileDigests) (<= 4.6.0-1) но пакет не может быть установлен
  smart-common: Требует: rpmlib(FileDigests) (<= 4.6.0-1) но пакет не может быть установлен
  smart-gallerysetup: Требует: rpmlib(FileDigests) (<= 4.6.0-1) но пакет не может быть установлен
  smart-hwr: Требует: rpmlib(FileDigests) (<= 4.6.0-1) но пакет не может быть установлен
  smart-languagesetup: Требует: rpmlib(FileDigests) (<= 4.6.0-1) но пакет не может быть установлен
  smart-notebook: Требует: rpmlib(FileDigests) (<= 4.6.0-1) но пакет не может быть установлен
  smart-product-drivers: Требует: rpmlib(FileDigests) (<= 4.6.0-1) но пакет не может быть установлен
E: Извините, `битые' пакеты
[root@celeron-m 1]#

Оффлайн berkut_174

  • Мастер
  • ***
  • Сообщений: 7 009
    • Email
Re: Smart Board Software и Simply Linux 7
« Ответ #11 : 27.08.2014 13:54:11 »
Так, подождите у меня версия другая, сейчас посмотрю. По вашей ссылке тоже не ставится.
Сноси Винду, переходи на Линукс ! :)

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 18 691
    • Домашняя страница
    • Email
Re: Smart Board Software и Simply Linux 7
« Ответ #12 : 27.08.2014 14:03:48 »
rpmlib в репозитарии вообще нет.
Это не пакет, а провайд:
$ rpm -q --provides rpm
/usr/lib/rpm/macros.d 
/etc/rpm/macros.d 
/usr/lib/rpm(ArgvFileAction) 
/usr/lib/rpm(CanonPath) 
/usr/lib/rpm(Debug) 
/usr/lib/rpm(Fatal) 
/usr/lib/rpm(FindByFile) 
/usr/lib/rpm(FindByFileUnderBuildroot) 
/usr/lib/rpm(FindByName) 
/usr/lib/rpm(FindPackage) 
/usr/lib/rpm(Info) 
/usr/lib/rpm(PackagedFiles) 
/usr/lib/rpm(RunMethods) 
/usr/lib/rpm(SetupMethods) 
/usr/lib/rpm(ValidateBuildRoot) 
/usr/lib/rpm(Verbose) 
/usr/lib/rpm(Warning) 
rpm = 4.0.4-alt100.76.M70P.1

пока поставьте через rpm -Uvh --nodeps
« Последнее редактирование: 27.08.2014 14:05:51 от Skull »
Андрей Черепанов (cas@)

Оффлайн XBM

  • Давно тут
  • **
  • Сообщений: 463
  • Бэкап - акт проявления трусости.
    • Email
Re: Smart Board Software и Simply Linux 7
« Ответ #13 : 27.08.2014 14:07:07 »
rpmlib в репозитарии вообще нет.
Это не пакет, а провайд:
ок. Словарный запас увеличен на одно слово. :)

Оффлайн berkut_174

  • Мастер
  • ***
  • Сообщений: 7 009
    • Email
Re: Smart Board Software и Simply Linux 7
« Ответ #14 : 27.08.2014 14:17:23 »
Не могу под рукой найти архив, который качал. До завтра найду его и погляжу какая там версия.
Сейчас у меня работает, все обновы на компе стоят, ОС 32-bit.
Сноси Винду, переходи на Линукс ! :)