Автор Тема: Установка "Рабочая станция" на DEPO Neos DF226 в режиме EFI  (Прочитано 36461 раз)

Оффлайн nilford

  • Завсегдатай
  • *
  • Сообщений: 13
    • Email
вывод команды efibootmgr -v:
BootCurrent: 0004
Timeout: 2 seconds
BootOrder: 0004,0003,0001
Boot0001  UEFI: Built-in EFI Shell VenMedia(5023b95c-db26-429b-a648-bd47664c8012)..BO
Boot0003  UEFI: IP4 Realtek PCIe GBE Family Controller PciRoot(0x0)/Pci(0x1c,0x0)/Pci(0x0,0x0)/MAC(309c2361b131,0)/IPv4(0.0.0.00.0.0.0,0,0)..BO
Boot0004* UEFI OS HD(1,GPT,a3d7c231-e23a-804b-9f36-71810158223c,0x800,0x7f800)/File(\EFI\BOOT\BOOTX64.EFI)..BO

Оффлайн Rider

  • /usr/sbin/control
  • *******
  • Сообщений: 1 136
А что будет если сказать команду grub-install и потом посмотреть efibootmgr -v ?

Оффлайн nilford

  • Завсегдатай
  • *
  • Сообщений: 13
    • Email
получилось это
Выполняется установка для платформы x86_64-efi.
Установка завершена. Ошибок нет.

BootCurrent: 0004
Timeout: 2 seconds
BootOrder: 0000,0004,0003,0001
Boot0000* altlinux HD(1,GPT,a3d7c231-e23a-804b-9f36-71810158223c,0x800,0x7f800)/File(\EFI\altlinux\shimx64.efi)
Boot0001  UEFI: Built-in EFI Shell VenMedia(5023b95c-db26-429b-a648-bd47664c8012)..BO
Boot0003  UEFI: IP4 Realtek PCIe GBE Family Controller PciRoot(0x0)/Pci(0x1c,0x0)/Pci(0x0,0x0)/MAC(309c2361b131,0)/IPv4(0.0.0.00.0.0.0,0,0)..BO
Boot0004* UEFI OS HD(1,GPT,a3d7c231-e23a-804b-9f36-71810158223c,0x800,0x7f800)/File(\EFI\BOOT\BOOTX64.EFI)..BO
удалил папку BOOT, запустил снова команду grub-istall,  перезагрузи и загрузка не работает. конец рабочего дня остальные эксперименты завтра
« Последнее редактирование: 30.10.2018 13:03:44 от nilford »

Оффлайн Rider

  • /usr/sbin/control
  • *******
  • Сообщений: 1 136
ну вот теперь стало как надо - появилась своя запись.
А эту нижнюю (четвёртую) можно удалить, как проверите что первая работает.

Оффлайн nilford

  • Завсегдатай
  • *
  • Сообщений: 13
    • Email
ну вот теперь стало как надо - появилась своя запись.
А эту нижнюю (четвёртую) можно удалить, как проверите что первая работает.

удалил папку BOOT, запустил снова команду grub-istall,  перезагрузил и загрузка не работает. конец рабочего дня остальные эксперименты завтра.

как проверить что работает первая?
« Последнее редактирование: 30.10.2018 14:34:53 от nilford »

Оффлайн klark973

  • Давно тут
  • **
  • Сообщений: 653
  • Неспящий саппорт
как проверить что работает первая?
Попробуйте четвёртую удалить, без проверки: efibootmgr -q -B -b 0004
« Последнее редактирование: 31.10.2018 03:21:24 от klark973 »
To moan or to solve -- that is the question!

Оффлайн nilford

  • Завсегдатай
  • *
  • Сообщений: 13
    • Email
Попробуйте четвёртую удалить, без проверки: efibootmgr -q -B -b 0004
Попробовал
[root@]# efibootmgr -q -B -b 0004
[root@]# efibootmgr -v
BootCurrent: 0004
Timeout: 2 seconds
BootOrder: 0003,0001
Boot0001  UEFI: Built-in EFI Shell VenMedia(5023b95c-db26-429b-a648-bd47664c8012)..BO
Boot0003  UEFI: IP4 Realtek PCIe GBE Family Controller PciRoot(0x0)/Pci(0x1c,0x0)/Pci(0x0,0x0)/MAC(309c2361b131,0)/IPv4(0.0.0.00.0.0.0,0,0)..BO
[root@]# grub-install
Выполняется установка для платформы x86_64-efi.
Установка завершена. Ошибок нет.
[root@]# efibootmgr -v
BootCurrent: 0004
Timeout: 2 seconds
BootOrder: 0000,0003,0001
Boot0000* altlinux HD(1,GPT,a3d7c231-e23a-804b-9f36-71810158223c,0x800,0x7f800)/File(\EFI\altlinux\shimx64.efi)
Boot0001  UEFI: Built-in EFI Shell VenMedia(5023b95c-db26-429b-a648-bd47664c8012)..BO
Boot0003  UEFI: IP4 Realtek PCIe GBE Family Controller PciRoot(0x0)/Pci(0x1c,0x0)/Pci(0x0,0x0)/MAC(309c2361b131,0)/IPv4(0.0.0.00.0.0.0,0,0)..BO

после перезагрузки все возвращается на место

BootCurrent: 0004
Timeout: 2 seconds
BootOrder: 0000,0004,0003,0001
Boot0000* altlinux HD(1,GPT,a3d7c231-e23a-804b-9f36-71810158223c,0x800,0x7f800)/File(\EFI\altlinux\shimx64.efi)
Boot0001  UEFI: Built-in EFI Shell VenMedia(5023b95c-db26-429b-a648-bd47664c8012)..BO
Boot0003  UEFI: IP4 Realtek PCIe GBE Family Controller PciRoot(0x0)/Pci(0x1c,0x0)/Pci(0x0,0x0)/MAC(309c2361b131,0)/IPv4(0.0.0.00.0.0.0,0,0)..BO
Boot0004* UEFI OS HD(1,GPT,a3d7c231-e23a-804b-9f36-71810158223c,0x800,0x7f800)/File(\EFI\BOOT\BOOTX64.EFI)..BO
Пробовал также удалять запись и папку BOOT, результат комп не грузится. как только возвращаю папку BOOT на место, все грузится. Сдается мне это из-за материнки.
также пробовал команду efibootmgr -A -b 0004 но все ровно при следующей загрузке запуск происходил с 0004

Оффлайн Rider

  • /usr/sbin/control
  • *******
  • Сообщений: 1 136
Это у вас волшебный BIOS. Обратитесь, пожалуйста, в DEPO.