Автор Тема: Альфа регулярных сборок для armh и aarch64  (Прочитано 73000 раз)

Оффлайн Антон Мидюков

  • alt linux team
  • ***
  • Сообщений: 4 108
  • antohami@
Однако, первый старт системы произвел "неизгладимое впечатление". Возможно, что под Raspberry Pi, на которую собственно прежде всего ориентирована данная регулярная сборка, есть драйвер GPU, использующий аппаратное ускорение. Кстати, если это так, то поделитесь впечатлением как там GUI шевелится.

Нормально шевелится. Надо в регулярке Mate compiz отрубить. Недоработка. Попробуйте сборки xfce и lxqt, пожалуйста.

Оффлайн Антон Мидюков

  • alt linux team
  • ***
  • Сообщений: 4 108
  • antohami@
Дал ссылку на форум sbolshakov@. И вот его ответ:

Цитировать
по glamour:
в моих ранних сборках был такой кусок:
--- %< ---
cat > /etc/X11/xorg.conf.d/99-modesetting-noglamor.conf << 'E_O_F'
Section "Device"
       Identifier      "default"
       Driver          "modesetting"
       Option          "AccelMethod"   "none"
EndSection
E_O_F
--- %< ---
для rpi3 с некоторых пор он не нужен, остальные вольны вписать
это ручками.

по mali:
я не планирую втаскивать в ядра драйвер от arm ltd и тем более
не собираюсь использовать их userspace blob'ы.
В наших ядрах уже есть lima, свободная реализация drm/kms для
Mali 400/450, в обозримом будущем будет и panfrost -- оно же
для современных T7xx.
userspace с поддержкой Mali (главным образом Mesa) я не выкладывал,
поскольку не готово, но тоже не за горами.

Оффлайн Merblud

  • Давно тут
  • **
  • Сообщений: 404
Нормально шевелится. Надо в регулярке Mate compiz отрубить. Недоработка. Попробуйте сборки xfce и lxqt, пожалуйста.

А поподробнее можно? Совсем лагов никаких незаметно, или все-таки подтормаживание заметно?
Сборка lxqt чем-то отличается от той альфы, что пару месяцев назад запостил sb?

Оффлайн Антон Мидюков

  • alt linux team
  • ***
  • Сообщений: 4 108
  • antohami@
Сборка lxqt чем-то отличается от той альфы, что пару месяцев назад запостил sb?

Мои сборки идентичны сборкам регулярок для X86.

А поподробнее можно? Совсем лагов никаких незаметно, или все-таки подтормаживание заметно?

Работает не шустро, это точно. Но приемлемо, как на недобуке.

Оффлайн Merblud

  • Давно тут
  • **
  • Сообщений: 404
Option          "AccelMethod"   "none"

На rpi3 без этого может быть жить и можно, а вот на rk3399 практически невозможно (если нет ARM-го блоба). И compiz тут как уже понятно не причем. Я первым делом попытался его отключить, на это ушло минут 10, так как перерисовывалось все через 5 секунд после тыкания куда-либо мышкой. И только потом понял, что оказывается glamoregl в сочетании с swrast - это ужас, летящий на крыльях ночи.

Я тоже не в восторге от ARM-их блобов. Более того, подчас не поймешь есть ли вообще от них польза в плане ускорения. Но насколько я понимаю на некоторых одноплатниках (в частности это касается того же rockchip-а) без открытого ARM-го драйвера в ядре ничего нельзя будет вывести на экран даже через fb. Рад был бы в этом заблуждаться. Тогда пусть меня поправят.

lima для mali 400/450 как-то уже припозднилась. Mali t7xx я что0то как-то даже и не встречал в широко доступных одноплатниках. У меня вот t8xx, что мне делать?

Кстати, если уж тут пошел такой разговор, то регулярной сборке для vivante затычка, и в сизифе я что-то не вижу etnaviv. Я пробовал её собирать гед-то год назад. Работала, но правда по краней мере на тот момент времени, от аппараратного ускорения в исполнении etnaviv толку особого заметно не было.

Оффлайн sb

  • Модератор глобальный
  • *****
  • Сообщений: 8 722
  • Кто ищет, тот найдёт.
Сборка lxqt,... что пару месяцев назад запостил sb?
Для ясности: не имею к сборкам iso-шников никакого отношения в данный момент, вы меня с кем-то спутали вероятно. Может разве что тему выделял откуда-то из другой темы, почему и авторство темы могло быть моим, но не авторство сборки.

Оффлайн Merblud

  • Давно тут
  • **
  • Сообщений: 404
Сборка lxqt,... что пару месяцев назад запостил sb?
Для ясности: не имею к сборкам iso-шников никакого отношения в данный момент, вы меня с кем-то спутали вероятно. Может разве что тему выделял откуда-то из другой темы, почему и авторство темы могло быть моим, но не авторство сборки.

Да, извиняюсь, темы соседние в ARM-ой ветке, видимо строчки попутал. Тему создал Rider: "Образ ALTLinux Sisyphus для Raspberry PI3 и Odroid C2". А образ создал Сергей Большаков.

Оффлайн Balbes

  • Мастер
  • ***
  • Сообщений: 565
Option          "AccelMethod"   "none"

На rpi3 без этого может быть жить и можно, а вот на rk3399 практически невозможно (если нет ARM-го блоба). И compiz тут как уже понятно не причем. Я первым делом попытался его отключить, на это ушло минут 10, так как перерисовывалось все через 5 секунд после тыкания куда-либо мышкой. И только потом понял, что оказывается glamoregl в сочетании с swrast - это ужас, летящий на крыльях ночи.

Я тоже не в восторге от ARM-их блобов. Более того, подчас не поймешь есть ли вообще от них польза в плане ускорения. Но насколько я понимаю на некоторых одноплатниках (в частности это касается того же rockchip-а) без открытого ARM-го драйвера в ядре ничего нельзя будет вывести на экран даже через fb. Рад был бы в этом заблуждаться. Тогда пусть меня поправят.

lima для mali 400/450 как-то уже припозднилась. Mali t7xx я что0то как-то даже и не встречал в широко доступных одноплатниках. У меня вот t8xx, что мне делать?

Кстати, если уж тут пошел такой разговор, то регулярной сборке для vivante затычка, и в сизифе я что-то не вижу etnaviv. Я пробовал её собирать гед-то год назад. Работала, но правда по краней мере на тот момент времени, от аппараратного ускорения в исполнении etnaviv толку особого заметно не было.
Не пишите чепухи. На rk3399 без всяких блобов для T860 DE XFCE летает и видео в полный экран до 1080р работает без заметных тормозов в чисто софтовом режиме. Я не знаю, что и как сделано в образе регулярки, возможно в них есть ошибки по отношению к ARM.

RPi3 - это чахлик, даже с включенным HW. и не подходит для нормального десктопа.
Кстати, посмотрел в образе набор u-boot - там всё для древних Allwiner ?

RPi сильно проигрывает текущим возможностям  rk3328\rk3399.
Многие наверно не знают, насколько быстро RK сейчас развивается в плане поддержки OpenSource.
« Последнее редактирование: 11.01.2019 17:51:33 от Balbes »

Оффлайн sb

  • Модератор глобальный
  • *****
  • Сообщений: 8 722
  • Кто ищет, тот найдёт.
Не пишите чепухи. На rk3399 без всяких блобов для T860 DE XFCE летает и видео в полный экран до 1080р работает без заметных тормозов в чисто софтовом режиме.
На альтовой регуляке летает ?

Оффлайн Balbes

  • Мастер
  • ***
  • Сообщений: 565
На альтовой регуляке летает ?
Увы, нет. Это Armbian.
Кстати, вышел медиа-скрипт для включения в Armbian HW на rk3399 для полноэкранного видео на любом разрешении (есть вариант и для rk3288, скоро ожидается для rk3328). Я сейчас тестирую этот скрипт (точнее тот софт с HW что он ставит автоматом) на Khadas EDGE rk3399, в Armbian. Без него система и так работает шустро (1080р можно смотреть и без HW), а с включением HW все летает и на 4К разрешении экрана. Буквально сейчас крутиться ютуб в полный экран на десктопе в браузере с разрешением рабочего стола 4096х20160 вообще без тормозов. MPV - в полный экран любое видео крутит (единственный недостаток, нельзя произвольно масштабировать на рабочем столе). Gstreamer - любое видео в любом масштабе с полным ускорением на рабочем столе. KODI - тут даже комментировать не чего, любое видео в полный экран.
Сам рабочий стол XFCE без всякого HW так же работе очень шустро даже на 4K разрешениях, про 1080р даже говорить не приходиться о каких то тормозах.
подробности
https://forum.armbian.com/topic/9272-development-rk3399-media-script/
https://forum.khadas.com/t/armbian-for-khadas-edge/3168/24


п.с. скорее всего причина тормозов в Alt - использование swrast, когда пытались его использовать в LE для s912, были дикие тормоза и от него категорично отказались.

Оффлайн Balbes

  • Мастер
  • ***
  • Сообщений: 565
Попробовал регулярку с XFCE (с использованием своего ядра). Сама система работает нормально, причина тормозов в swras (те же симптомы, что я наблюдал на LE, когда пытались использовать этот swrast). Хотел его удалить - но похоже он прибит гвоздями к xorg (mesa).

Специально посмотрел в Armbian (Debian\Ubuntu) - там нет swrast. Зачем то к xorg в Alt прибили гвоздями кучу всего , поэтому скорее всего и глюки.
« Последнее редактирование: 12.01.2019 20:51:10 от Balbes »

Оффлайн Merblud

  • Давно тут
  • **
  • Сообщений: 404
Я попробовал установить свежую (видимо это февральская - скачал где-то неделю назад) сборку lxqt на rk3399. С предыдущими сборками (декабрь) проблем не было в том смысле, что они успешно устанвливались (хотя потом не все работало, но это отдельный разговор). Правда ранее именно lxqt я не пробовал.
Но теперь потерпел фиаско.
Ядро грузится, но далее, судя по всему, установщик не запускается. В текстовой консоли предлагается ввести логин. Так как он неизвестен (мне по карйней мере), то на этом все и завершается.
С оталдочного порта я увидел ругань типа такой:

Failed to start Run scripts from /etc/firsttime.d.
See 'systemctl status altlinux-first_time.service' for detail.

Но так как авторизоваться я не могу, то и посмотреть systemctl status altlinux-first_time.service тоже не могу.
В /var/log/journal/ пусто. Так что, посмотреть что-то еще невозможно.
Если есть варианты, куда еще заглянуть и что посмотреть, то готов это сделать.

Оффлайн Антон Мидюков

  • alt linux team
  • ***
  • Сообщений: 4 108
  • antohami@
Да, это сборки с прошлой недели. Альфы остались:
http://nightly.altlinux.org/sisyphus-armh/alpha/
http://nightly.altlinux.org/sisyphus-aarch64/alpha/

Попробуйте удалить /etc/X11/xorg.conf.d/99-modesetting-noglamor.conf

Это, пожалуй, самое заметное изменение. А в остальном, обновилось ядро да systemd.

Завтра будут выложены новые сборки, предыдущие смотреть здесь:
http://nightly.altlinux.org/sisyphus-armh/snapshots/
http://nightly.altlinux.org/sisyphus-aarch64/snapshots/

Оффлайн Merblud

  • Давно тут
  • **
  • Сообщений: 404
Попробуйте удалить /etc/X11/xorg.conf.d/99-modesetting-noglamor.conf

Вот это вообще в данном случае имеет какое-либо значение, так как, насколько я понял, до старта X-ов вообще дело почему-то не доходит. Иначе X-ы хоть как-то ругались в свой лог. А его вообще нету в /var/log. Если конечно он куда-нибудь не перенаправляется.

Оффлайн Антон Мидюков

  • alt linux team
  • ***
  • Сообщений: 4 108
  • antohami@
Попробуйте удалить /etc/X11/xorg.conf.d/99-modesetting-noglamor.conf

Вот это вообще в данном случае имеет какое-либо значение, так как, насколько я понял, до старта X-ов вообще дело почему-то не доходит. Иначе X-ы хоть как-то ругались в свой лог. А его вообще нету в /var/log. Если конечно он куда-нибудь не перенаправляется.

И всё же попробуйте. И убедитесь, что всё нормально записалось.

Можно также исключить ядро, скопировав ядро, модули и образ initrd, а также extlinux.conf из альфы.