Автор Тема: Два Local link адреса на одном сетевом интерфейсе  (Прочитано 243 раз)

Оффлайн psaq

  • Начинающий
  • *
  • Сообщений: 5
Доброго времени суток!
У меня возникла следующая ситуация. Перенёс систему (Альт Рабочая станция К 10.0) с одного компа на другой. После этого начались проблемы с Avahi на исходной системе.
После проведения небольшого исследования выяснил, что на машине с перенесённой системой сетевой интерфейс имеет два Scope:Link адреса, один из которых с исходной системы.
С таким я сталкиваюсь в первые. В других пользуемых мною ранее дистрибутивах (openSUSE, например) такого не наблюдалась. Подскажите, пожалуйста, как можно удалить лишний Scope:Link адрес (совсем!).
« Последнее редактирование: 17.07.2022 16:34:47 от psaq »

Онлайн kessys

  • Давно тут
  • **
  • Сообщений: 232
Тема довольно актуальная. В виндовс такие фишки прячутся, но не мешают, а тут ещё не дошёл до этого этапа тестирования.
Пробовали ли менять IP-адрес или в роутере чистить данный ip от этого пк?

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 31 503
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
А что там у вас за сообщение о конфликте hostname ?

Оффлайн psaq

  • Начинающий
  • *
  • Сообщений: 5
Тема довольно актуальная. В виндовс такие фишки прячутся, но не мешают, а тут ещё не дошёл до этого этапа тестирования.
Пробовали ли менять IP-адрес или в роутере чистить данный ip от этого пк?
Пробовал чистить ipv6 адреса для данного интерфейса и удалять конкретный адрес, но не особо помогает.
Насчёт роутера я как-то не подумал, с другим дистром данной проблемы не наблюдалось...

Оффлайн psaq

  • Начинающий
  • *
  • Сообщений: 5
А что там у вас за сообщение о конфликте hostname ?
А это из-за того что у двух машин в сети по факту один ip6 адрес Avahi начинает выносить мозг! В его настройках пробовал отключать ipv6 (use-ipv6=no), но безрезультатно.

Оффлайн psaq

  • Начинающий
  • *
  • Сообщений: 5
Кстати, проблема только с Wlan! На проводном интерфейсе ничего подобного не наблюдаю...

Оффлайн psaq

  • Начинающий
  • *
  • Сообщений: 5
Спасибо, всем кто откликнулся! Проблема, по ходу, была в NetworkManager. Почему-то именно он допускает это безобразие с IPv6-адресами. Поле удаления wifi-соединения и создания его заново у интерфейса появился один новый local link адрес. У меня не слишком большие знания касаемые IPv6, но разве local link не генерируется из MAC адреса устройства? И почему их стало два (со старого компа и новый) тоже пока загадка!. Надеюсь, что кто-нибудь сможет просветить в данном вопросе...