Автор Тема: Установка webmin  (Прочитано 237 раз)

Оффлайн chim

  • Начинающий
  • *
  • Сообщений: 4
Установка webmin
« : 01.06.2024 10:58:40 »
Alt linux версии 10.2, пытаюсь установить скачанный пакет webmin:
rpm -ivh webmin-2.111-1.noarch.rpm
ошибка: Неудовлетворенные зависимости:
        perl(Data::Dumper) нужен для webmin-2.111-1.noarch
        perl(Digest::MD5) нужен для webmin-2.111-1.noarch
        perl(Digest::SHA) нужен для webmin-2.111-1.noarch
        perl(File::Basename) нужен для webmin-2.111-1.noarch
        perl(File::Path) нужен для webmin-2.111-1.noarch
        perl(Net::SSLeay) нужен для webmin-2.111-1.noarch
        perl(Time::Local) нужен для webmin-2.111-1.noarch
        perl(lib) нужен для webmin-2.111-1.noarch
        perl(open) нужен для webmin-2.111-1.noarch
Perl установлен:
perl -v

This is perl 5, version 34, subversion 0 (v5.34.0 (79a7b254d85a10b65126ad99bf10e70480569d68)) built for x86_64-linux-thread-multi
Пытался так же ставить пакеты которые похожи по имени с требуемыми(хотя как я понимаю это классы/модули):
apt-get install perl-Data-Dumper-Concise perl-Digest-Perl-MD5 perl-Digest-SHA perl-File-PathInfo perl-Net-SSLeay perl-DateTime-Locale perl-lib-relative perl-Browser-OpenНо ошибка всё та же. Как исправить?

Оффлайн Александр Ерещенко

  • Завсегдатай
  • *
  • Сообщений: 1 189
Re: Установка webmin
« Ответ #1 : 01.06.2024 11:06:18 »
Если действительно так хочется поставить webmin, то попробуйте установку через apt-get, который попытается сам установить зависимости. А ещё лучше, сначала попробовать перепаковать этот сторонний rpm через epm repack , а потом уже устанавливать через apt-get

Оффлайн chim

  • Начинающий
  • *
  • Сообщений: 4
Re: Установка webmin
« Ответ #2 : 01.06.2024 11:14:35 »
Как через apt-get если его нет в репозитории. И можно хоть какой ни будь пример про перепаковку и установку через epm repack?
epmi webmin-2.111-1.noarch.rpm
WARNING: %%% You are trying install package webmin-2.111-1.noarch.rpm from third-party software source. Use it at your own risk. %%%
WARNING: Scripts are DISABLED for package webmin-2.111-1.noarch.rpm from outside vendor 'Jamie Cameron'. Use --scripts if you need run scripts from such packages.
 # rpm -Uvh --noscripts webmin-2.111-1.noarch.rpm
ошибка: Неудовлетворенные зависимости:
        perl(Data::Dumper) нужен для webmin-2.111-1.noarch
        perl(Digest::MD5) нужен для webmin-2.111-1.noarch
        perl(Digest::SHA) нужен для webmin-2.111-1.noarch
        perl(File::Basename) нужен для webmin-2.111-1.noarch
        perl(File::Path) нужен для webmin-2.111-1.noarch
        perl(Net::SSLeay) нужен для webmin-2.111-1.noarch
        perl(Time::Local) нужен для webmin-2.111-1.noarch
        perl(lib) нужен для webmin-2.111-1.noarch
        perl(open) нужен для webmin-2.111-1.noarch

Workaround for install packages via apt with --noscripts (see https://bugzilla.altlinux.org/44670)
Firstly install package requrements …
 # epm req --short webmin-2.111-1.noarch.rpm
 # rpm -q --requires -p webmin-2.111-1.noarch.rpm
 # epm install --skip-installed /usr/bin/perl /usr/bin/perl gzip openssl perl(Data::Dumper) perl(Digest::MD5) perl(Digest::SHA) perl(File::Basename) perl(File::Path) perl(Net::SSLeay) perl(Time::Local) perl(lib) perl(open) tar unzip
 # apt-get -o APT::Install::VirtualVersion=true -o APT::Install::Virtual=true install perl(Data::Dumper) perl(Digest::MD5) perl(Digest::SHA) perl(File::Basename) perl(File::Path) perl(Net::SSLeay) perl(Time::Local) perl(lib) perl(open)
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
E: Невозможно найти пакет perl(Data::Dumper)
попробовал одну из предложенных команд:
rpm -q --requires -p webmin-2.111-1.noarch.rpm
/bin/sh
/bin/sh
/bin/sh
/bin/sh
/bin/sh
/bin/sh
/usr/bin/perl
/usr/bin/perl
gzip
openssl
perl(Data::Dumper)
perl(Digest::MD5)
perl(Digest::SHA)
perl(File::Basename)
perl(File::Path)
perl(Net::SSLeay)
perl(Time::Local)
perl(lib)
perl(open)
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1
tar
unzip
« Последнее редактирование: 01.06.2024 11:19:17 от chim »