Автор Тема: Ноутбук с Симпли 10, звука нет ни в динамиках ноутбука, ни в наушниках сразу после установки  (Прочитано 8014 раз)

Оффлайн Pavel P

  • Начинающий
  • *
  • Сообщений: 47
    • Email
Ставил Манжаро с ядром 5.18.5 - звук появился только в наушниках

Оффлайн Aleksand

  • Давно тут
  • **
  • Сообщений: 97
Ставил Манжаро с ядром 5.18.5 - звук появился только в наушниках
Ну это уже хорошо, что хоть как то появился.
В alsamixer смотрели? Что там отображается?
Что показывают?:
lspci |grep -i audio
cat /proc/asound/cards
aplay -l

Оффлайн Pavel P

  • Начинающий
  • *
  • Сообщений: 47
    • Email
Выкладываю, то, что показывает Симпли
~]$ lspci |grep -i audio
00:0e.0 Multimedia audio controller: Intel Corporation Celeron/Pentium Silver Processor High Definition Audio (rev 06)
[pavel@localhost ~]$     
~]$ cat /proc/asound/cards
--- no soundcards ---
~]$ aplay -l
aplay: device_list:274: no soundcards found
Что покажет Манжаро - выложу позже, надо установить, обновить ядро

Оффлайн Pavel P

  • Начинающий
  • *
  • Сообщений: 47
    • Email
Манжаро 5.15 - звука нет
Спойлер
[pavel@pavel-u1520hd ~]$ lspci |grep -i audio
00:0e.0 Multimedia audio controller: Intel Corporation Celeron/Pentium Silver Processor High Definition Audio (rev 06)
[pavel@pavel-u1520hd ~]$ cat /proc/asound/cards
 0 [sofhdadsp      ]: sof-hda-dsp - sof-hda-dsp
                      Haier-U1520HD-Defaultstring
[pavel@pavel-u1520hd ~]$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: sofhdadsp [sof-hda-dsp], device 1: HDMI1 (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: sofhdadsp [sof-hda-dsp], device 2: HDMI2 (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: sofhdadsp [sof-hda-dsp], device 3: HDMI3 (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
[pavel@pavel-u1520hd ~]$

Оффлайн Pavel P

  • Начинающий
  • *
  • Сообщений: 47
    • Email
Манжаро 5.18.5 - появился звук в наушниках
Спойлер
avel@pavel-u1520hd ~]$ lspci |grep -i audio
00:0e.0 Multimedia audio controller: Intel Corporation Celeron/Pentium Silver Processor High Definition Audio (rev 06)
[pavel@pavel-u1520hd ~]$ cat /proc/asound/cards
 0 [sofessx8336    ]: sof-essx8336 - sof-essx8336
                      Haier-U1520HD-Defaultstring
[pavel@pavel-u1520hd ~]$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: sofessx8336 [sof-essx8336], device 0: ES8336 (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: sofessx8336 [sof-essx8336], device 5: HDMI 1 (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: sofessx8336 [sof-essx8336], device 6: HDMI 2 (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: sofessx8336 [sof-essx8336], device 7: HDMI 3 (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
[pavel@pavel-u1520hd ~]$

Оффлайн Aleksand

  • Давно тут
  • **
  • Сообщений: 97
cat /proc/asound/cards: sof-essx8336
Устройство появилось.
Что теперь показывает в консоли: alsamixer?
Двигали там ползунки?

Я вам ещё в личку написал сообщение по этому вопросу, прочитайте.

Оффлайн Aleksand

  • Давно тут
  • **
  • Сообщений: 97
Pavel P, у нас с вами ноутбуки разные, но вот эта фигня essx8336 одинаковая.
Так вот, сейчас загрузил лайв юсб Альт Рабочая станция К 10.0, с ядром 5.15.34-un-def-alt1 и в нем звук есть.
До этого Альт образование 10 пробовал, звука не было.
И если у вас появляется звук хотя бы в чем то, то тут уже наверное настройки или конфиги нужно ковырять.

У меня звук с микрофонов очень плохой. Попробовать винду накатить, как в ней микрофоны будут работать?
Хотя бы узнать, драйвер виноват или микрофоны такие плохие.

dango_

  • Гость
Pavel P, у нас с вами ноутбуки разные, но вот эта фигня essx8336 одинаковая.
[pavel@pavel-u1520hd ~]$ cat /proc/asound/cards
 0 [sofessx8336    ]: sof-essx8336 - sof-essx8336
                      Haier-U1520HD-Defaultstring
Возможно, фигня не совсем одинаковая. Может от производителя зависит.
Манжаро 5.18.5 - появился звук в наушниках
Если будут бэкпорты новых драйверов в ядра 5.15.*/5.17.*  может будет счастье. Или ждать 5.18.
Можно конечно попытаться ускорить процесс и попросить, начав отсюда https://www.altlinux.org/BugTracking.

Оффлайн Pavel P

  • Начинающий
  • *
  • Сообщений: 47
    • Email
Пробовал вчера Рабочую станцию К 10 - звука нет. Возможно для моего ноутбука в принципе нет драйверов под линукс.

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 935
    • Домашняя страница
    • Email
apt-repo set sisyphus
apt-get update
update-kernel -t un-def
apt-repo set p10
Андрей Черепанов (cas@)

Оффлайн Pavel P

  • Начинающий
  • *
  • Сообщений: 47
    • Email

Оффлайн ARHAN

  • Завсегдатай
  • *
  • Сообщений: 1 090
  • kde-p10,mate-p10 xfce-p10
Цитировать
Ставил Манжаро с ядром 5.18.5 - звук появился только в наушниках
Kак то странно,в наушинках есть,а в динамиках нет,может динамики дохлые,или в разьеме контакта нет который выход унч с  динамиками соединяет.
А до альта что там стояло, звук был в динамиках?
Век живи, век учись.

Оффлайн Pavel P

  • Начинающий
  • *
  • Сообщений: 47
    • Email
А до альта что там стояло,
Ничего, новый, пустой ноутбук.
Динамики тоже давали о себе знать, иногда издавая щелчки.
« Последнее редактирование: 25.06.2022 17:29:50 от Pavel P »

Оффлайн ARHAN

  • Завсегдатай
  • *
  • Сообщений: 1 090
  • kde-p10,mate-p10 xfce-p10
А на альте наушники пробовали подключать? По идее наушники с того же усилителя звук получают что и динамики,переключение в разьеме происходит. Там контакты наушников просто цепь динамиков размыкают. Хотя могли в обход сделать.В любом случае или сигнал переключается прямо на гнезде или берется с этого разьема для коммутации  унч  динамиков, если они работаю от разных унч.
Микшер поставить еще попробовать какой нибудь,может там где муте включено или громкость убавлена,я обычно на алса перехожу с пульсе и карта появляется и куча регулировок,начинаешь все крутить,иногда они не совсем сопадают с регуляторм громкости что у вас на панели и требуется еще что нибудь прибавить или включить через микшер программно. У меня kde сейчас,у них побольше настроек,чем там mate или xfce,
обычно ставлю полный дистр,на лайф не всегда звук удачно стает,приходиться что нибудь доставлять или где то включать.

« Последнее редактирование: 25.06.2022 18:40:47 от ARHAN »
Век живи, век учись.

Оффлайн Pavel P

  • Начинающий
  • *
  • Сообщений: 47
    • Email
apt-repo set sisyphus
apt-get update
update-kernel -t un-def
apt-repo set p10
Cпасибо, ядро 5.18.6 установилось, но результата нет, значит дело не в ядре. Не хватает чего-то другого.
я обычно на алса перехожу с пульсе
Вот это еще не пробовал, попробую, знать бы еще как.