Автор Тема: Всего-лишь вопрос по установке проприетарных драйверов NVIDIA  (Прочитано 3385 раз)

Оффлайн PIF

  • Давно тут
  • **
  • Сообщений: 46
Данный вопрос не призван решать какую либо проблему, а носит целью понять глубины так сказать. Итак...
Мной был поставлен  alt-p8-mate-20190312-x86_64

Впервые пришлось столкнутся с установкой проприетарных драйверов NVIDIA на компьютер под управлением linux (мера вынужденная т.к Raven Ridge как я понял в свободно распространяемый альт на настоящий момент так и не завезли... но не суть) и в руках моих оказалась затычка по имени Ge Force 710. Сообственно решено ставим это (под это подразумевается Ge Force 710). Из коробки завелись nouveau и в принципе всё бы нормально но 60 Гц на экране (1920х1080), заставили попробывать, драйвер nvidia.
Воспользовался мурзилкой:
https://www.altlinux.org/%D0%A3%D1%81%D1%82%D0%B0%D0%BD%D0%BE%D0%B2%D0%BA%D0%B0_%D0%BF%D1%80%D0%BE%D0%BF%D1%80%D0%B8%D0%B5%D1%82%D0%B0%D1%80%D0%BD%D1%8B%D1%85_%D0%B4%D1%80%D0%B0%D0%B9%D0%B2%D0%B5%D1%80%D0%BE%D0%B2_NVIDIA_%D0%B8_ATI

Поставилось нормально, правда результата я не получил в части изменения частоты обновления изображения на экране зато наименование монитора появилось вместо неизвестный.  И дело либо в мониторе, либо "никакой" видюшке (хотя реклама на монитор обещает 75 Гц) чему-то из них возможно не позубам 1920х1080_75Hz ну это мы ещё попробуем узнать.

Ну и теперь сам вопрос: при использовании скрипта:
# nvidia-install-driver
происходит проход про репо и тут предлагается выкачать всё что начинается с i586-nvidia_glx_304.137.32bit, i586-nvidia_glx_340.107.32bit .... nvidia_glx_410.104
Я наивно попытался ораничится последним и не качать всю эту вереницу пакетов как мне показалось тянущихся со времён юрского периода..., но не тут-то было, перезагрузка показала висюна (его мы благополучно убрали в последствии... опять же не суть).
Вообщем получается, что я ставлю последнюю версию пакета, а она каким-то образом зависит от всего набора в том числе 32 бит пакетов? Причина такой реализации, вот что интересно и есть ли способ обойти такое поведение.

Оффлайн zerg

  • ненужная строка
  • alt linux team
  • ***
  • Сообщений: 2 141
  • ненужная строка
есть ли способ обойти такое поведение.
apt-get remove i586-glibc-core
Убрать этот мусор можно переключателем: Не показывать подписи других пользователей.

Оффлайн PIF

  • Давно тут
  • **
  • Сообщений: 46
есть ли способ обойти такое поведение.
apt-get remove i586-glibc-core

Я так полагаю позволит избавится от установки i586-* пакетов.

А вот 64 бит подтянутся все, начиная с nvidia_glx_304.137 и до последнего. Почему сообственно так? Когда качаешь с сайта nvidia дрова получаешь run размером за 100 МБ и судя по описанию поддержку кучи поколений видео карт. В альте реализация видимо другая, потому как каждый пакет размером 20 МБ (я поначалу даже удивился, думаю славно оптимизировали выпилив гуи и сетинги нативные), но оказывается надо качать всё, более того есть чувство, что при выходе новых версий придётся качать всё больше и больше заполняя диск возможно не самыми актуальными данными...

Оффлайн yaleks

  • Мастер
  • ***
  • Сообщений: 5 628
при выходе новых версий придётся качать всё больше и больше заполняя диск возможно не самыми актуальными данными...
для этого есть nvidia-clean-drivers

Оффлайн zerg

  • ненужная строка
  • alt linux team
  • ***
  • Сообщений: 2 141
  • ненужная строка
А вот 64 бит подтянутся все, начиная с nvidia_glx_304.137 и до последнего. Почему сообственно так?
Потому, что заранее не известно, какие нужны.

Когда качаешь с сайта nvidia дрова получаешь run размером за 100 МБ
Вы заранее выбираете версию.

есть чувство, что при выходе новых версий придётся качать всё больше и больше заполняя диск возможно не самыми актуальными данными...
nvidia-clean-driver поможет.
Убрать этот мусор можно переключателем: Не показывать подписи других пользователей.

Оффлайн PIF

  • Давно тут
  • **
  • Сообщений: 46
Воспользовался nvidia-clean-driver
при выполнении скрипта был найден 1 пакет для удаления - это nvidia_glx_410.93 остальные остались.

На основе моих догадок (возможно и неверных) могу предположить что установленые пакеты содержат хотя бы частично отличающийся набор поддерживаемых продуктов.

Т.к. используемая мной GeForce GT 710 есть в нативных nvidia драйверах (если смотреть в Supported products) версий 410.104 и в 390.116 и в 340.107 и все они остаются установленными в системе, что в моём случае (для данной видеокарты) избыточно.

glxinfo | grep NVIDIA
показывает что используются драйвера версии 410.104
« Последнее редактирование: 17.04.2019 09:46:20 от PIF »

Оффлайн zerg

  • ненужная строка
  • alt linux team
  • ***
  • Сообщений: 2 141
  • ненужная строка
могу предположить что установленые пакеты содержат хотя бы частично отличающийся набор поддерживаемых продуктов.
Именно так. При этом для разных ядер может быть разный комплект nvidia_glx-ов.

P.S.
remove-old-kernels
nvidia-clean-driver
Убрать этот мусор можно переключателем: Не показывать подписи других пользователей.