Автор Тема: Установлено несколько версий пакета "gpg-pubkey".[РЕШЕНО]  (Прочитано 2647 раз)

Оффлайн Suveren

  • Начинающий
  • *
  • Сообщений: 1
Установил Opera rpm с официального сайта. После этого действия apt-get и synaptic ругаются на наличие нескольких версий gpg-pubkey.
comp-athlon-x4-6c938d ~ # apt-get update
Получено: 1 http://browser-rpm.sputnik.ru x86_64 release [426B]
Получено: 2 http://mirror.yandex.ru p9/branch/x86_64 release [1743B]
Получено: 3 http://mirror.yandex.ru p9/branch/x86_64-i586 release [1175B]
Получено: 4 http://mirror.yandex.ru p9/branch/noarch release [1327B]
Получено 4671B за 0s (10,6kB/s).
Найдено http://mirror.yandex.ru p9/branch/x86_64/classic pkglist
Найдено http://mirror.yandex.ru p9/branch/x86_64/classic release
Найдено http://mirror.yandex.ru p9/branch/x86_64-i586/classic pkglist
Найдено http://mirror.yandex.ru p9/branch/x86_64-i586/classic release
Найдено http://mirror.yandex.ru p9/branch/noarch/classic pkglist
Найдено http://mirror.yandex.ru p9/branch/noarch/classic release
Получено: 1 http://browser-rpm.sputnik.ru x86_64/classic pkglist [984B]
Получено: 2 http://browser-rpm.sputnik.ru x86_64/classic release [126B]
Получено 1110B за 0s (13,8kB/s).
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
W: В Вашей системе установлено несколько версий пакета "gpg-pubkey".

Этот пакет не может быть обновлён обычным путём до тех пор, пока Вы не
оставите только одну его версию. Чтобы оставить установленными несколько версий,
и не п
W: Возможно, Вам потребуется запустить `apt-get update' для исправления.
Вывод dist-upgrade чист:
comp-athlon-x4-6c938d ~ # apt-get dist-upgrade
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Подсчет обновлений... Завершено
0 будет обновлено, 0 новых установлено, 0 пакетов будет удалено и 0 не будет обновлено.
Synaptic видит ошибку, но удалить не может.
Пытаюсь удалить вручную:
comp-athlon-x4-6c938d ~ # apt-get remove gpg-pubkey
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Выбрано gpg-pubkey#abdc4346-5d79ff84@1568276356 для 'gpg-pubkey'
Следующие пакеты будут УДАЛЕНЫ:
  gpg-pubkey#abdc4346-5d79ff84@1568276356
0 будет обновлено, 0 новых установлено, 1 пакетов будет удалено и 0 не будет обновлено.
Необходимо получить 0B архивов.
После распаковки потребуется дополнительно 0B дискового пространства.
Продолжить? [Y/n] y
Ошибка сегментирования
Что делать?
Оказалось, можно было просто удалить пакеты вручную через rpm
rpm -e gpg-pubkey-abdc4346-5d79ff84@1568276356Возможно, я зря это сделал, но apt-get теперь молчит.
« Последнее редактирование: 30.10.2019 16:12:48 от Suveren »

Онлайн Gennadij

  • Завсегдатай
  • *
  • Сообщений: 15
Несколько месяцев назад была аналогичная проблема, после эксперементов с браузерами в системе было установлено 3 разных gpg-pubkey.  Два из них так же удалил вручную с помощью rpm -e. Больше проблем с этим не замечено, все работает стабильно.

Оффлайн Biker

  • в Linux начинающий "чайник"
  • Давно тут
  • **
  • Сообщений: 235
а если удалить gpg-pubkey, то браузеры смогут без них работать или наличие 3 различных ключей не вредят системе и друг другу?

Оффлайн Koi

  • Мастер
  • ***
  • Сообщений: 1 876
  • валар дохаэрис
    • Канал на youtube
Kernel Manager - кнопка очистка.  ;-D