Автор Тема: Обновление пакетов: gst-plugins-base ошибка  (Прочитано 257 раз)

Оффлайн xterro

  • Давно тут
  • **
  • Сообщений: 204
    • Email
Доброго времени суток,  в последнее время заметил такое сообщение при обновлении пакетов на машине

Preparing...                 ############################################################################################# [100%]
file /usr/lib64/gstreamer-1.0/libgstrawparse.so from install of gst-plugins-base1.0-1.12.3-alt0.M80P.1 conflicts with file from package gst-plugins-bad1.0-1.10.5-alt0.M80P.1
E: Ошибка во время исполнения транзакции

Такое и на "рабочей станции" и на "симпли"  8-версии. Хотя раньше пакеты обновлялись без проблем,
что случилось?

Подключены репы:

[altlinux@localhost apt]$ cat sources.list
rpm [p8] ftp://ftp.altlinux.org/pub/distributions/ALTLinux p8/branch/x86_64 classic
rpm [p8] ftp://ftp.altlinux.org/pub/distributions/ALTLinux p8/branch/x86_64-i586 classic
rpm [p8] ftp://ftp.altlinux.org/pub/distributions/ALTLinux p8/branch/noarch classic

« Последнее редактирование: 16.10.2017 19:38:12 от xterro »

Оффлайн asy

  • alt linux team
  • ***
  • Сообщений: 5 995
  • Sunny 273 RUS crew
Типичная ошибка в spec-файле при сборке - недопроставленный "Conflicts". Повесте баг в багзилле на gst-plugins соответствующий. Так бывает иногда.

Собственно, вот про похожую проблему: https://forum.altlinux.org/index.php?topic=40184.0. Можете так же проверить возможность установки пакета с одновременным удалением, но внимательно смотрите на то, что будет написано в "Следующие пакеты будут УДАЛЕНЫ", а то там человек чуть систему не вынес - спасла следующая ошибка.
« Последнее редактирование: 16.10.2017 20:17:00 от asy »

Оффлайн xterro

  • Давно тут
  • **
  • Сообщений: 204
    • Email
Спасибо, повешал багу #34020  :-)