Автор Тема: Занятный подгон от 1Совцев  (Прочитано 3581 раз)

Оффлайн prof-alex

  • Давно тут
  • **
  • Сообщений: 33
На новой версии платформы 1С изменились зависимости у 32-битных сборок. Внезапно, они стали требовать 64-битное окружение.

apt-get install *.rpm
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Выбрано 1C_Enterprise83-common для '1C_Enterprise83-common-8.3.14-1565.i386.rpm'
Выбрано 1C_Enterprise83-common-nls для '1C_Enterprise83-common-nls-8.3.14-1565.i386.rpm'
Выбрано 1C_Enterprise83-crs для '1C_Enterprise83-crs-8.3.14-1565.i386.rpm'
Выбрано 1C_Enterprise83-server для '1C_Enterprise83-server-8.3.14-1565.i386.rpm'
Выбрано 1C_Enterprise83-server-nls для '1C_Enterprise83-server-nls-8.3.14-1565.i386.rpm'
Выбрано 1C_Enterprise83-ws для '1C_Enterprise83-ws-8.3.14-1565.i386.rpm'
Выбрано 1C_Enterprise83-ws-nls для '1C_Enterprise83-ws-nls-8.3.14-1565.i386.rpm'
Некоторые пакеты установить невозможно. Это может означать, что Вы
потребовали невозможного, либо пользуетесь нестабильным репозиторием.
Часть необходимых пакетов либо ещё не создана, либо была удалена
из каталога 'Входящие'.
Эти сведения могут помочь найти выход из ситуации:

Следующие пакеты имеют неудовлетворенные зависимости:
  1C_Enterprise83-server: Требует: ld-linux-x86-64.so.2()(64bit) но пакет не может быть установлен
                          Требует: ld-linux-x86-64.so.2(GLIBC_2.3)(64bit) но пакет не может быть установлен
                          Требует: libc.so.6()(64bit) но пакет не может быть установлен
                          Требует: libc.so.6(GLIBC_2.2.5)(64bit) но пакет не может быть установлен
                          Требует: libc.so.6(GLIBC_2.3)(64bit) но пакет не может быть установлен
                          Требует: libc.so.6(GLIBC_2.3.2)(64bit) но пакет не может быть установлен
                          Требует: libc.so.6(GLIBC_2.4)(64bit) но пакет не может быть установлен
                          Требует: libc.so.6(GLIBC_2.6)(64bit) но пакет не может быть установлен
                          Требует: libc.so.6(GLIBC_2.7)(64bit) но пакет не может быть установлен
                          Требует: libc.so.6(GLIBC_2.8)(64bit) но пакет не может быть установлен
                          Требует: libc.so.6(GLIBC_2.9)(64bit) но пакет не может быть установлен
                          Требует: libdl.so.2()(64bit) но пакет не может быть установлен
                          Требует: libdl.so.2(GLIBC_2.2.5)(64bit) но пакет не может быть установлен
                          Требует: libm.so.6()(64bit) но пакет не может быть установлен
                          Требует: libm.so.6(GLIBC_2.2.5)(64bit) но пакет не может быть установлен
                          Требует: libnsl.so.1()(64bit) но пакет не может быть установлен
                          Требует: libpthread.so.0()(64bit) но пакет не может быть установлен
                          Требует: libpthread.so.0(GLIBC_2.2.5)(64bit) но пакет не может быть установлен
                          Требует: libpthread.so.0(GLIBC_2.3.2)(64bit) но пакет не может быть установлен
                          Требует: libpthread.so.0(GLIBC_2.3.3)(64bit) но пакет не может быть установлен
                          Требует: librt.so.1()(64bit) но пакет не может быть установлен
                          Требует: libz.so.1()(64bit) но пакет не может быть установлен
                          Требует: libz.so.1(ZLIB_1.2.0)(64bit) но пакет не может быть установлен
E: Извините, `битые' пакеты

Что характерно, сборки deb этой "особенности" не имеют.

Использующие серверы 1С под линуксом, будьте бдительны!

Оффлайн sb

  • Модератор глобальный
  • *****
  • Сообщений: 8 712
  • Кто ищет, тот найдёт.
Re: Занятный подгон от 1Совцев
« Ответ #1 : 12.02.2019 08:24:59 »
В новости, однозначно!

Оффлайн yaleks

  • Мастер
  • ***
  • Сообщений: 5 796
Re: Занятный подгон от 1Совцев
« Ответ #2 : 12.02.2019 12:58:38 »
А если через epm перепаковать rpm'ки?

Оффлайн freddyb

  • Давно тут
  • **
  • Сообщений: 39
Re: Занятный подгон от 1Совцев
« Ответ #3 : 22.02.2019 11:21:27 »
Это значит не получится поставить 1С-сервер_х32 на Линукс_х32? Только на Линукс_х64?