Автор Тема: pip python  (Прочитано 3957 раз)

Оффлайн him

  • Давно тут
  • **
  • Сообщений: 904
pip python
« : 27.02.2019 22:18:26 »
# pip install --upgrade pip
Collecting pip
  Downloading https://files.pythonhosted.org/packages/d8/f3/413bab4ff08e1fc4828dfc59996d721917df8e8583ea85385d51125dceff/pip-19.0.3-py2.py3-none-any.whl (1.4MB)
    100% |████████████████████████████████| 1.4MB 5.8MB/s
rtlsdr-scanner 1.3.0 requires visvis, which is not installed.
cheetah 2.4.4 requires Markdown>=2.0.1, which is not installed.
matplotlib 2.0.0.post0 requires pytz, which is not installed.
matplotlib 2.0.0.post0 requires subprocess32, which is not installed.
rtlsdr-scanner 1.3.0 has requirement matplotlib<2, but you'll have matplotlib 2.0.0.post0 which is incompatible.
Installing collected packages: pip
  Found existing installation: pip 10.0.1
    Uninstalling pip-10.0.1:
      Successfully uninstalled pip-10.0.1
Successfully installed pip-19.0.3

Надо что то до обновить ?

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 18 581
    • Домашняя страница
    • Email
Re: pip python
« Ответ #1 : 28.02.2019 05:55:14 »
Нет, откатить matplotlib.
Андрей Черепанов (cas@)

Оффлайн Олег Андрианов

  • Начинающий
  • *
  • Сообщений: 3
Re: pip python
« Ответ #2 : 22.04.2021 13:40:05 »
Выполняю:
apt-get update
apt-get install python-pip

E: Невозможно найти пакет pip
Нужно  для создания исполняемого файла exe из кода на питоне.

Оффлайн Koi

  • Мастер
  • ***
  • Сообщений: 1 943
  • валар дохаэрис
    • Канал на youtube
Re: pip python
« Ответ #3 : 22.04.2021 18:09:24 »
$ apt-cache search python | grep -w pip
python-modules-ensurepip - Bootstrapping the pip installer
python-module-pip - The PyPA recommended tool for installing Python packages
python-module-pip-docs - Documentation for pip
python3-module-pip - The PyPA recommended tool for installing Python packages
python3-module-pip-docs - Documentation for pip3
Пользуйтесь synaptic это удобнее, а фильтровать все же в терминале лучше.