Автор Тема: Не устанавливается последняя версия skype на p9  (Прочитано 9376 раз)

Оффлайн monotribe

  • Начинающий
  • *
  • Сообщений: 4
    • Email
Здравствуйте!
При попытке на дистрибутиве altlinux p9 starterkit от 12 марта установить skype последней версии, который можно скачать с официального сайта https://go.skype.com/skypeforlinux-64.rpm, появляется сообщение о том, что требуется пакет libatomic или libatomic1, хотя libatomic1-8.4.1 есть в системе.
apt-get install /home/username/Загрузки/skypeforlinux-64.rpm
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Выбрано skypeforlinux для '/home/username/Загрузки/skypeforlinux-64.rpm'
Некоторые пакеты установить невозможно. Это может означать, что Вы
потребовали невозможного, либо пользуетесь нестабильным репозиторием.
Часть необходимых пакетов либо ещё не создана, либо была удалена
из каталога 'Входящие'.

Так как для выполнения Вашего запроса достаточно одной операции, то
скорее всего этот пакет просто невозможно установить. Сообщите, пожалуйста,
об этом как о найденной ошибке в пакете.
Эти сведения могут помочь найти выход из ситуации:

Следующие пакеты имеют неудовлетворенные зависимости:
  skypeforlinux: Требует: (libatomic or libatomic1) но пакет не может быть установлен
E: Извините, `битые' пакеты
Подскажите, пожалуйста, имеется ли какая-то возможность установить последнюю версию skype на altlinux p9? В данный момент стабильно работает только старая версия skypeforlinux_8.68.0.100-1.x86_64.rpm от 2020 года.
« Последнее редактирование: 25.05.2021 09:38:15 от monotribe »

Оффлайн gosts 87

  • Давно тут
  • **
  • Сообщений: 997
  • Дмитрий/Dmitry/德米特里/दिमित्री
Ага. Выдало то-же самое, только на инглише:
Reading Package Lists...
Building Dependency Tree...
Selecting skypeforlinux for '/home/using/Загрузки/skypeforlinux-64.rpm'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following packages have unmet dependencies:
  skypeforlinux: Depends: (libatomic or libatomic1) but it is not installable
E: Broken packages
Скорее всего требуются эти пакеты определённых версий, но их в репозиториях нет.

Оффлайн gosts 87

  • Давно тут
  • **
  • Сообщений: 997
  • Дмитрий/Dmitry/德米特里/दिमित्री
Можно попробовать установить SNAP-пакет.

Оффлайн yaleks

  • Мастер
  • ***
  • Сообщений: 5 760
eepm install --repack /home/username/Загрузки/skypeforlinux-64.rpmне поможет?

Оффлайн gosts 87

  • Давно тут
  • **
  • Сообщений: 997
  • Дмитрий/Dmitry/德米特里/दिमित्री
eepm install --repack /home/username/Загрузки/skypeforlinux-64.rpmне поможет?
Вот, я попробовал:
Спойлер
# eepm install --repack /home/using/Загрузки/skypeforlinux-64.rpm
Installing appropriate package for fakeroot command...
Running command for update remote package repository database
 # apt-get update
Получено: 1 http://mirror.yandex.ru p9/branch/x86_64 release [1954B]
Получено: 2 http://browser-rpm.sputnik.ru x86_64 release [426B] 
Получено: 3 http://mirror.yandex.ru p9/branch/x86_64-i586 release [1175B]
Получено: 4 http://mirror.yandex.ru p9/branch/noarch release [1545B]
Получено 5100B за 0s (13,2kB/s).
Найдено http://browser-rpm.sputnik.ru x86_64/classic pkglist
Найдено http://browser-rpm.sputnik.ru x86_64/classic release
Найдено http://mirror.yandex.ru p9/branch/x86_64/classic pkglist
Найдено http://mirror.yandex.ru p9/branch/x86_64/classic release
Найдено http://mirror.yandex.ru p9/branch/x86_64-i586/classic pkglist
Найдено http://mirror.yandex.ru p9/branch/x86_64-i586/classic release
Найдено http://mirror.yandex.ru p9/branch/noarch/classic pkglist
Найдено http://mirror.yandex.ru p9/branch/noarch/classic release
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
 # apt-get -y --force-yes -o APT::Install::VirtualVersion=true -o APT::Install::Virtual=true -o Dpkg::Options::=--force-confdef -o Dpkg::Options::=--force-confold install fakeroot
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Следующие НОВЫЕ пакеты будут установлены:
  fakeroot
0 будет обновлено, 1 новых установлено, 0 пакетов будет удалено и 0 не будет обновлено.
Необходимо получить 54,4kB архивов.
После распаковки потребуется дополнительно 128kB дискового пространства.
Получено: 1 http://mirror.yandex.ru p9/branch/x86_64/classic fakeroot 1.20.2-alt2:sisyphus+229033.100.2.1@1557324306 [54,4kB]
Получено 54,4kB за 0s (118kB/s).
Совершаем изменения...
Подготовка...                           ################################# [100%]
Обновление / установка...
1: fakeroot-1.20.2-alt2                 ################################# [100%]
Завершено.
Installing appropriate package for alien command...
 # apt-get -y --force-yes -o APT::Install::VirtualVersion=true -o APT::Install::Virtual=true -o Dpkg::Options::=--force-confdef -o Dpkg::Options::=--force-confold install alien
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Следующие НОВЫЕ пакеты будут установлены:
  alien
0 будет обновлено, 1 новых установлено, 0 пакетов будет удалено и 0 не будет обновлено.
Необходимо получить 46,6kB архивов.
После распаковки потребуется дополнительно 110kB дискового пространства.
Получено: 1 http://mirror.yandex.ru p9/branch/noarch/classic alien 8.95-alt9:p9+267525.100.1.1@1615291689 [46,6kB]
Получено 46,6kB за 0s (70,6kB/s).
Совершаем изменения...
Подготовка...                           ################################# [100%]
Обновление / установка...
1: alien-8.95-alt9                      ################################# [100%]
Завершено.
Installing appropriate package for rpmbuild command...
 # apt-get -y --force-yes -o APT::Install::VirtualVersion=true -o APT::Install::Virtual=true -o Dpkg::Options::=--force-confdef -o Dpkg::Options::=--force-confold install rpm-build
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Следующие дополнительные пакеты будут установлены:
  autoconf autoconf-common autoconf_2.60 automake automake_1.16 bison
  bison-runtime elfutils gcc gcc8 gnu-config libasan5 libasm libatomic1
  libitm1 liblsan0 libmpx2 librpm librpmbuild libtool libtool-common
  libtool_2.4 libtsan0 libubsan1 libvtv0 perl-CPAN-Meta-Requirements
  rpm-build-perl rpm-build-python rpmspec
Следующие НОВЫЕ пакеты будут установлены:
  autoconf autoconf-common autoconf_2.60 automake automake_1.16 bison
  bison-runtime elfutils gcc gcc8 gnu-config libasan5 libasm libatomic1
  libitm1 liblsan0 libmpx2 librpm librpmbuild libtool libtool-common
  libtool_2.4 libtsan0 libubsan1 libvtv0 perl-CPAN-Meta-Requirements rpm-build
  rpm-build-perl rpm-build-python rpmspec
0 будет обновлено, 30 новых установлено, 0 пакетов будет удалено и 0 не будет обновлено.
Необходимо получить 17,5MB/17,5MB архивов.
После распаковки потребуется дополнительно 55,4MB дискового пространства.
Получено: 1 http://mirror.yandex.ru p9/branch/noarch/classic autoconf-common 0.3.1-alt1@1533421647 [3220B]
Получено: 2 http://mirror.yandex.ru p9/branch/noarch/classic autoconf_2.60 2:2.69-alt6:p9+238696.100.1.1@1570226680 [577kB]
Получено: 3 http://mirror.yandex.ru p9/branch/noarch/classic autoconf 2:2.69-alt4@1533423868 [4098B]
Получено: 4 http://mirror.yandex.ru p9/branch/noarch/classic gnu-config 1.0.895.9e51-alt1:sisyphus.218625.100@1545832480 [23,4kB]
Получено: 5 http://mirror.yandex.ru p9/branch/noarch/classic automake_1.16 1.16.1-alt1:sisyphus+226928.100.1.1@1554814755 [613kB]
Получено: 6 http://mirror.yandex.ru p9/branch/noarch/classic automake 1:1.16-alt1:sisyphus+226889.100.2.1@1554763109 [3090B]
Получено: 7 http://mirror.yandex.ru p9/branch/noarch/classic bison-runtime 3.0.5-alt1:sisyphus+221902.1100.4.1@1550589333 [6174B]
Получено: 8 http://mirror.yandex.ru p9/branch/x86_64/classic bison 3.0.5-alt1:sisyphus+221902.1100.4.1@1550589333 [545kB]
Получено: 9 http://mirror.yandex.ru p9/branch/x86_64/classic libasm 0.183-alt1:p9+266215.200.3.1@1614869792 [24,8kB]
Получено: 10 http://mirror.yandex.ru p9/branch/x86_64/classic elfutils 0.183-alt1:p9+266215.200.3.1@1614869792 [369kB]
Получено: 11 http://mirror.yandex.ru p9/branch/x86_64/classic libasan5 8.4.1-alt0.p9.1:p9+247559.100.2.1@1585587756 [390kB]
Получено: 12 http://mirror.yandex.ru p9/branch/x86_64/classic libtsan0 8.4.1-alt0.p9.1:p9+247559.100.2.1@1585587756 [311kB]
Получено: 13 http://mirror.yandex.ru p9/branch/x86_64/classic libitm1 8.4.1-alt0.p9.1:p9+247559.100.2.1@1585587756 [55,0kB]
Получено: 14 http://mirror.yandex.ru p9/branch/x86_64/classic liblsan0 8.4.1-alt0.p9.1:p9+247559.100.2.1@1585587756 [160kB]
Получено: 15 http://mirror.yandex.ru p9/branch/x86_64/classic libubsan1 8.4.1-alt0.p9.1:p9+247559.100.2.1@1585587756 [148kB]
Получено: 16 http://mirror.yandex.ru p9/branch/x86_64/classic libvtv0 8.4.1-alt0.p9.1:p9+247559.100.2.1@1585587756 [41,3kB]
Получено: 17 http://mirror.yandex.ru p9/branch/x86_64/classic libmpx2 8.4.1-alt0.p9.1:p9+247559.100.2.1@1585587756 [39,2kB]
Получено: 18 http://mirror.yandex.ru p9/branch/x86_64/classic gcc8 8.4.1-alt0.p9.1:p9+247559.100.2.1@1585587756 [12,9MB]
Получено: 19 http://mirror.yandex.ru p9/branch/x86_64/classic gcc 8-alt2:p9+246536.100.3.1@1582643803 [5161B]
Получено: 20 http://mirror.yandex.ru p9/branch/x86_64/classic librpm 4.0.4-alt164:p9+266215.100.3.1@1614869581 [313kB]
Получено: 21 http://mirror.yandex.ru p9/branch/x86_64/classic librpmbuild 4.0.4-alt164:p9+266215.100.3.1@1614869581 [160kB]
Получено: 22 http://mirror.yandex.ru p9/branch/x86_64/classic libtool-common 0.2.2-alt1@1533412160 [5735B]
Получено: 23 http://mirror.yandex.ru p9/branch/x86_64/classic libtool_2.4 2.4.6-alt1:sisyphus+226971.100.2.1@1554906326 [407kB]
Получено: 24 http://mirror.yandex.ru p9/branch/noarch/classic libtool 3:2.4.2-alt7@1533461531 [2738B]
Получено: 25 http://mirror.yandex.ru p9/branch/noarch/classic perl-CPAN-Meta-Requirements 2.140-alt1@1450184784 [13,0kB]
Получено: 26 http://mirror.yandex.ru p9/branch/noarch/classic rpm-build-perl 0.84-alt16:sisyphus+223355.100.1.2@1551483645 [34,7kB]
Получено: 27 http://mirror.yandex.ru p9/branch/noarch/classic rpm-build-python 0.37.0-alt1@1530500955 [54,2kB]
Получено: 28 http://mirror.yandex.ru p9/branch/x86_64/classic rpmspec 4.13.0.1-alt24:p9+254187.340.9.1@1598671540 [90,6kB]
Получено: 29 http://mirror.yandex.ru p9/branch/x86_64/classic rpm-build 4.0.4-alt164:p9+266215.100.3.1@1614869581 [178kB]
Получено 17,5MB за 7s (2402kB/s).                                             
Совершаем изменения...
Подготовка...                           ################################# [100%]
Обновление / установка...
 1: gnu-config-1.0.895.9e51-alt1        ################################# [  3%]
 2: autoconf-common-0.3.1-alt1          ################################# [  7%]
 3: autoconf_2.60-2:2.69-alt6           ################################# [ 10%]
 4: autoconf-2:2.69-alt4                ################################# [ 13%]
 5: automake_1.16-1.16.1-alt1           ################################# [ 17%]
 6: automake-1:1.16-alt1                ################################# [ 20%]
 7: rpmspec-4.13.0.1-alt24              ################################# [ 23%]
 8: rpm-build-python-0.37.0-alt1        ################################# [ 27%]
 9: perl-CPAN-Meta-Requirements-2.140-al################################# [ 30%]
10: rpm-build-perl-0.84-alt16           ################################# [ 33%]
11: libtool-common-0.2.2-alt1           ################################# [ 37%]
12: libtool_2.4-2.4.6-alt1              ################################# [ 40%]
13: libtool-3:2.4.2-alt7                ################################# [ 43%]
14: librpm-4.0.4-alt164                 ################################# [ 47%]
15: librpmbuild-4.0.4-alt164            ################################# [ 50%]
16: libmpx2-8.4.1-alt0.p9.1             ################################# [ 53%]
17: libvtv0-8.4.1-alt0.p9.1             ################################# [ 57%]
18: libubsan1-8.4.1-alt0.p9.1           ################################# [ 60%]
19: liblsan0-8.4.1-alt0.p9.1            ################################# [ 63%]
20: libitm1-8.4.1-alt0.p9.1             ################################# [ 67%]
21: libtsan0-8.4.1-alt0.p9.1            ################################# [ 70%]
22: libasan5-8.4.1-alt0.p9.1            ################################# [ 73%]
23: libatomic1-8.4.1-alt0.p9.1          ################################# [ 77%]
24: gcc8-8.4.1-alt0.p9.1                ################################# [ 80%]
25: gcc-8-alt2                          ################################# [ 83%]
26: libasm-0.183-alt1                   ################################# [ 87%]
27: elfutils-0.183-alt1                 ################################# [ 90%]
28: bison-runtime-3.0.5-alt1            ################################# [ 93%]
29: bison-3.0.5-alt1                    ################################# [ 97%]
30: rpm-build-4.0.4-alt164              ################################# [100%]
Завершено.

Repacking /home/using/Загрузки/skypeforlinux-64.rpm to local rpm format ...
 # fakeroot alien --generate --to-rpm ../skypeforlinux-64.rpm
Warning: Skipping conversion of scripts in package skypeforlinux: postinst
Warning: Use the --scripts parameter to include the scripts.
Use of uninitialized value in concatenation (.) or string at /usr/share/perl5/Alien/Package/Rpm.pm line 342, <GETPERMS> line 115.
 # bash /etc/eepm/repack.d/skypeforlinux.sh /tmp/.private/root/tmp.hI3eCMfW6T/skypeforlinux-64.rpm.tmpdir/skypeforlinux-8.72.0.82 /tmp/.private/root/tmp.hI3eCMfW6T/skypeforlinux-64.rpm.tmpdir/skypeforlinux-8.72.0.82-2.spec
 # fakeroot rpmbuild --buildroot /tmp/.private/root/tmp.hI3eCMfW6T/skypeforlinux-64.rpm.tmpdir/skypeforlinux-8.72.0.82 --define=_allow_root_build 1 -bb /tmp/.private/root/tmp.hI3eCMfW6T/skypeforlinux-64.rpm.tmpdir/skypeforlinux-8.72.0.82-2.spec
предупреждение: absolute symlink: /tmp/.private/root/tmp.hI3eCMfW6T/skypeforlinux-64.rpm.tmpdir/skypeforlinux-8.72.0.82/usr/bin/skype -> /usr/bin/skypeforlinux
find-requires: running scripts (cpp,debuginfo,files,gir-js,gir-python,gir,lib,pam,perl,pkgconfig,pkgconfiglib,python,python3,rpmlib,shebang,shell,static,symlinks,systemd-services,typelib)
lib.req: WARNING: /tmp/.private/root/tmp.hI3eCMfW6T/skypeforlinux-64.rpm.tmpdir/skypeforlinux-8.72.0.82/opt/skype/resources/app.asar.unpacked/modules/electron_utility.node: overlinked libraries: /lib64/libm.so.6
lib.req: WARNING: /tmp/.private/root/tmp.hI3eCMfW6T/skypeforlinux-64.rpm.tmpdir/skypeforlinux-8.72.0.82/opt/skype/resources/app.asar.unpacked/modules/keytar.node: overlinked libraries: /lib64/libm.so.6 /usr/lib64/libgio-2.0.so.0 /usr/lib64/libgobject-2.0.so.0
symlinks.req: /tmp/.private/root/tmp.hI3eCMfW6T/skypeforlinux-64.rpm.tmpdir/skypeforlinux-8.72.0.82/usr/lib/.build-id/b2/4de59d738335312ca8996aeacc4e7e60244ce1: /usr/share/skypeforlinux/chrome-sandbox -> /usr/share/skypeforlinux/chrome-sandbox (raw, not installed)
symlinks.req: /tmp/.private/root/tmp.hI3eCMfW6T/skypeforlinux-64.rpm.tmpdir/skypeforlinux-8.72.0.82/usr/lib/.build-id/ef/53f56148cf2d1fbf2d3866e4a8387e585c41ad: /usr/share/skypeforlinux/libEGL.so -> /usr/share/skypeforlinux/libEGL.so (raw, not installed)
symlinks.req: /tmp/.private/root/tmp.hI3eCMfW6T/skypeforlinux-64.rpm.tmpdir/skypeforlinux-8.72.0.82/usr/lib/.build-id/74/a3e7e71005c3792e78eeef5d2ce1c5e3c5ffee: /usr/share/skypeforlinux/libGLESv2.so -> /usr/share/skypeforlinux/libGLESv2.so (raw, not installed)
symlinks.req: /tmp/.private/root/tmp.hI3eCMfW6T/skypeforlinux-64.rpm.tmpdir/skypeforlinux-8.72.0.82/usr/lib/.build-id/a4/69c393b0a80ec67cfdff127180a7b6fb1e9e39: /usr/share/skypeforlinux/libffmpeg.so -> /usr/share/skypeforlinux/libffmpeg.so (raw, not installed)
symlinks.req: /tmp/.private/root/tmp.hI3eCMfW6T/skypeforlinux-64.rpm.tmpdir/skypeforlinux-8.72.0.82/usr/lib/.build-id/e8/7f188e8dc194aba16a64481c562f39f52ca726: /usr/share/skypeforlinux/libvk_swiftshader.so -> /usr/share/skypeforlinux/libvk_swiftshader.so (raw, not installed)
symlinks.req: /tmp/.private/root/tmp.hI3eCMfW6T/skypeforlinux-64.rpm.tmpdir/skypeforlinux-8.72.0.82/usr/lib/.build-id/47/66940d55c56a64fc44b9068b384dd907546b35: /usr/share/skypeforlinux/libvulkan.so -> /usr/share/skypeforlinux/libvulkan.so (raw, not installed)
symlinks.req: /tmp/.private/root/tmp.hI3eCMfW6T/skypeforlinux-64.rpm.tmpdir/skypeforlinux-8.72.0.82/usr/lib/.build-id/8d/bb7b481b609daeb2316dfb1c2459126787994d: /usr/share/skypeforlinux/skypeforlinux -> /usr/share/skypeforlinux/skypeforlinux (raw, not installed)
symlinks.req: /tmp/.private/root/tmp.hI3eCMfW6T/skypeforlinux-64.rpm.tmpdir/skypeforlinux-8.72.0.82/usr/lib/.build-id/a8/1e0722055b27f4d32c59538e6058b4cbbf0e61: /usr/share/skypeforlinux/swiftshader/libEGL.so -> /usr/share/skypeforlinux/swiftshader/libEGL.so (raw, not installed)
symlinks.req: /tmp/.private/root/tmp.hI3eCMfW6T/skypeforlinux-64.rpm.tmpdir/skypeforlinux-8.72.0.82/usr/lib/.build-id/dd/50ec0d1fed265f44d37c64a7e92d293a2a3f50: /usr/share/skypeforlinux/swiftshader/libGLESv2.so -> /usr/share/skypeforlinux/swiftshader/libGLESv2.so (raw, not installed)
++ /bin/sed -e '/^libffmpeg.so().*/d' -e '/^libEGL.so().*/d' -e '/^libGLESv2.so().*/d'
find-requires: FINDPACKAGE-COMMANDS: mkdir nohup
 # rpm -Uvh /tmp/.private/root/tmp.hI3eCMfW6T/skypeforlinux-8.72.0.82-alt1.repacked.with.epm.2.x86_64.rpm
ошибка: Неудовлетворенные зависимости:
   /usr/share/skypeforlinux/chrome-sandbox нужен для skypeforlinux-8.72.0.82-alt1.repacked.with.epm.2.x86_64
   /usr/share/skypeforlinux/libEGL.so нужен для skypeforlinux-8.72.0.82-alt1.repacked.with.epm.2.x86_64
   /usr/share/skypeforlinux/libGLESv2.so нужен для skypeforlinux-8.72.0.82-alt1.repacked.with.epm.2.x86_64
   /usr/share/skypeforlinux/libffmpeg.so нужен для skypeforlinux-8.72.0.82-alt1.repacked.with.epm.2.x86_64
   /usr/share/skypeforlinux/libvk_swiftshader.so нужен для skypeforlinux-8.72.0.82-alt1.repacked.with.epm.2.x86_64
   /usr/share/skypeforlinux/libvulkan.so нужен для skypeforlinux-8.72.0.82-alt1.repacked.with.epm.2.x86_64
   /usr/share/skypeforlinux/skypeforlinux нужен для skypeforlinux-8.72.0.82-alt1.repacked.with.epm.2.x86_64
   /usr/share/skypeforlinux/swiftshader/libEGL.so нужен для skypeforlinux-8.72.0.82-alt1.repacked.with.epm.2.x86_64
   /usr/share/skypeforlinux/swiftshader/libGLESv2.so нужен для skypeforlinux-8.72.0.82-alt1.repacked.with.epm.2.x86_64
 # apt-get install /tmp/.private/root/tmp.hI3eCMfW6T/skypeforlinux-8.72.0.82-alt1.repacked.with.epm.2.x86_64.rpm
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Выбрано skypeforlinux для '/tmp/.private/root/tmp.hI3eCMfW6T/skypeforlinux-8.72.0.82-alt1.repacked.with.epm.2.x86_64.rpm'
Некоторые пакеты установить невозможно. Это может означать, что Вы
потребовали невозможного, либо пользуетесь нестабильным репозиторием.
Часть необходимых пакетов либо ещё не создана, либо была удалена
из каталога 'Входящие'.

Так как для выполнения Вашего запроса достаточно одной операции, то
скорее всего этот пакет просто невозможно установить. Сообщите, пожалуйста,
об этом как о найденной ошибке в пакете.
Эти сведения могут помочь найти выход из ситуации:

Следующие пакеты имеют неудовлетворенные зависимости:
  skypeforlinux: Требует: /usr/share/skypeforlinux/chrome-sandbox но пакет не может быть установлен
                 Требует: /usr/share/skypeforlinux/libEGL.so но пакет не может быть установлен
                 Требует: /usr/share/skypeforlinux/libGLESv2.so но пакет не может быть установлен
                 Требует: /usr/share/skypeforlinux/libffmpeg.so но пакет не может быть установлен
                 Требует: /usr/share/skypeforlinux/libvk_swiftshader.so но пакет не может быть установлен
                 Требует: /usr/share/skypeforlinux/libvulkan.so но пакет не может быть установлен
                 Требует: /usr/share/skypeforlinux/skypeforlinux но пакет не может быть установлен
                 Требует: /usr/share/skypeforlinux/swiftshader/libEGL.so но пакет не может быть установлен
                 Требует: /usr/share/skypeforlinux/swiftshader/libGLESv2.so но пакет не может быть установлен
E: Извините, `битые' пакеты
удалён '/tmp/.private/root/tmp.hI3eCMfW6T/.rpmmacros'
удалён '/tmp/.private/root/tmp.hI3eCMfW6T/skypeforlinux-8.72.0.82-alt1.repacked.with.epm.2.x86_64.rpm'
rmdir: удаление каталога, '/tmp/.private/root/tmp.hI3eCMfW6T'

Оффлайн ASte

  • Мастер
  • ***
  • Сообщений: 1 426
Можно попробовать установить SNAP-пакет.
snapd в altlinux ЕМНИП нет, а вот flatpak есть и в сизифе и в p9.
Так что через flatpak можно попробовать, там тоже есть skype

Оффлайн gosts 87

  • Давно тут
  • **
  • Сообщений: 997
  • Дмитрий/Dmitry/德米特里/दिमित्री
Мне, в принципе, не нужно. Я просто решил проверить - оказывается не установился даже переупакованный пакет.
Чувствую, что ситуация как с Яндекс-Браузером на "Восьмой платформе", пакет  libatomic1 не той версии, которая теперь Скайпу требуется.

Оффлайн gosts 87

  • Давно тут
  • **
  • Сообщений: 997
  • Дмитрий/Dmitry/德米特里/दिमित्री
Там, правда, в случае с Я.Б. вообще нужный пакет в репозиториях отсутствовал.

Оффлайн Kalt

  • Давно тут
  • **
  • Сообщений: 946
...Легко обновился сейчас:
« Последнее редактирование: 24.05.2021 22:16:34 от Kalt »
Intel Xeon X3440 2,53GHz, MSI H55- G43, DDR3- 4x2GB, GF GT710

Оффлайн gosts 87

  • Давно тут
  • **
  • Сообщений: 997
  • Дмитрий/Dmitry/德米特里/दिमित्री
А почему тогда пишет, что "Broken packages"?

Оффлайн Kalt

  • Давно тут
  • **
  • Сообщений: 946
...Меня это не смущает...
Intel Xeon X3440 2,53GHz, MSI H55- G43, DDR3- 4x2GB, GF GT710

Оффлайн gosts 87

  • Давно тут
  • **
  • Сообщений: 997
  • Дмитрий/Dmitry/德米特里/दिमित्री
...Меня это не смущает...
Так дело не в том, смущает или нет. :-) Если все зависимости удовлетворены и все нужные пакеты встали, то такого выброса с ошибками быть не должно...

Оффлайн Kalt

  • Давно тут
  • **
  • Сообщений: 946
Цитировать
Чтение списков пакетов ...
Построение дерева зависимостей ...
Выбор skypeforlinux для '/ home / kalt1 / Загрузки / skypeforlinux-64 (5) .rpm'
Некоторые пакеты не могут быть установлены. Это может означать, что у вас есть
запросил невозможную ситуацию или если вы используете нестабильный
дистрибутив, некоторые требуемые пакеты еще не созданы
или был перемещен из списка входящих.
Следующие пакеты имеют неудовлетворенные зависимости:
   skypeforlinux: Зависит от: (libatomic или libatomic1), но не устанавливается
E: битые пакеты
...Согласен с выше изложенным, однако запуск, обновление и работа ПО проходит нормально...
« Последнее редактирование: 24.05.2021 22:48:01 от Kalt »
Intel Xeon X3440 2,53GHz, MSI H55- G43, DDR3- 4x2GB, GF GT710

Оффлайн gosts 87

  • Давно тут
  • **
  • Сообщений: 997
  • Дмитрий/Dmitry/德米特里/दिमित्री
...Согласен с выше изложенным, однако запуск, обновление и работа ПО проходит нормально...
А вот я сейчас не смог установить. До этого не было. Alt Workstation 9.1 x86_64 (MATE)

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 9 581
Этот тоже можно установить:
https://repo.skype.com/rpm/stable/skypeforlinux_8.72.0.82-1.x86_64.rpm

Через '-Uhv' и '--noscrips'.
Иначе без '--noscrips' он насрёт в терминал о некорректном пакетном менеджере. Он yum или yast в постинсталл скриптах хочет.
'rpm -Uhv --noscripts' подскажет чего ему не хватает и что он хочет по зависимостям.
В p9-xfce-sysv, работающей чуть больше года, он захотел  gnome-keyring p11-kit.