Автор Тема: p7 Sisyphus  (Прочитано 2898 раз)

Оффлайн mayhl

  • Завсегдатай
  • *
  • Сообщений: 568
    • softmasterhl.awardspace.info
    • Email
Re: p7 Sisyphus
« Ответ #15 : 21.03.2022 14:30:46 »
Пришлось(удалось) вернуться к к переходу со свежеустановленного p7 (32бит) на Sisyphus.
Поиски архивной даты для работоспособного варианта привели только к последовательному обновлению на даты 2014.01.01, и только потом -- на 2014.06.01, переход на 2015.01.01 или архивы поздних дат приводил к неработоспосбности.
Попытки осуществлялись на (апдайт с p6 на p7 заменил лицензию p6 на p7.05):
АльтЛинукс Рабочая станция Кентавр, АльтЛинукс Школьный Юниор, начиная с "чистых" установок.

Сеть настроена "вручную" через etcnet.
Для успеха предварительно (по опыту неудачных проб) перед обновлениями удалены пакеты создающие проблемы(зависания) обновления, загрузки... : clamav mariadb avahi-daemon NetworkManager
Установлен (на всякий случай): KDE 3.5 .
После обновления на Sisyphus 2014.06.01 установки apt-scrips(на всякий случай), удалось безпроблемно (с обновлением apt-get и увеличением его кеша) обновиться на p8 (при этом, прямое обновление p7 на p8 не удавалось).

В p8 варианте:
LO Writer "вылетал" без сообщений на обновлённых ядрах, но запускался на "старых";
LO Base выдаёт ошибку, в параметрах настройки нет java (установка 1.8 не помогает)...
Спойлер
Невозможно установить соединение с источником данных «Новая база данных».

Состояние SQL: HY000
Невозможно подключиться к внешнему источнику данных. Не найден драйвер SDBC для URL 'sdbc:embedded:firebird'.

Было запрошено соединение со следующим URL «sdbc:embedded:firebird».

 


« Последнее редактирование: 21.03.2022 14:34:36 от mayhl »

Оффлайн yaleks

  • Мастер
  • ***
  • Сообщений: 6 157
Re: p7 Sisyphus
« Ответ #16 : 21.03.2022 15:22:49 »
firebird не требует Java - это другой движок.

Оффлайн mayhl

  • Завсегдатай
  • *
  • Сообщений: 568
    • softmasterhl.awardspace.info
    • Email
Re: p7 Sisyphus
« Ответ #17 : 22.03.2022 12:42:48 »
Возможно ЛибреОфис подключает что-то через java?
При этом установлены: java1.6, 1.7, 1.8, mariadb, firebird ...
В Synaptic нет пакетов с sdbc в названии для установки.
В LO Base нет опции java в параметрах.
« Последнее редактирование: 22.03.2022 12:52:55 от mayhl »

Оффлайн yaleks

  • Мастер
  • ***
  • Сообщений: 6 157
Re: p7 Sisyphus
« Ответ #18 : 22.03.2022 16:04:44 »
java 1.6, 1.7, 1.8 уже не актуальны.
Может быть вы напоролись на какой-то баг с 32-битной архитектурой, её плохо тестируют сейчас.

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 493
    • Домашняя страница
    • Email
Re: p7 Sisyphus
« Ответ #19 : 22.03.2022 18:51:50 »
java 1.6, 1.7, 1.8 уже не актуальны.
Может быть вы напоролись на какой-то баг с 32-битной архитектурой, её плохо тестируют сейчас.
java-1.8.0-openjdk актуальна и поддерживается.
Андрей Черепанов (cas@)

Оффлайн mayhl

  • Завсегдатай
  • *
  • Сообщений: 568
    • softmasterhl.awardspace.info
    • Email
Re: p7 Sisyphus
« Ответ #20 : 24.03.2022 12:41:51 »
Двигаюсь дальше с p8 на архив сизифа 2016/12/08 -- успешно.
А дальше стопор:
Preparing...                 ########################################### [100%]
file /usr/lib/rpm/macros from install of librpm7-4.13.0-alt7 conflicts with file from package librpm-4.0.4-alt101.M80P.5.6
file /usr/lib/rpm/rpmrc from install of librpm7-4.13.0-alt7 conflicts with file from package librpm-4.0.4-alt101.M80P.5.6
E: Ошибка во время исполнения транзакции
Спойлер
из http://sisyphus.ru/ru/srpm/rpm/changelog
 20 декабря 2016 Gleb F-Malinovskiy <glebfm at altlinux.org> 4.13.0-alt7

    rpmquery: added -i alias for --info (ALT#32872).
    librpmbuild7: removed C: librpm < 4.0.4-alt100.97.
    librpm7: actually added C: librpm < 4.0.4-alt100.97.
    Moved rpmspec utility to separate subpackage.

19 декабря 2016 Gleb F-Malinovskiy <glebfm at altlinux.org> 4.13.0-alt6

    librpm7: added C: librpm < 4.0.4-alt100.97.

16 декабря 2016 Gleb F-Malinovskiy <glebfm at altlinux.org> 4.13.0-alt5

    Moved /bin/rpm back to /usr/bin/rpm (ALT#32878).
    Dropped useless cron subpackage.
    Moved selinux plugin to librpm7 package.
    Dropped outdated translated manpages.
    Moved rpm.supp to librpm-devel package.

13 декабря 2016 Gleb F-Malinovskiy <glebfm at altlinux.org> 4.13.0-alt4

    rpmspec: restored support of BuildRequires(pre) (ALT#32870), and Serial (ALT#32888) tags.
    rpmspec: fixed support of long lines in specfile.
    rpm: restored --with{,out} and --{en,dis}able aliases for rpmbuild.
    Added conflict to apt < 0.5.15lorg2-alt54 (ALT#32873).
    Fixed retrieving of remote files.
    Dropped R: curl (it is optional).
    Fixed encoding of translated manpages.
    Changed rpmlog to write to stderr.
    Fixed support of APT external tags (ALT#32887).
    Define RPM_INSTALL_{NAME,ARG1,ARG2} env variables only for per-package scripts (ALT#32890).
Не помогает #apt-get -f install #apt-get --fix-broken dist-upgrade
Если же попытаться #apt-get remove librpm -- хочет очень много удалять.
« Последнее редактирование: 24.03.2022 12:48:04 от mayhl »

Оффлайн Александр Ерещенко

  • Завсегдатай
  • *
  • Сообщений: 995
Re: p7 Sisyphus
« Ответ #21 : 24.03.2022 13:51:02 »
Глупый вопрос.
А почему не был выбран проверенный и описанный на вики поэтапный путь апгрейда p7 -> p8 -> p9 -> p10 -> sisyphus (если очень надо) ?

Возможно сейчас вам может помочь что-то из описаний таких переходов
https://www.altlinux.org/Update/p8
https://www.altlinux.org/Update/p9
https://www.altlinux.org/Update/p10
« Последнее редактирование: 24.03.2022 13:54:47 от Александр Ерещенко »

Оффлайн asy

  • alt linux team
  • ***
  • Сообщений: 7 785
Re: p7 Sisyphus
« Ответ #22 : 24.03.2022 16:26:02 »
Двигаюсь дальше с p8 на архив сизифа 2016/12/08 -- успешно.
Вот кстати да. Наверное лучше до ближайшего бранча, потом с бранча на бранч. Если до p8 получилось дойти, то дальше уже p9.

Оффлайн mayhl

  • Завсегдатай
  • *
  • Сообщений: 568
    • softmasterhl.awardspace.info
    • Email
Re: p7 Sisyphus
« Ответ #23 : 25.03.2022 12:40:13 »
... А почему не был выбран проверенный и описанный на вики поэтапный путь апгрейда p7 -> p8 -> p9 -> p10 -> sisyphus (если очень надо) ?
Описанный на вики путь апгрейда p7 -> p8 практически неработоспособен (или требует отключения- лучше удаления неуказанных служб, неуказанных (супер продвинутых) действий, восстановлений работоспособности... ).

Мне удалось только каким-то чудом обновить p7->p8 только в 1 варианте примерно из 20 попыток на 5 идентичных комп. (2Гб, Пень.G630). Причём, это была попытка №3, повторить которую в дальнейшем не получилось. https://forum.altlinux.org/index.php?topic=44321.msg350213#msg350213
Сейчас пытаюсь подготовить вариант для переноса на "слабые" комп.(Cel.D-P631, 256-1024Гб, раздел 20Гб).
Удивительным образом 1 комп. помощнее (из "слабых") p7 пару лет (пока не закончилось свободное место) обновлялся на прямой Сизиф или смешанный с репой p7, пока у Сизифа не поменялась конфигурация (эта тема). 
Сейчас обновить p7->p8 (с учётом опыта многократных попыток) на работоспособный вариант (который хотя бы проходит загрузку, без зависания или не завершающихся стартующих безлимитных служб, без возможности перехода в доп.текст. консоль...) не получается.
Поэтому, здесь поиск варианта обновления через архивы Сизифа.
ИТОГО (с предварительным удалением clamav mariadb avahi-daemon NetworkManager):
+ p6->p7;
-  p7->архив Сизифа 2014/06/01;
+ p7->архив Сизифа 2014/01/01;
+ архив Сизифа 2014/01/01 -> архив Сизифа 2014/06/01;
-  архив Сизифа 2014/06/01 -> архив Сизифа 2014/12/01;
+ архив Сизифа 2014/06/01 -> p8;
+ p8 -> архив Сизифа 2016/12/08;
- архив Сизифа 2016/12/08 -> архив Сизифа 2016/12/13.

В принципе, для "слабых" комп. было бы достаточно обновлением добраться до p8, только не работает LO Base (в этой версии обновления), а, OpenOffice "вылетал" ранее, в аналогичном работающем варианте обновления p7->p8.
Хотя, в Симпли8 LO работает без проблем, но компы в школе, поэтому, желательно, Школьный дистр. (p6).
« Последнее редактирование: 25.03.2022 13:21:47 от mayhl »

Оффлайн asy

  • alt linux team
  • ***
  • Сообщений: 7 785
Re: p7 Sisyphus
« Ответ #24 : 25.03.2022 14:26:37 »
Мне удалось только каким-то чудом обновить p7->p8 только в 1 варианте примерно из 20 попыток на 5 идентичных комп. (2Гб, Пень.G630). Причём, это была попытка №3, повторить которую в дальнейшем не получилось. https://forum.altlinux.org/index.php?topic=44321.msg350213#msg350213
А я там в однопользовательском режиме предлагал обновить, не получилось?

Оффлайн mayhl

  • Завсегдатай
  • *
  • Сообщений: 568
    • softmasterhl.awardspace.info
    • Email
Re: p7 Sisyphus
« Ответ #25 : 25.03.2022 15:25:03 »
Смогу сделать следующую контрольную попытку на след.  неделе.

Оффлайн yaleks

  • Мастер
  • ***
  • Сообщений: 6 157
Re: p7 Sisyphus
« Ответ #26 : 25.03.2022 15:26:05 »
java 1.6, 1.7, 1.8 уже не актуальны.
Может быть вы напоролись на какой-то баг с 32-битной архитектурой, её плохо тестируют сейчас.
java-1.8.0-openjdk актуальна и поддерживается.
Для LibreOffice?

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 493
    • Домашняя страница
    • Email
Re: p7 Sisyphus
« Ответ #27 : 25.03.2022 18:37:40 »
Нет, LO новых версий требует 9 и выше. 1.8.0 longterm.
Андрей Черепанов (cas@)

Оффлайн yaleks

  • Мастер
  • ***
  • Сообщений: 6 157
Re: p7 Sisyphus
« Ответ #28 : 25.03.2022 19:28:54 »
Нет, LO новых версий требует 9 и выше. 1.8.0 longterm.
вот и топикстартер спрашивал про LO.

Оффлайн mayhl

  • Завсегдатай
  • *
  • Сообщений: 568
    • softmasterhl.awardspace.info
    • Email
Re: p7 Sisyphus
« Ответ #29 : 28.03.2022 15:10:52 »
Мне удалось только каким-то чудом обновить p7->p8 только в 1 варианте примерно из 20 попыток на 5 идентичных комп. (2Гб, Пень.G630). Причём, это была попытка №3, повторить которую в дальнейшем не получилось. https://forum.altlinux.org/index.php?topic=44321.msg350213#msg350213
А я там в однопользовательском режиме предлагал обновить, не получилось?
Прямая попытка обновления обновлённого p7 [из обновления p6] -> p8.
После:
# apt-repo rm all
# apt-repo add branch p8
# apt-get update
# apt-get -d dist-upgrade
# telinit 1
Спойлер
# rpm -Uvh *.rpm
ошибка: неудовлетворенные зависимости:
   python-module-cupshelpers конфликтует с python3-module-cupshelpers-1.5.11-alt3.M80P.1
   python-module-numpy = 2.0.0-alt9.M70P.1.git20121009 нужен для python-module-numpy-addons-2.0.0-alt9.M70P.1.git20121009
   python-module-numpy < 2.0.0-alt9.M70P.1.git20121009 конфликтует с python-module-numpy-addons-2.0.0-alt9.M70P.1.git20121009
   ant = 1.8.4-alt4 нужен для ant-junit4-1.8.4-alt4
   ant = 1.8.4-alt4 нужен для ant-jai-1.8.4-alt4
   /usr/share/ant/bin/antRun.pl   нужен для eclipse-platform-4.2.0-alt5_7jpp7
   /usr/share/ant/bin/complete-ant-cmd.pl   нужен для eclipse-platform-4.2.0-alt5_7jpp7
   /usr/share/ant/bin/runant.pl   нужен для eclipse-platform-4.2.0-alt5_7jpp7
   /usr/share/ant/bin/runant.py   нужен для eclipse-platform-4.2.0-alt5_7jpp7
   /usr/share/java/ant-testutil.jar   нужен для eclipse-platform-4.2.0-alt5_7jpp7
   osgi(org.apache.batik.css) < 1.7.0 нужен для eclipse-platform-4.2.0-alt5_7jpp7
   eclipse-equinox-osgi = 1:4.2.0-alt5_7jpp7 нужен для eclipse-rcp-4.2.0-alt5_7jpp7
   eclipse-swt = 1:4.2.0-alt5_7jpp7 нужен для eclipse-rcp-4.2.0-alt5_7jpp7
   /usr/share/java/felix/org.apache.felix.gogo.command.jar   нужен для eclipse-platform-4.2.0-alt5_7jpp7
   /usr/share/java/felix/org.apache.felix.gogo.runtime.jar   нужен для eclipse-platform-4.2.0-alt5_7jpp7
   /usr/share/java/felix/org.apache.felix.gogo.shell.jar   нужен для eclipse-platform-4.2.0-alt5_7jpp7
   /usr/share/java/glassfish-jsp-api.jar   нужен для jetty-8.1.5-alt4_6jpp7.qa1
   gutenprint = 1:5.2.9-alt1 нужен для gutenprint-foomatic-5.2.9-alt1
   gvfs = 1.16.4-alt0.M70T.0.M70P.1 нужен для gvfs-backend-obexftp-1.16.4-alt0.M70T.0.M70P.1
   java-1.6.0-sun = 0:1.6.0.26-alt7 нужен для mozilla-plugin-java-1.6.0-sun-1.6.0.26-alt7
   jetty-annotations = 8.1.5-alt4_6jpp7.qa1 нужен для jetty-8.1.5-alt4_6jpp7.qa1
   jetty-deploy = 8.1.5-alt4_6jpp7.qa1 нужен для jetty-overlay-deployer-8.1.5-alt4_6jpp7.qa1
   jetty-websocket = 8.1.5-alt4_6jpp7.qa1 нужен для jetty-8.1.5-alt4_6jpp7.qa1
   jetty-jndi = 8.1.5-alt4_6jpp7.qa1 нужен для jetty-overlay-deployer-8.1.5-alt4_6jpp7.qa1
   jetty-monitor = 8.1.5-alt4_6jpp7.qa1 нужен для jetty-8.1.5-alt4_6jpp7.qa1
   jetty-rewrite = 8.1.5-alt4_6jpp7.qa1 нужен для jetty-8.1.5-alt4_6jpp7.qa1
   jetty-server = 8.1.5-alt4_6jpp7.qa1 нужен для jetty-ajp-8.1.5-alt4_6jpp7.qa1
   jetty-servlets = 8.1.5-alt4_6jpp7.qa1 нужен для jetty-8.1.5-alt4_6jpp7.qa1
   jetty-util = 8.1.5-alt4_6jpp7.qa1 нужен для jetty-policy-8.1.5-alt4_6jpp7.qa1
   libqt5-gui = 5.6.2-alt0.M70P.1 нужен для libqt5-egldeviceintegration-5.6.2-alt0.M70P.1
   libreoffice = 3.6.6.1-alt1 нужен для libreoffice-gnome-3.6.6.1-alt1
   libreoffice = 3.6.6.1-alt1 нужен для libreoffice-langpack-ru-3.6.6.1-alt1
   libruby.so.1.9 >= set:oiObjWIz2HFnfZK03y0WZDb8fgfV33URRjIDRj42PlNDbiUsaofEn94RaZaPNHrS5794Fowgp28jZycdiQ2T0tsr48G2P4EMLZJ1ghp7t10sov2KE2b3 нужен для ruby-racc-runtime-1.4.6-alt2.1
   osgi(org.apache.lucene.analysis) < 4.0.0 нужен для eclipse-platform-4.2.0-alt5_7jpp7
   osgi(org.apache.lucene.core) < 4.0.0 нужен для eclipse-platform-4.2.0-alt5_7jpp7
   /usr/share/java/lucene.jar   нужен для eclipse-platform-4.2.0-alt5_7jpp7
   /usr/share/java/lucene-contrib/lucene-analyzers.jar   нужен для eclipse-platform-4.2.0-alt5_7jpp7
   maven-release = 1:2.2.1-alt2_4jpp7 нужен для maven-release-manager-2.2.1-alt2_4jpp7
   tomcat-el-2.2-api нужен для jetty-orbit-maven-depmap-1.0-alt1jpp1
   /usr/share/java/tomcat-el-2.2-api.jar   нужен для jetty-8.1.5-alt4_6jpp7.qa1
   /usr/share/java/tomcat/tomcat-el-2.2-api.jar   нужен для eclipse-platform-4.2.0-alt5_7jpp7
   tomcat-jsp-2.2-api нужен для jetty-orbit-maven-depmap-1.0-alt1jpp1
   /usr/share/java/tomcat/tomcat-jsp-2.2-api.jar   нужен для eclipse-platform-4.2.0-alt5_7jpp7
   /usr/share/java/tomcat/tomcat-jsp-2.2-api.jar   нужен для jetty-8.1.5-alt4_6jpp7.qa1
   /usr/share/java/tomcat/tomcat-servlet-3.0-api.jar   нужен для eclipse-platform-4.2.0-alt5_7jpp7
   tomcat-servlet-3.0-api нужен для jetty-orbit-maven-depmap-1.0-alt1jpp1
   /usr/share/java/tomcat-servlet-3.0-api.jar   нужен для jetty-8.1.5-alt4_6jpp7.qa1
   xorg-server = 2:1.14.7-alt4.M70P.1 нужен для xorg-drv-multimedia-1.14.7-alt4.M70P.1
стало боязно запускать...
« Последнее редактирование: 28.03.2022 15:18:51 от mayhl »