Автор Тема: Odoo psycopg2 не устанавливается [РЕШЕНО]  (Прочитано 2422 раз)

Оффлайн flint1975

  • Давно тут
  • **
  • Сообщений: 1 318
    • Email
Symply 64 обновлена до сизифа.
при попытке установить odoo:
Следующие пакеты имеют неудовлетворенные зависимости:
  odoo: Требует: python3(psycopg2) (< 0)
        Требует: python3(psycopg2.errorcodes) (< 0)
        Требует: python3(psycopg2.extensions) (< 0)
        Требует: python3(psycopg2.extras) (< 0)
        Требует: python3(psycopg2.pool) (< 0)
E: Извините, `битые' пакеты

при попытке установить python3-module-psycopg2:
python3-module-psycopg2:
 Зависит от: libpq.so.5()(64bit) (>= set:le0TVGKd0aLPs2Nto7Z1f8FxU3t37565zOwtmwlUaWn0dXOK7GBJfWweelDqOjusm7LJHI69oPyonkICCiZ0KE8twsNhtmDQxu1w9MNRQM6iIwtsGmhvDgb4B6QuzxLcX13wdIuoKDPIJQr4x1t1hL1zoDFNfnwrgBoGCYuEls2pCkkAe2WpTW8FwTtXB)
 Зависит от: python3(psycopg2._psycopg) (< 0)

Пока писал, нашел виноватого:
libpq5 не устанавливался, потому что остался libpq5.9 от p8, помогло:
apt-get install libpq5после чего старый пакет удалился, и после этого все остальное поставилось

Оффлайн berkut_174

  • Мастер
  • ***
  • Сообщений: 7 007
    • Email
Неоднократно с этим сталкиваюсь при переходе с p8 на p9.
Никак нельзя решить вопрос непосредственно при dist-upgrade ?
Сноси Винду, переходи на Линукс ! :)

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 18 637
    • Домашняя страница
    • Email
Нет.
Андрей Черепанов (cas@)