Страницы: [1] 2 3 ... 10

Последние сообщения

1
Вроде бы ясность проступила. Судя по всему - дело в особенностях zim'a:
Там в настройках внешней команды есть галочки для 1) команда не изменяет данные и 2) Вывод должен заменить текущий выбор
Почему-то галка на втором варианте подвешивает zim, а если ее не ставить переформатированный текст помещается в первичный буфер.
Внешняя команда нормально срабатывает только если галка на 1-м пункте. Поэтому потом приходится текст вручную вставлять клавиатурной комбинацией. Ну хоть уже что-то. И еще - я для удобства перенаправил вывод форматированного текста в clipboard:
xsel -o | sed 's/.*/\L&/' | xsel -b
2
по опыту разработчиков Rujel главное раздобыть ЭЦП которая работает не только под виндой  ;-)

дак вродеж летом обещали через браузер спутник :)
Не, там вроде отсоединенная ЭЦП на заявку нужна. И они на Mac хотели что бы работало. Но вроде как в Коломну пришлось ехать.
3
по опыту разработчиков Rujel главное раздобыть ЭЦП которая работает не только под виндой  ;-)

дак вродеж летом обещали через браузер спутник :)
4

А вообще это идея!
Поговорю с директором. Может получится внести.

Попробуйте!
Там интересная кухня должно быть.
5
Загрузчики (lilo,grub,syslinux) / Re: Удаление пакетов grub-customizer...
« Последний ответ от K0T Вчера в 20:13:32 »
тема не новая, уже было После установки Simply8.2 Grub2 оказался в "локальных/устаревших" пакетах

и в багзилле висит https://bugzilla.altlinux.org/show_bug.cgi?id=34239 и https://bugzilla.altlinux.org/show_bug.cgi?id=34246

можно ничего не делать, и так работает
можно самому вручную
apt-get install grub-pc alterator-grubможно до р9 дождаться, может там исправят ...
7
Загрузчики (lilo,grub,syslinux) / Re: Удаление пакетов grub-customizer...
« Последний ответ от Speccyfighter Вчера в 19:34:43 »
В альтах слишком вольное обращение с именами пакетов:
# apt-cache show alterator-grub | grep '^Pack\|^Vers\|^Dep'
Package: alterator-grub
Version: 0.12-alt1
Depends: alterator (>= 4.7-alt5), alterator-l10n (>= 2.9-alt10), alterator-sh-functions (>= 0.6-alt1), alterator-hw-functions (>= 0.7.6-alt1), grub-pc (> 2.00-alt20), /bin/sh, /etc/sysconfig/i18n, /lib/ld-linux.so.2, coreutils, grep, grub-common, libc.so.6(GLIBC_2.0), libc.so.6(GLIBC_2.3.4), libdevmapper.so.1.00 (>= set:mioP51z8VRAJU7z51BVl02aaHDe4), libdevmapper.so.1.00(Base), libshell, rtld(GNU_HASH), sed
Package: alterator-grub
Version: 0.11-alt1
Depends: alterator (>= 4.7-alt5), alterator-l10n (>= 2.9-alt10), alterator-sh-functions (>= 0.6-alt1), alterator-hw-functions (>= 0.7.6-alt1), grub2-pc (> 2.00-alt20), /bin/sh, /etc/sysconfig/i18n, /lib/ld-linux.so.2, coreutils, grep, grub2-common, libc.so.6(GLIBC_2.0), libc.so.6(GLIBC_2.3.4), libdevmapper.so.1.00 (>= set:mioP51z8VRAJU7z51BVl02aaHDe4), libdevmapper.so.1.00(Base), libshell, rtld(GNU_HASH), sed
# apt-cache show grub-pc grub2-pc | grep '^Pack\|^Vers\|^Dep'
Package: grub-pc
Version: 2.02-alt2.M80P.1
Depends: grub-common (= 2.02-alt2.M80P.1), /usr/lib/rpm, rpmlib(PosttransFiletriggers)
Package: grub2-pc
Version: 2.00-alt21
Depends: grub2-common (= 2.00-alt21), /usr/lib/rpm, rpmlib(PosttransFiletriggers)
# apt-cache depends alterator-grub | head -n6
alterator-grub-0.12-alt1
  Требует: alterator >= 4.7-alt5
  Требует: alterator-l10n >= 2.9-alt10
  Требует: alterator-sh-functions >= 0.6-alt1
  Требует: alterator-hw-functions >= 0.7.6-alt1
  Требует: grub-pc > 2.00-alt20
# apt-get reinstall alterator-grub -s
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Следующие дополнительные пакеты будут установлены:
  grub-common grub-pc
Следующие пакеты будут ОБНОВЛЕНЫ:
  alterator-grub
Следующие пакеты будут УДАЛЕНЫ:
  grub2-common grub2-pc
Следующие НОВЫЕ пакеты будут установлены:
  grub-common grub-pc
1 будет обновлено, 2 новых установлено, 2 пакетов будет удалено и 11 не будет обновлено.
Inst alterator-grub [0.11-alt1] (0.12-alt1 p8:1524499233/ALT Linux p8) []
Remv grub2-pc (2.00-alt21 ) []
Remv grub2-common (2.00-alt21 ) []
Inst grub-common (2.02-alt2.M80P.1 p8:1524499233/ALT Linux p8) []
Inst grub-pc (2.02-alt2.M80P.1 p8:1524499233/ALT Linux p8)
Conf grub-common (2.02-alt2.M80P.1 p8:1524499233/ALT Linux p8)
Conf grub-pc (2.02-alt2.M80P.1 p8:1524499233/ALT Linux p8)
Conf alterator-grub (0.12-alt1 p8:1524499233/ALT Linux p8)
8
Загрузчики (lilo,grub,syslinux) / Удаление пакетов grub-customizer...
« Последний ответ от San Вчера в 18:24:06 »
Последнее обновление (по моей хронологии) удалит следующие пакеты: alterator-grub grub-customizer grub2-pc
Чем это будет заменено?
9
У меня отрабатывает. Вопрос в том, ГДЕ Вы это запускаете
в редакторе zim есть в меню пункт внешние инструменты, т.е. можно либо командный файл выполнять, либо команду. В команде можно использовать следующие выражения:
%f исходный код страницы как временный файл
%d папка с вложениями текущей страницы
%s реальный исходный код страницы (если есть)
%п путь к блокноту (файл или каталог)
%D корневая папка документа (если есть)
%t выделенный текст или слово под курсором
%Т выделенный текст с wiki-форматированием
Командой менять регистр текста не получается.
10
Здравствуйте.
Может кто скомпилировать исходники из под Linux?
http://rus-linux.net/MyLDP/BOOKS/Linux-tools/GUI_01.html
и поделиться исполнимыми эльф-бинарниками?

Хочу поизучать простейшие GUI ELFs с помощью IDA под Windows. Но скомпилировать их нигде кроме Linux не могу (пробовал и в мингв и в онлайн компиляторах), все ругаются на нехватку некоторых includes. Из под самой Линукс программировать пока побаиваюсь, охота аккуратно пощупать из вне. Пока под виндой могу скомпилировать только консольный эльф файл - нет инклудников для линукс гуи библиотек. Плюс почитать про linux ABI - это одно, а подиссасемблить и потрогать код это другое.

В общем заранее спасибо.

Страницы: [1] 2 3 ... 10