Автор Тема: не работает fglrx на radeon 9550  (Прочитано 4206 раз)

Оффлайн yantux

  • Давно тут
  • **
  • Сообщений: 320
    • Простой калькулятор общего пользования.
не работает fglrx на radeon 9550
« : 22.02.2009 19:19:38 »
а конечно понимаю, что железо у меня тухлое, но работать же должно?

[root@localhost extensions]# [root@localhost ~]# cat Xorg.0.log

X.Org X Server 1.5.3
Release Date: 5 November 2008
X Protocol Version 11, Revision 0
Build Operating System: ALT Linux 5.0 OfficeServer (none) i686
Current Operating System: Linux localhost.localdomain 2.6.27-std-def-alt11 #1 SMP Thu Jan 29 07:46:04 UTC 2009 i686
Build Date: 20 February 2009  11:33:54AM

        Before reporting problems, check https://bugzilla.altlinux.org/
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun Feb 22 18:57:05 2009
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Minimal layout"
(**) |-->Screen "Screen0" (0)
(**) |   |-->Monitor "Philips 170S|0"
(**) |   |-->Device "Card0|0"
(**) |-->Input Device "Keyboard0"
(**) |-->Input Device "ImPS/2 Generic Wheel Mouse|0"
(**) Option "AllowMouseOpenFail" "true"
(==) Not automatically adding devices
(==) Automatically enabling devices
(==) No FontPath specified.  Using compiled-in default.
(==) FontPath set to:
        catalogue:/etc/X11/fontpath.d
(==) ModulePath set to "/usr/lib/X11/modules"
(II) Loader magic: 0x81c3a20
(II) Module ABI versions:
        X.Org ANSI C Emulation: 0.4
        X.Org Video Driver: 4.1
        X.Org XInput driver : 2.1
        X.Org Server Extension : 1.1
        X.Org Font Renderer : 0.6
(II) Loader running on linux
(++) using VT number 7

(--) PCI:*(0@1:0:0) ATI Technologies Inc RV350 AS [Radeon 9550] rev 0, Mem @ 0xd8000000/0, 0xe9000000/0, I/O @ 0x0000a000/0, BIOS @ 0x????????/131072
(--) PCI: (0@1:0:1) ATI Technologies Inc RV350 AS [Radeon 9550] (Secondary) rev 0, Mem @ 0xe0000000/0, 0xe9010000/0
(II) System resource ranges:
       
  • -1  0       0xffffffff - 0xffffffff (0x1) MX
  • [1] -1  0       0x000f0000 - 0x000fffff (0x10000) MX

        [2] -1  0       0x000c0000 - 0x000effff (0x30000) MX
        [3] -1  0       0x00000000 - 0x0009ffff (0xa0000) MX
        [4] -1  0       0x0000ffff - 0x0000ffff (0x1) IX
        [5] -1  0       0x00000000 - 0x00000000 (0x1) IX
(II) Executed /usr/libexec/X11/drv.d/fglrx
(II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
(II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
(II) "glx" will be loaded. This was enabled by default and also specified in the config file.
(II) "freetype" will be loaded. This was enabled by default and also specified in the config file.
(II) "dri" will be loaded. This was enabled by default and also specified in the config file.
(II) LoadModule: "freetype"

(II) Loading /usr/lib/X11/modules/fonts/libfreetype.so
(II) Module freetype: vendor="X.Org Foundation & the After X-TT Project"
        compiled for 1.5.3, module version = 2.1.0
        Module class: X.Org Font Renderer
        ABI class: X.Org Font Renderer, version 0.6
(II) Loading font FreeType
(II) LoadModule: "glx"

(II) Loading /usr/lib/X11/modules/extensions/libglx.so
dlopen: /usr/lib/X11/modules/extensions/libglx.so: cannot open shared object file: No such file or directory
(EE) Failed to load /usr/lib/X11/modules/extensions/libglx.so
(II) UnloadModule: "glx"
(EE) Failed to load module "glx" (loader failed, 7)
(II) LoadModule: "dri"

(II) Loading /usr/lib/X11/modules/extensions/libdri.so
(II) Module dri: vendor="X.Org Foundation"
        compiled for 1.5.3, module version = 1.0.0
        ABI class: X.Org Server Extension, version 1.1
(II) Loading extension XFree86-DRI
(II) LoadModule: "dbe"

(II) Loading /usr/lib/X11/modules/extensions/libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
        compiled for 1.5.3, module version = 1.0.0
        Module class: X.Org Server Extension
        ABI class: X.Org Server Extension, version 1.1
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "extmod"

(II) Loading /usr/lib/X11/modules/extensions/libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
        compiled for 1.5.3, module version = 1.0.0
        Module class: X.Org Server Extension
        ABI class: X.Org Server Extension, version 1.1
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension DPMS
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "fglrx"

(II) Loading /usr/lib/X11/modules/drivers/fglrx_drv.so
dlopen: /usr/lib/X11/modules/drivers/fglrx_drv.so: undefined symbol: miZeroLineScreenIndex
(EE) Failed to load /usr/lib/X11/modules/drivers/fglrx_drv.so
(II) UnloadModule: "fglrx"
(EE) Failed to load module "fglrx" (loader failed, 7)
(II) LoadModule: "kbd"

(II) Loading /usr/lib/X11/modules/input/kbd_drv.so
(II) Module kbd: vendor="X.Org Foundation"
        compiled for 1.5.3, module version = 1.3.1
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 2.1
(II) LoadModule: "mouse"

(II) Loading /usr/lib/X11/modules/input/mouse_drv.so
(II) Module mouse: vendor="X.Org Foundation"
        compiled for 1.5.3, module version = 1.4.0
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 2.1
(EE) No drivers available.

Fatal server error:
no screens found

[root@localhost extensions]# pwd
/usr/lib/X11/modules/extensions
[root@localhost extensions]# ls -lt
итого 144
lrwxrwxrwx 1 root root     36 Фев 22 13:19 libdri.so -> ../../../../../etc/X11/lib/libdri.so
lrwxrwxrwx 1 root root     36 Фев 22 13:19 libglx.so -> ../../../../../etc/X11/lib/libglx.so
-rw-r--r-- 1 root root  17876 Фев 20 14:40 libdbe.so
-rw-r--r-- 1 root root 125456 Фев 20 14:40 libextmod.so
[root@localhost extensions]#   

С уважением,
yantux.

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 559
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Re: не работает fglrx на radeon 9550
« Ответ #1 : 22.02.2009 19:22:03 »
У вас ругань идёт, что не найден fglrx лрайвер

Оффлайн nik

  • Давно тут
  • **
  • Сообщений: 506
  • PuppyRus Linux & ALT Linux
Re: не работает fglrx на radeon 9550
« Ответ #2 : 22.02.2009 21:37:51 »
попробуйте
modprobe agpgart затем
modprobe fglrx
пробуйте перезагрузить иксы.

Оффлайн yantux

  • Давно тут
  • **
  • Сообщений: 320
    • Простой калькулятор общего пользования.
Re: не работает fglrx на radeon 9550
« Ответ #3 : 22.02.2009 22:11:42 »
попробуйте
modprobe agpgart затем
modprobe fglrx
пробуйте перезагрузить иксы.

Попробую, но сомневаюсь:

[root@localhost ~]# lsmod | grep agp
via_agp                12032  1
agpgart                37192  2 via_agp,fglrx

[root@localhost ~]#
[root@localhost ~]# lsmod | grep fgl
fglrx                1791040  0
agpgart                37192  2 via_agp,fglrx
[root@localhost ~]#                     
С уважением,
yantux.

Оффлайн nik

  • Давно тут
  • **
  • Сообщений: 506
  • PuppyRus Linux & ALT Linux
Re: не работает fglrx на radeon 9550
« Ответ #4 : 22.02.2009 22:17:10 »
тогда не поможет
а файл на месте
/usr/lib/X11/modules/drivers/fglrx_drv.so
« Последнее редактирование: 22.02.2009 22:46:55 от nik »

Оффлайн yantux

  • Давно тут
  • **
  • Сообщений: 320
    • Простой калькулятор общего пользования.
Re: не работает fglrx на radeon 9550
« Ответ #5 : 22.02.2009 23:00:54 »
тогда не поможет
а файл на месте
/usr/lib/X11/modules/drivers/fglrx_drv.so

Выше я написал:
[root@localhost extensions]# pwd
/usr/lib/X11/modules/extensions
[root@localhost extensions]# ls -lt
итого 144
lrwxrwxrwx 1 root root     36 Фев 22 13:19 libdri.so -> ../../../../../etc/X11/lib/libdri.so
lrwxrwxrwx 1 root root     36 Фев 22 13:19 libglx.so -> ../../../../../etc/X11/lib/libglx.so
-rw-r--r-- 1 root root  17876 Фев 20 14:40 libdbe.so
-rw-r--r-- 1 root root 125456 Фев 20 14:40 libextmod.so
[root@localhost extensions]#   
С уважением,
yantux.

Оффлайн yantux

  • Давно тут
  • **
  • Сообщений: 320
    • Простой калькулятор общего пользования.
Re: не работает fglrx на radeon 9550
« Ответ #6 : 22.02.2009 23:01:19 »
попробуйте
modprobe agpgart затем
modprobe fglrx
пробуйте перезагрузить иксы.

Не помогло.
С уважением,
yantux.

Оффлайн yantux

  • Давно тут
  • **
  • Сообщений: 320
    • Простой калькулятор общего пользования.
Re: не работает fglrx на radeon 9550
« Ответ #7 : 22.02.2009 23:04:37 »
Меня смущают два момента:
1. /usr/lib/X11/modules/extensions/libglx.so - существует, как проверял см конец первого поста
2. miZeroLineScreenIndex - файл с этой функции не существует
С уважением,
yantux.

Drool

  • Гость
Re: не работает fglrx на radeon 9550
« Ответ #8 : 23.02.2009 09:31:44 »
Я могу ошибаться, но Radeon 9550 разве поддерживается нынешней версией fglrx? Или это не тот 9550, который появился на свет лет 5-6 назад, AGP?

Оффлайн nik

  • Давно тут
  • **
  • Сообщений: 506
  • PuppyRus Linux & ALT Linux
Re: не работает fglrx на radeon 9550
« Ответ #9 : 23.02.2009 09:56:20 »
Цитировать
Я могу ошибаться, но Radeon 9550 разве поддерживается нынешней версией fglrx?
Скорей всего в этом причина и есть.
Цитировать
Поддерживаемые чипы:

FireGL

ATI FireGL™ V8650
ATI FireGL™ V3300
ATI FireGL™ V8600
ATI FireGL™ V3200
ATI FireGL™ V7700
ATI FireGL™ V3100
ATI FireGL™ V7600
ATI FireGL™ X3-256
ATI FireGL™ V7350
ATI FireGL™ X3
ATI FireGL™ V7300
ATI FireGL™ V5000
ATI FireGL™ V7200
ATI FireGL™ X2-256
ATI FireGL™ V7100
ATI FireGL™ Z1-128
ATI FireGL™ V5600
ATI FireGL™ T2-128
ATI FireGL™ V5200
ATI FireGL™ X1-128
ATI FireGL™ V5100
ATI FireGL™ X1-256p
ATI FireGL™ V5000
ATI FireMV™ 2200 (Single card PCI-e configuration)
ATI FireGL™ V3600
ATI Mobility™ FireGL™ V5000
ATI FireGL™ V3400
ATI Mobility™ FireGL™ T2


Mobility Radeon

ATI Mobility™ Radeon™ X1800
ATI Mobility™ Radeon™ X600
ATI Mobility™ Radeon™ X1600
ATI Mobility™ Radeon™ X300
ATI Mobility™ Radeon™ X1400
ATI Mobility™ Radeon™ X200
ATI Mobility™ Radeon™ X1300
ATI Mobility™ Radeon™ 9800
ATI Mobility™ Radeon™ X1200
ATI Mobility™ Radeon™ 9600
ATI Mobility™ Radeon™ X1100
ATI Mobility™ Radeon™ 9550
ATI Mobility™ Radeon™ X800
ATI Mobility™ Radeon™ 9500
ATI Mobility™ Radeon™ X700
ATI Mobility™ Radeon™ Xpress 1100 series
ATI Mobility™ Radeon™ Xpress 1200 series
ATI Mobility™ Radeon™ Xpress 200 series


Radeon

ATI Radeon™ HD 3800 series
ATI Radeon™ X800 series
ATI Radeon™ HD 3600 series
ATI Radeon™ X700 series
ATI Radeon™ HD 3400 series
ATI Radeon™ Xpress1200 series
ATI Radeon™ HD 3200 series
ATI Radeon™ Xpress 200 series
ATI Radeon™ HD 3100 series
ATI Radeon™ X600 series
ATI Radeon™ HD 2900 series
ATI Radeon™ X550/X300 series
ATI Radeon™ HD 2400 series
ATI Radeon™ 9800 series
ATI Radeon™ HD 2600 series
ATI Radeon™ 9700 series
ATI Radeon™ X1900 series
ATI Radeon™ 9600 series
ATI Radeon™ X1800 series
ATI Radeon™ 9550 series
ATI Radeon™ X1600 series
ATI Radeon™ 9500 series
ATI Radeon™ X1300 series
ATI Radeon™ Xpress 1100 series
ATI Radeon™ X850 series

Drool

  • Гость
Re: не работает fglrx на radeon 9550
« Ответ #10 : 23.02.2009 10:04:56 »
Radeon
ATI Radeon™ 9550 series

Драйвер radeon пробовали?

Оффлайн yantux

  • Давно тут
  • **
  • Сообщений: 320
    • Простой калькулятор общего пользования.
Re: не работает fglrx на radeon 9550
« Ответ #11 : 23.02.2009 20:01:16 »

Драйвер radeon пробовали?

Пробовал, но с драйверами ati, radeon у меня падает лиса:
http://forum.altlinux.org/index.php/topic,2203.0.html
поэтому пытаюсь использовать fgrlx, но видимо не судьба... чипсет rv350 видимо не поддерживается?
С уважением,
yantux.

Drool

  • Гость
Re: не работает fglrx на radeon 9550
« Ответ #12 : 23.02.2009 21:13:51 »
Пробовал, но с драйверами ati, radeon у меня падает лиса:
http://forum.altlinux.org/index.php/topic,2203.0.html
поэтому пытаюсь использовать fgrlx, но видимо не судьба... чипсет rv350 видимо не поддерживается?

Вариантов два - 1) не использовать это кривое угробище forefox; 2) сменить видяху на какой-нить GF4MX440, как сделал я.
« Последнее редактирование: 23.02.2009 21:17:39 от Drool »