Голосование

У Вас работает звук в P7 на тв-тюнере?

Да
Нет
Не пробовал(а)
Да, но не в P7
Елеле, что-то там похрипывает

Автор Тема: Не работает звук в ТВ-тюнере на P7  (Прочитано 1973 раз)

Оффлайн МИНЗДРАВ

  • Модератор раздела
  • ****
  • Сообщений: 3 369
  • ALKD7 х64 Branch sysd & server-light_1.9.3sysV noX
    • http://lines.net.ua/11/10_4/6_1226440800_20847_1_1_1_2_2_1_1.jpeg
На всех платформах тв-тюнеры подымают по следющему универсальному алгоритму:
Выкладываю настроки, если они нужны ... В папке /etc/modprobe.d/ создал файл tuner. В файл /etc/modules прописал модуль см. файл. Использовал программу kdetv настраивал на уличную антенну, а не на кабельную. Частоты могут отличаться. Сделал экспорт настроек см. файл R_kanaly.xml. Проводок со звуковой карты в тв-тюнер воткнут. Без него звук не шел. Не экспериментировал. Конфиг кнопок пульта (самое необходимое на мой взгляд) см. файл lircd.conf. Заменить в /etc/lircd.conf. Вот, пожалуй и все, что я могу передать в конфигах...
Редактировать сообщение
* tuner.txt (0.3 кБ - загружено 124 раз.)
* modules.txt (0.25 кБ - загружено 112 раз.)
* R_Kanaly.xml.txt (7.11 кБ - загружено 82 раз.)
* lircd.conf.txt (0.43 кБ - загружено 72 раз.)

А вот при очередном обновлении, почему-то звук не работает. И не знаю в какую сторону копать?

Иам-же была байка, что этот твтюнер вообще на пятой платформе не пахал, потому-что была какая-то бага.

Как легче всего работоспособность настроить?

Оффлайн МИНЗДРАВ

  • Модератор раздела
  • ****
  • Сообщений: 3 369
  • ALKD7 х64 Branch sysd & server-light_1.9.3sysV noX
    • http://lines.net.ua/11/10_4/6_1226440800_20847_1_1_1_2_2_1_1.jpeg
Re: Не работает звук в ТВ-тюнере на P7
« Ответ #1 : 12.07.2013 20:32:59 »
большинство проблем, после обновления была с правами в etc/group
может и тут, тв-тюнеру каких прав не хватает? В какие группы он должен входить?

Оффлайн МИНЗДРАВ

  • Модератор раздела
  • ****
  • Сообщений: 3 369
  • ALKD7 х64 Branch sysd & server-light_1.9.3sysV noX
    • http://lines.net.ua/11/10_4/6_1226440800_20847_1_1_1_2_2_1_1.jpeg
Re: Не работает звук в ТВ-тюнере на P7
« Ответ #2 : 29.03.2014 20:27:53 »
Ну как звук починить?
Уже почти год телевизор в linux не работает.

С правами всё нормально. пульсу удалил. потом опять поставил. Ну не может быть, чтоб раньше работало, а теперь нет!

То, что в linux, хоть раз заработало, должно работать вечно (с) мифы о линуксе

Оффлайн МИНЗДРАВ

  • Модератор раздела
  • ****
  • Сообщений: 3 369
  • ALKD7 х64 Branch sysd & server-light_1.9.3sysV noX
    • http://lines.net.ua/11/10_4/6_1226440800_20847_1_1_1_2_2_1_1.jpeg
Re: Не работает звук в ТВ-тюнере на P7
« Ответ #3 : 13.04.2014 22:19:56 »
Ну вот, в очередной раз, вроде успешно обновился, а звук в телевизоре так и не появился.
Ведь логично-же предположить, что если он пропал после обновления, то и появиться должен тоже после обновления?

Оффлайн МИНЗДРАВ

  • Модератор раздела
  • ****
  • Сообщений: 3 369
  • ALKD7 х64 Branch sysd & server-light_1.9.3sysV noX
    • http://lines.net.ua/11/10_4/6_1226440800_20847_1_1_1_2_2_1_1.jpeg
Re: Не работает звук в ТВ-тюнере на P7
« Ответ #4 : 13.04.2014 22:21:37 »
P.S. systemd сносил, потом опять ставил - всё-равно звука нету. (вернее есть, очень тихий хрипящий, на максимально выставленных настройках)

Оффлайн МИНЗДРАВ

  • Модератор раздела
  • ****
  • Сообщений: 3 369
  • ALKD7 х64 Branch sysd & server-light_1.9.3sysV noX
    • http://lines.net.ua/11/10_4/6_1226440800_20847_1_1_1_2_2_1_1.jpeg
Re: Не работает звук в ТВ-тюнере на P7
« Ответ #5 : 26.04.2014 23:31:17 »
Симптомы: звук работает только со старыми версиями alsa-driver <= 1.0.15. Все последующие версии либо вообще не выдают звука, либо выдают очень тихий, шипящий и щёлкающий звук (слышно если выкрутить все регуляторы на максимум и хорошо прислушаться). Манипуляции с параметрами модуля snd-hda-intel (model, position_fix, enable_msi, probe_mask) не помогают.

Причина: эти модели используют один и тот же выход для вывода и аналогового, и цифрового сигнала (S/PDIF). По идее, драйвер должен сам определять, какое оборудование подключено к устройству, и в зависимости от этого выдавать либо аналоговый, либо цифровой сигнал. Но по какой-то причине это перестало работать начиная с alsa-driver 1.0.16.
Есть надежда, что в следующей версии ядра, эта бага исправится?

vano

  • Гость
Re: Не работает звук в ТВ-тюнере на P7
« Ответ #6 : 11.06.2014 06:07:13 »
Ведь логично-же предположить, что если он пропал после обновления, то и появиться должен тоже после обновления?
Или при откате.

Оффлайн МИНЗДРАВ

  • Модератор раздела
  • ****
  • Сообщений: 3 369
  • ALKD7 х64 Branch sysd & server-light_1.9.3sysV noX
    • http://lines.net.ua/11/10_4/6_1226440800_20847_1_1_1_2_2_1_1.jpeg